1f35f805c2
Mon Aug 14 2000 Jeff Johnson <jbj@redhat.com> - remove utilities that expect /etc/inetd.conf (#16059). Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com> - security hardening (#11881). Wed Jul 12 2000 Prospector <bugzilla@redhat.com> - automatic rebuild Tue Jun 06 2000 Jeff Johnson <jbj@redhat.com> - FHS packaging. Tue May 16 2000 Chris Evans <chris@ferret.lmh.ox.ac.uk> - Make tcpd mode -rwx--x--x as a security hardening measure Mon Feb 07 2000 Jeff Johnson <jbj@redhat.com> - compress man pages. Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com> - add netgroup support (#3940). Wed May 26 1999 Jeff Johnson <jbj@redhat.com> - compile on sparc with -fPIC. Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> - auto rebuild in the new build environment (release 7) Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com> - build for glibc 2.1 Sat Aug 22 1998 Jeff Johnson <jbj@redhat.com> - close setenv bug (problem #690) - spec file cleanup Thu Jun 25 1998 Alan Cox <alan@redhat.com> - Erp where did the Dec 05 patch escape to Thu May 07 1998 Prospector System <bugs@redhat.com> - translations modified for de, fr, tr Fri Dec 05 1997 Erik Troan <ewt@redhat.com> - don't build setenv.o module -- it just breaks things Wed Oct 29 1997 Marc Ewing <marc@redhat.com> - upgrade to 7.6 Thu Jul 17 1997 Erik Troan <ewt@redhat.com> - built against glibc Mon Mar 03 1997 Erik Troan <ewt@redhat.com> - Upgraded to version 7.5 - Uses a build root
94 lines
3.2 KiB
Diff
94 lines
3.2 KiB
Diff
--- tcp_wrappers_7.4/Makefile.orig Mon Mar 25 13:22:25 1996
|
|
+++ tcp_wrappers_7.4/Makefile Fri Aug 9 17:31:01 1996
|
|
@@ -43,7 +43,7 @@
|
|
#REAL_DAEMON_DIR=/usr/etc
|
|
#
|
|
# SysV.4 Solaris 2.x OSF AIX
|
|
-#REAL_DAEMON_DIR=/usr/sbin
|
|
+REAL_DAEMON_DIR=/usr/sbin
|
|
#
|
|
# BSD 4.4
|
|
#REAL_DAEMON_DIR=/usr/libexec
|
|
@@ -143,7 +143,7 @@
|
|
linux:
|
|
@make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
|
|
LIBS= RANLIB=ranlib ARFLAGS=rv AUX_OBJ=setenv.o \
|
|
- NETGROUP= TLI= EXTRA_CFLAGS="-DBROKEN_SO_LINGER" all
|
|
+ NETGROUP= TLI= EXTRA_CFLAGS="$(RPM_OPT_FLAGS) -DSYS_ERRLIST_DEFINED -DBROKEN_SO_LINGER" all
|
|
|
|
# This is good for many SYSV+BSD hybrids with NIS, probably also for HP-UX 7.x.
|
|
hpux hpux8 hpux9:
|
|
@@ -461,7 +461,7 @@
|
|
# Uncomment the next definition to turn on the language extensions
|
|
# (examples: allow, deny, banners, twist and spawn).
|
|
#
|
|
-#STYLE = -DPROCESS_OPTIONS # Enable language extensions.
|
|
+STYLE = -DPROCESS_OPTIONS # Enable language extensions.
|
|
|
|
################################################################
|
|
# Optional: Changing the default disposition of logfile records
|
|
@@ -484,7 +484,8 @@
|
|
#
|
|
# The LOG_XXX names below are taken from the /usr/include/syslog.h file.
|
|
|
|
-FACILITY= LOG_MAIL # LOG_MAIL is what most sendmail daemons use
|
|
+#FACILITY= LOG_MAIL # LOG_MAIL is what most sendmail daemons use
|
|
+FACILITY= LOG_AUTHPRIV # LOG_AUTHPRIV is more appropriate for RH 2.0
|
|
|
|
# The syslog priority at which successful connections are logged.
|
|
|
|
@@ -500,7 +501,7 @@
|
|
# off by default because it causes problems on sites that don't use DNS
|
|
# and with Solaris < 2.4.
|
|
#
|
|
-# DOT= -DAPPEND_DOT
|
|
+DOT= -DAPPEND_DOT
|
|
|
|
##################################################
|
|
# Optional: Always attempt remote username lookups
|
|
@@ -520,7 +521,7 @@
|
|
# still do selective username lookups as documented in the hosts_access.5
|
|
# and hosts_options.5 manual pages (`nroff -man' format).
|
|
#
|
|
-#AUTH = -DALWAYS_RFC931
|
|
+AUTH = #-DALWAYS_RFC931
|
|
#
|
|
# The default username lookup timeout is 10 seconds. This may not be long
|
|
# enough for slow hosts or networks, but is enough to irritate PC users.
|
|
@@ -579,7 +580,7 @@
|
|
# Paranoid mode implies hostname lookup. In order to disable hostname
|
|
# lookups altogether, see the next section.
|
|
|
|
-PARANOID= -DPARANOID
|
|
+PARANOID= #-DPARANOID
|
|
|
|
########################################
|
|
# Optional: turning off hostname lookups
|
|
@@ -592,7 +593,7 @@
|
|
# In order to perform selective hostname lookups, disable paranoid
|
|
# mode (see previous section) and comment out the following definition.
|
|
|
|
-HOSTNAME= -DALWAYS_HOSTNAME
|
|
+HOSTNAME= #-DALWAYS_HOSTNAME
|
|
|
|
#############################################
|
|
# Optional: Turning on host ADDRESS checking
|
|
@@ -617,7 +618,7 @@
|
|
#
|
|
# Uncomment the following macro definition if your getsockopt() is OK.
|
|
#
|
|
-# KILL_OPT= -DKILL_IP_OPTIONS
|
|
+KILL_OPT= -DKILL_IP_OPTIONS
|
|
|
|
## End configuration options
|
|
############################
|
|
@@ -627,7 +628,7 @@
|
|
SHELL = /bin/sh
|
|
.c.o:; $(CC) $(CFLAGS) -c $*.c
|
|
|
|
-CFLAGS = -O -DFACILITY=$(FACILITY) $(ACCESS) $(PARANOID) $(NETGROUP) \
|
|
+CFLAGS = -DFACILITY=$(FACILITY) $(ACCESS) $(PARANOID) $(NETGROUP) \
|
|
$(BUGS) $(SYSTYPE) $(AUTH) $(UMASK) \
|
|
-DREAL_DAEMON_DIR=\"$(REAL_DAEMON_DIR)\" $(STYLE) $(KILL_OPT) \
|
|
-DSEVERITY=$(SEVERITY) -DRFC931_TIMEOUT=$(RFC931_TIMEOUT) \
|