95 lines
3.7 KiB
Diff
95 lines
3.7 KiB
Diff
diff -up tcp_wrappers_7.6/Makefile.patch1 tcp_wrappers_7.6/Makefile
|
|
--- tcp_wrappers_7.6/Makefile.patch1 1997-03-21 19:27:21.000000000 +0100
|
|
+++ tcp_wrappers_7.6/Makefile 2008-08-29 09:45:12.000000000 +0200
|
|
@@ -44,7 +44,7 @@ what:
|
|
#REAL_DAEMON_DIR=/usr/etc
|
|
#
|
|
# SysV.4 Solaris 2.x OSF AIX
|
|
-#REAL_DAEMON_DIR=/usr/sbin
|
|
+REAL_DAEMON_DIR=/usr/sbin
|
|
#
|
|
# BSD 4.4
|
|
#REAL_DAEMON_DIR=/usr/libexec
|
|
@@ -144,7 +144,7 @@ freebsd:
|
|
linux:
|
|
@make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
|
|
LIBS= RANLIB=ranlib ARFLAGS=rv AUX_OBJ=setenv.o \
|
|
- NETGROUP= TLI= EXTRA_CFLAGS="-DBROKEN_SO_LINGER" all
|
|
+ NETGROUP= TLI= EXTRA_CFLAGS="$(RPM_OPT_FLAGS) -DSYS_ERRLIST_DEFINED -DBROKEN_SO_LINGER" all
|
|
|
|
# This is good for many SYSV+BSD hybrids with NIS, probably also for HP-UX 7.x.
|
|
hpux hpux8 hpux9 hpux10:
|
|
@@ -491,7 +491,7 @@ VSYSLOG = -Dvsyslog=myvsyslog
|
|
# Uncomment the next definition to turn on the language extensions
|
|
# (examples: allow, deny, banners, twist and spawn).
|
|
#
|
|
-#STYLE = -DPROCESS_OPTIONS # Enable language extensions.
|
|
+STYLE = -DPROCESS_OPTIONS # Enable language extensions.
|
|
|
|
################################################################
|
|
# Optional: Changing the default disposition of logfile records
|
|
@@ -514,7 +514,8 @@ VSYSLOG = -Dvsyslog=myvsyslog
|
|
#
|
|
# The LOG_XXX names below are taken from the /usr/include/syslog.h file.
|
|
|
|
-FACILITY= LOG_MAIL # LOG_MAIL is what most sendmail daemons use
|
|
+#FACILITY= LOG_MAIL # LOG_MAIL is what most sendmail daemons use
|
|
+FACILITY= LOG_AUTHPRIV # LOG_AUTHPRIV is more appropriate for RH 2.0
|
|
|
|
# The syslog priority at which successful connections are logged.
|
|
|
|
@@ -531,7 +532,7 @@ SEVERITY= LOG_INFO # LOG_INFO is normall
|
|
# and with Solaris < 2.4. APPEND_DOT will not work with hostnames taken
|
|
# from /etc/hosts or from NIS maps. It does work with DNS through NIS.
|
|
#
|
|
-# DOT= -DAPPEND_DOT
|
|
+DOT= -DAPPEND_DOT
|
|
|
|
##################################################
|
|
# Optional: Always attempt remote username lookups
|
|
@@ -551,7 +552,7 @@ SEVERITY= LOG_INFO # LOG_INFO is normall
|
|
# still do selective username lookups as documented in the hosts_access.5
|
|
# and hosts_options.5 manual pages (`nroff -man' format).
|
|
#
|
|
-#AUTH = -DALWAYS_RFC931
|
|
+AUTH = #-DALWAYS_RFC931
|
|
#
|
|
# The default username lookup timeout is 10 seconds. This may not be long
|
|
# enough for slow hosts or networks, but is enough to irritate PC users.
|
|
@@ -610,7 +611,7 @@ TABLES = -DHOSTS_DENY=\"/etc/hosts.deny\
|
|
# Paranoid mode implies hostname lookup. In order to disable hostname
|
|
# lookups altogether, see the next section.
|
|
|
|
-PARANOID= -DPARANOID
|
|
+PARANOID= #-DPARANOID
|
|
|
|
########################################
|
|
# Optional: turning off hostname lookups
|
|
@@ -623,7 +624,7 @@ PARANOID= -DPARANOID
|
|
# In order to perform selective hostname lookups, disable paranoid
|
|
# mode (see previous section) and comment out the following definition.
|
|
|
|
-HOSTNAME= -DALWAYS_HOSTNAME
|
|
+HOSTNAME= #-DALWAYS_HOSTNAME
|
|
|
|
#############################################
|
|
# Optional: Turning on host ADDRESS checking
|
|
@@ -649,7 +650,7 @@ HOSTNAME= -DALWAYS_HOSTNAME
|
|
# source-routed traffic in the kernel. Examples: 4.4BSD derivatives,
|
|
# Solaris 2.x, and Linux. See your system documentation for details.
|
|
#
|
|
-# KILL_OPT= -DKILL_IP_OPTIONS
|
|
+KILL_OPT= -DKILL_IP_OPTIONS
|
|
|
|
## End configuration options
|
|
############################
|
|
@@ -659,7 +660,7 @@ HOSTNAME= -DALWAYS_HOSTNAME
|
|
SHELL = /bin/sh
|
|
.c.o:; $(CC) $(CFLAGS) -c $*.c
|
|
|
|
-CFLAGS = -O -DFACILITY=$(FACILITY) $(ACCESS) $(PARANOID) $(NETGROUP) \
|
|
+CFLAGS = -DFACILITY=$(FACILITY) $(ACCESS) $(PARANOID) $(NETGROUP) \
|
|
$(BUGS) $(SYSTYPE) $(AUTH) $(UMASK) \
|
|
-DREAL_DAEMON_DIR=\"$(REAL_DAEMON_DIR)\" $(STYLE) $(KILL_OPT) \
|
|
-DSEVERITY=$(SEVERITY) -DRFC931_TIMEOUT=$(RFC931_TIMEOUT) \
|