13 lines
575 B
Diff
13 lines
575 B
Diff
diff -up tcp_wrappers_7.6/Makefile.relro tcp_wrappers_7.6/Makefile
|
|
--- tcp_wrappers_7.6/Makefile.relro 2011-08-10 03:33:25.457892277 +0200
|
|
+++ tcp_wrappers_7.6/Makefile 2011-08-10 03:33:39.565892352 +0200
|
|
@@ -726,7 +726,7 @@ $(LIB): $(LIB_OBJ)
|
|
-$(RANLIB) $(LIB)
|
|
|
|
$(SHLIB): $(LIB_OBJ)
|
|
- gcc -shared -fPIC -Wl,-soname -Wl,$(SHLIB).$(MAJOR) \
|
|
+ gcc -shared -fPIC -Wl,-z,relro -Wl,-soname -Wl,$(SHLIB).$(MAJOR) \
|
|
-o $(SHLIB).$(MAJOR).$(MINOR).$(REL) $^ $(LIBS)
|
|
ln -s $(SHLIB).$(MAJOR).$(MINOR).$(REL) $(SHLIB).$(MAJOR)
|
|
ln -s $(SHLIB).$(MAJOR).$(MINOR).$(REL) $(SHLIB)
|