257 lines
9.9 KiB
Diff
257 lines
9.9 KiB
Diff
diff -up tcp_wrappers_7.6/Makefile.patch11 tcp_wrappers_7.6/Makefile
|
|
--- tcp_wrappers_7.6/Makefile.patch11 2008-08-29 09:45:12.000000000 +0200
|
|
+++ tcp_wrappers_7.6/Makefile 2008-08-29 09:45:12.000000000 +0200
|
|
@@ -150,8 +150,8 @@ netbsd:
|
|
|
|
linux:
|
|
@make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
|
|
- LIBS="-lnsl" RANLIB=ranlib ARFLAGS=rv AUX_OBJ= \
|
|
- NETGROUP="-DNETGROUP" TLI= EXTRA_CFLAGS="$(RPM_OPT_FLAGS) -DSYS_ERRLIST_DEFINED -DBROKEN_SO_LINGER -DINET6=1 -Dss_family=__ss_family -Dss_len=__ss_len" all
|
|
+ LIBS="-lnsl" RANLIB=ranlib ARFLAGS=rv AUX_OBJ=weak_symbols.o \
|
|
+ NETGROUP="-DNETGROUP" TLI= EXTRA_CFLAGS="$(RPM_OPT_FLAGS) -fPIC -DPIC -D_REENTRANT -DSYS_ERRLIST_DEFINED -DBROKEN_SO_LINGER -DINET6=1 -Dss_family=__ss_family -Dss_len=__ss_len -DHAVE_WEAKSYMS" all
|
|
|
|
linux-old:
|
|
@make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
|
|
@@ -249,7 +249,7 @@ tandem:
|
|
|
|
# Amdahl UTS 2.1.5 (Richard.Richmond@bridge.bst.bls.com)
|
|
uts215:
|
|
- @make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
|
|
+ @make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
|
|
LIBS="-lsocket" RANLIB=echo \
|
|
ARFLAGS=rv AUX_OBJ=setenv.o NETGROUP=-DNO_NETGROUP TLI= all
|
|
|
|
@@ -706,8 +706,9 @@ KIT = README miscd.c tcpd.c fromhost.c h
|
|
scaffold.h tcpdmatch.8 README.NIS
|
|
|
|
LIB = libwrap.a
|
|
+SHLIB = libwrap.so
|
|
|
|
-all other: config-check tcpd tcpdmatch try-from safe_finger tcpdchk
|
|
+all other: config-check tcpd tcpdmatch try-from safe_finger tcpdchk $(SHLIB)
|
|
|
|
# Invalidate all object files when the compiler options (CFLAGS) have changed.
|
|
|
|
@@ -724,6 +725,12 @@ $(LIB): $(LIB_OBJ)
|
|
$(AR) $(ARFLAGS) $(LIB) $(LIB_OBJ)
|
|
-$(RANLIB) $(LIB)
|
|
|
|
+$(SHLIB): $(LIB_OBJ)
|
|
+ gcc -shared -fPIC -Wl,-soname -Wl,$(SHLIB).$(MAJOR) \
|
|
+ -o $(SHLIB).$(MAJOR).$(MINOR).$(REL) $^ $(LIBS)
|
|
+ ln -s $(SHLIB).$(MAJOR).$(MINOR).$(REL) $(SHLIB).$(MAJOR)
|
|
+ ln -s $(SHLIB).$(MAJOR).$(MINOR).$(REL) $(SHLIB)
|
|
+
|
|
tcpd: tcpd.o $(LIB)
|
|
$(CC) $(CFLAGS) -o $@ tcpd.o $(LIB) $(LIBS)
|
|
|
|
@@ -906,5 +913,6 @@ update.o: cflags
|
|
update.o: mystdarg.h
|
|
update.o: tcpd.h
|
|
vfprintf.o: cflags
|
|
+weak_symbols.o: tcpd.h
|
|
workarounds.o: cflags
|
|
workarounds.o: tcpd.h
|
|
diff -up tcp_wrappers_7.6/scaffold.c.patch11 tcp_wrappers_7.6/scaffold.c
|
|
--- tcp_wrappers_7.6/scaffold.c.patch11 2008-08-29 09:45:12.000000000 +0200
|
|
+++ tcp_wrappers_7.6/scaffold.c 2008-08-29 09:45:12.000000000 +0200
|
|
@@ -237,10 +237,17 @@ struct request_info *request;
|
|
|
|
/* ARGSUSED */
|
|
|
|
-void rfc931(request)
|
|
-struct request_info *request;
|
|
+void rfc931(rmt_sin, our_sin, dest)
|
|
+#ifndef INET6
|
|
+struct sockaddr_in *rmt_sin;
|
|
+struct sockaddr_in *our_sin;
|
|
+#else
|
|
+struct sockaddr *rmt_sin;
|
|
+struct sockaddr *our_sin;
|
|
+#endif
|
|
+char *dest;
|
|
{
|
|
- strcpy(request->user, unknown);
|
|
+ strcpy(dest, unknown);
|
|
}
|
|
|
|
/* check_path - examine accessibility */
|
|
diff -up tcp_wrappers_7.6/tcpd.h.patch11 tcp_wrappers_7.6/tcpd.h
|
|
--- tcp_wrappers_7.6/tcpd.h.patch11 2008-08-29 09:45:12.000000000 +0200
|
|
+++ tcp_wrappers_7.6/tcpd.h 2008-08-29 09:45:12.000000000 +0200
|
|
@@ -4,6 +4,25 @@
|
|
* Author: Wietse Venema, Eindhoven University of Technology, The Netherlands.
|
|
*/
|
|
|
|
+#ifndef _TCPWRAPPERS_TCPD_H
|
|
+#define _TCPWRAPPERS_TCPD_H
|
|
+
|
|
+/* someone else may have defined this */
|
|
+#undef __P
|
|
+
|
|
+/* use prototypes if we have an ANSI C compiler or are using C++ */
|
|
+#if defined(__STDC__) || defined(__cplusplus)
|
|
+#define __P(args) args
|
|
+#else
|
|
+#define __P(args) ()
|
|
+#endif
|
|
+
|
|
+/* Need definitions of struct sockaddr_in and FILE. */
|
|
+#include <netinet/in.h>
|
|
+#include <stdio.h>
|
|
+
|
|
+__BEGIN_DECLS
|
|
+
|
|
/* Structure to describe one communications endpoint. */
|
|
|
|
#define STRING_LENGTH 128 /* hosts, users, processes */
|
|
@@ -29,10 +48,10 @@ struct request_info {
|
|
char pid[10]; /* access via eval_pid(request) */
|
|
struct host_info client[1]; /* client endpoint info */
|
|
struct host_info server[1]; /* server endpoint info */
|
|
- void (*sink) (); /* datagram sink function or 0 */
|
|
- void (*hostname) (); /* address to printable hostname */
|
|
- void (*hostaddr) (); /* address to printable address */
|
|
- void (*cleanup) (); /* cleanup function or 0 */
|
|
+ void (*sink) __P((int)); /* datagram sink function or 0 */
|
|
+ void (*hostname) __P((struct host_info *)); /* address to printable hostname */
|
|
+ void (*hostaddr) __P((struct host_info *)); /* address to printable address */
|
|
+ void (*cleanup) __P((struct request_info *)); /* cleanup function or 0 */
|
|
struct netconfig *config; /* netdir handle */
|
|
};
|
|
|
|
@@ -65,25 +84,34 @@ extern char paranoid[];
|
|
/* Global functions. */
|
|
|
|
#if defined(TLI) || defined(PTX) || defined(TLI_SEQUENT)
|
|
-extern void fromhost(); /* get/validate client host info */
|
|
+extern void fromhost __P((struct request_info *)); /* get/validate client host info */
|
|
#else
|
|
#define fromhost sock_host /* no TLI support needed */
|
|
#endif
|
|
|
|
-extern int hosts_access(); /* access control */
|
|
-extern void shell_cmd(); /* execute shell command */
|
|
-extern char *percent_x(); /* do %<char> expansion */
|
|
-extern void rfc931(); /* client name from RFC 931 daemon */
|
|
-extern void clean_exit(); /* clean up and exit */
|
|
-extern void refuse(); /* clean up and exit */
|
|
-extern char *xgets(); /* fgets() on steroids */
|
|
-extern char *split_at(); /* strchr() and split */
|
|
-extern unsigned long dot_quad_addr(); /* restricted inet_addr() */
|
|
+extern void shell_cmd __P((char *)); /* execute shell command */
|
|
+extern char *percent_x __P((char *, int, char *, struct request_info *)); /* do %<char> expansion */
|
|
+#ifdef INET6
|
|
+extern void rfc931 __P((struct sockaddr *, struct sockaddr *, char *)); /* client name from RFC 931 daemon */
|
|
+#else
|
|
+extern void rfc931 __P((struct sockaddr_in *, struct sockaddr_in *, char *)); /* client name from RFC 931 daemon */
|
|
+#endif
|
|
+extern void clean_exit __P((struct request_info *)); /* clean up and exit */
|
|
+extern void refuse __P((struct request_info *)); /* clean up and exit */
|
|
+extern char *xgets __P((char *, int, FILE *)); /* fgets() on steroids */
|
|
+extern char *split_at __P((char *, int)); /* strchr() and split */
|
|
+extern unsigned long dot_quad_addr __P((char *)); /* restricted inet_addr() */
|
|
|
|
/* Global variables. */
|
|
|
|
+#ifdef HAVE_WEAKSYMS
|
|
+extern int allow_severity __attribute__ ((weak)); /* for connection logging */
|
|
+extern int deny_severity __attribute__ ((weak)); /* for connection logging */
|
|
+#else
|
|
extern int allow_severity; /* for connection logging */
|
|
extern int deny_severity; /* for connection logging */
|
|
+#endif
|
|
+
|
|
extern char *hosts_allow_table; /* for verification mode redirection */
|
|
extern char *hosts_deny_table; /* for verification mode redirection */
|
|
extern int hosts_access_verbose; /* for verbose matching mode */
|
|
@@ -96,9 +124,14 @@ extern int resident; /* > 0 if residen
|
|
*/
|
|
|
|
#ifdef __STDC__
|
|
+extern int hosts_access(struct request_info *request);
|
|
+extern int hosts_ctl(char *daemon, char *client_name, char *client_addr,
|
|
+ char *client_user);
|
|
extern struct request_info *request_init(struct request_info *,...);
|
|
extern struct request_info *request_set(struct request_info *,...);
|
|
#else
|
|
+extern int hosts_access();
|
|
+extern int hosts_ctl();
|
|
extern struct request_info *request_init(); /* initialize request */
|
|
extern struct request_info *request_set(); /* update request structure */
|
|
#endif
|
|
@@ -121,27 +154,31 @@ extern struct request_info *request_set(
|
|
* host_info structures serve as caches for the lookup results.
|
|
*/
|
|
|
|
-extern char *eval_user(); /* client user */
|
|
-extern char *eval_hostname(); /* printable hostname */
|
|
-extern char *eval_hostaddr(); /* printable host address */
|
|
-extern char *eval_hostinfo(); /* host name or address */
|
|
-extern char *eval_client(); /* whatever is available */
|
|
-extern char *eval_server(); /* whatever is available */
|
|
+extern char *eval_user __P((struct request_info *)); /* client user */
|
|
+extern char *eval_hostname __P((struct host_info *)); /* printable hostname */
|
|
+extern char *eval_hostaddr __P((struct host_info *)); /* printable host address */
|
|
+extern char *eval_hostinfo __P((struct host_info *)); /* host name or address */
|
|
+extern char *eval_client __P((struct request_info *)); /* whatever is available */
|
|
+extern char *eval_server __P((struct request_info *)); /* whatever is available */
|
|
#define eval_daemon(r) ((r)->daemon) /* daemon process name */
|
|
#define eval_pid(r) ((r)->pid) /* process id */
|
|
|
|
/* Socket-specific methods, including DNS hostname lookups. */
|
|
|
|
-extern void sock_host(); /* look up endpoint addresses */
|
|
-extern void sock_hostname(); /* translate address to hostname */
|
|
-extern void sock_hostaddr(); /* address to printable address */
|
|
+/* look up endpoint addresses */
|
|
+extern void sock_host __P((struct request_info *));
|
|
+/* translate address to hostname */
|
|
+extern void sock_hostname __P((struct host_info *));
|
|
+/* address to printable address */
|
|
+extern void sock_hostaddr __P((struct host_info *));
|
|
+
|
|
#define sock_methods(r) \
|
|
{ (r)->hostname = sock_hostname; (r)->hostaddr = sock_hostaddr; }
|
|
|
|
/* The System V Transport-Level Interface (TLI) interface. */
|
|
|
|
#if defined(TLI) || defined(PTX) || defined(TLI_SEQUENT)
|
|
-extern void tli_host(); /* look up endpoint addresses etc. */
|
|
+extern void tli_host __P((struct request_info *)); /* look up endpoint addresses etc. */
|
|
#endif
|
|
|
|
/*
|
|
@@ -182,7 +219,7 @@ extern struct tcpd_context tcpd_context;
|
|
* behavior.
|
|
*/
|
|
|
|
-extern void process_options(); /* execute options */
|
|
+extern void process_options __P((char *, struct request_info *)); /* execute options */
|
|
extern int dry_run; /* verification flag */
|
|
|
|
/* Bug workarounds. */
|
|
@@ -221,3 +258,7 @@ extern char *fix_strtok();
|
|
#define strtok my_strtok
|
|
extern char *my_strtok();
|
|
#endif
|
|
+
|
|
+__END_DECLS
|
|
+
|
|
+#endif /* tcpd.h */
|
|
diff -up /dev/null tcp_wrappers_7.6/weak_symbols.c
|
|
--- /dev/null 2008-08-29 10:35:15.589003986 +0200
|
|
+++ tcp_wrappers_7.6/weak_symbols.c 2008-08-29 09:45:12.000000000 +0200
|
|
@@ -0,0 +1,11 @@
|
|
+ /*
|
|
+ * @(#) weak_symbols.h 1.5 99/12/29 23:50
|
|
+ *
|
|
+ * Author: Anthony Towns <ajt@debian.org>
|
|
+ */
|
|
+
|
|
+#ifdef HAVE_WEAKSYMS
|
|
+#include <syslog.h>
|
|
+int deny_severity = LOG_WARNING;
|
|
+int allow_severity = SEVERITY;
|
|
+#endif
|