tcl/tcl-8.4.13-autoconf.patch

68 lines
1.9 KiB
Diff

--- tcl8.4.13/unix/configure.in.ac123 2006-04-19 17:39:42.000000000 -0400
+++ tcl8.4.13/unix/configure.in 2006-04-19 17:41:29.000000000 -0400
@@ -211,7 +211,7 @@
}], tcl_cv_strstr_unbroken=ok, tcl_cv_strstr_unbroken=broken,
tcl_cv_strstr_unbroken=broken)])
if test $tcl_cv_strstr_unbroken = broken; then
- LIBOBJS="$LIBOBJS strstr.o"
+ AC_LIBOBJ(strstr)
fi
fi
@@ -243,7 +243,7 @@
fi
fi
if test $tcl_ok = 0; then
- LIBOBJS="$LIBOBJS strtoul.o"
+ AC_LIBOBJ(strtoul)
fi
#--------------------------------------------------------------------
@@ -273,7 +273,7 @@
fi
fi
if test $tcl_ok = 0; then
- LIBOBJS="$LIBOBJS strtod.o"
+ AC_LIBOBJ(strtod)
fi
#--------------------------------------------------------------------
@@ -352,7 +352,7 @@
AC_CHECK_LIB(inet, strncasecmp, tcl_ok=1, tcl_ok=0)
fi
if test "$tcl_ok" = 0; then
- LIBOBJS="$LIBOBJS strncasecmp.o"
+ AC_LIBOBJ(strncasecmp)
fi
#--------------------------------------------------------------------
--- tcl8.4.13/unix/tcl.m4.ac123 2006-04-19 17:39:42.000000000 -0400
+++ tcl8.4.13/unix/tcl.m4 2006-04-19 17:40:31.000000000 -0400
@@ -1123,7 +1123,7 @@
# AIX v<=4.1 has some different flags than 4.2+
if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
- LIBOBJS="$LIBOBJS tclLoadAix.o"
+ AC_LIBOBJ(tclLoadAix)
DL_LIBS="-lld"
fi
@@ -1365,7 +1365,7 @@
# is kind of overkill but it works.
# Disable inlining only when one of the
# files in compat/*.c is being linked in.
- if test x"${LIBOBJS}" != x ; then
+ if test x"${LIB@&t@OBJS}" != x ; then
CFLAGS="$CFLAGS -fno-inline"
fi
@@ -2571,7 +2571,7 @@
}], tcl_cv_strtod_buggy=ok, tcl_cv_strtod_buggy=buggy,
tcl_cv_strtod_buggy=buggy)])
if test "$tcl_cv_strtod_buggy" = buggy; then
- LIBOBJS="$LIBOBJS fixstrtod.o"
+ AC_LIBOBJ(fixstrtod)
AC_DEFINE(strtod, fixstrtod)
fi
fi