tcl/tcl-confi.patch

102 lines
3.2 KiB
Diff

--- tcl8.4.15/unix/configure.in.confi 2007-05-24 22:40:13.000000000 +0200
+++ tcl8.4.15/unix/configure.in 2007-08-08 12:50:16.000000000 +0200
@@ -246,7 +246,7 @@
}], tcl_cv_strstr_unbroken=ok, tcl_cv_strstr_unbroken=broken,
tcl_cv_strstr_unbroken=broken)])
if test $tcl_cv_strstr_unbroken = broken; then
- LIBOBJS="$LIBOBJS strstr.o"
+ AC_LIBOBJ([strstr])
fi
fi
@@ -278,7 +278,7 @@
fi
fi
if test $tcl_ok = 0; then
- LIBOBJS="$LIBOBJS strtoul.o"
+ AC_LIBOBJ([strtoul])
fi
#--------------------------------------------------------------------
@@ -308,7 +308,7 @@
fi
fi
if test $tcl_ok = 0; then
- LIBOBJS="$LIBOBJS strtod.o"
+ AC_LIBOBJ([strtod])
fi
#--------------------------------------------------------------------
@@ -387,7 +387,7 @@
AC_CHECK_LIB(inet, strncasecmp, tcl_ok=1, tcl_ok=0)
fi
if test "$tcl_ok" = 0; then
- LIBOBJS="$LIBOBJS strncasecmp.o"
+ AC_LIBOBJ([strncasecmp])
fi
#--------------------------------------------------------------------
@@ -642,7 +642,7 @@
elif test "$prefix" != "$exec_prefix"; then
TCL_PACKAGE_PATH="${libdir} ${prefix}/lib"
else
- TCL_PACKAGE_PATH="${prefix}/lib"
+ TCL_PACKAGE_PATH="${libdir} ${prefix}/share ${prefix}/share/tcl8.4 ${libdir}/tcl8.4"
fi
#--------------------------------------------------------------------
--- tcl8.4.15/unix/tcl.m4.confi 2007-05-24 22:40:13.000000000 +0200
+++ tcl8.4.15/unix/tcl.m4 2007-08-09 07:51:59.000000000 +0200
@@ -1124,7 +1124,7 @@
# AIX v<=4.1 has some different flags than 4.2+
if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
- LIBOBJS="$LIBOBJS tclLoadAix.o"
+ AC_LIBOBJ([tclLoadAix])
DL_LIBS="-lld"
fi
@@ -1345,11 +1345,11 @@
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
+ SHLIB_LD='${CC} ${CFLAGS} -shared ${LDFLAGS} -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ CC_SEARCH_FLAGS=''
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
else
AC_CHECK_HEADER(dld.h, [
@@ -1381,7 +1381,7 @@
# is kind of overkill but it works.
# Disable inlining only when one of the
# files in compat/*.c is being linked in.
- if test x"${LIBOBJS}" != x ; then
+ if test x"${LIB@&t@OBJS}" != x ; then
CFLAGS="$CFLAGS -fno-inline"
fi
@@ -2633,7 +2633,7 @@
}], tcl_cv_strtod_buggy=ok, tcl_cv_strtod_buggy=buggy,
tcl_cv_strtod_buggy=buggy)])
if test "$tcl_cv_strtod_buggy" = buggy; then
- LIBOBJS="$LIBOBJS fixstrtod.o"
+ AC_LIBOBJ([fixstrtod])
AC_DEFINE(strtod, fixstrtod)
fi
fi
--- tcl8.4.15/unix/Makefile.in.confi 2007-05-24 22:40:13.000000000 +0200
+++ tcl8.4.15/unix/Makefile.in 2007-08-08 12:50:16.000000000 +0200
@@ -628,7 +628,7 @@
fi
@echo "Installing $(LIB_FILE) to $(LIB_INSTALL_DIR)/"
@@INSTALL_LIB@
- @chmod 555 $(LIB_INSTALL_DIR)/$(LIB_FILE)
+ @chmod 755 $(LIB_INSTALL_DIR)/$(LIB_FILE)
@if test "$(TCL_BUILD_EXP_FILE)" != ""; then \
echo "Installing $(TCL_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
$(INSTALL_DATA) $(TCL_BUILD_EXP_FILE) \