New version

- Defuzzified patches
This commit is contained in:
Jaroslav Škarvada 2014-04-24 12:06:48 +02:00
parent 313b5e976d
commit ff87f7145d
4 changed files with 24 additions and 29 deletions

View File

@ -1,8 +1,8 @@
diff --git a/library/auto.tcl b/library/auto.tcl
index 4bd860d..edc09ee 100644
index 02edcc4..cd3b587 100644
--- a/library/auto.tcl
+++ b/library/auto.tcl
@@ -80,6 +80,13 @@ proc tcl_findLibrary {basename version patch initScript enVarName varName} {
@@ -81,6 +81,13 @@ proc tcl_findLibrary {basename version patch initScript enVarName varName} {
lappend dirs [::${basename}::pkgconfig get scriptdir,runtime]
}
@ -17,10 +17,10 @@ index 4bd860d..edc09ee 100644
# Tcl library as well as allowing loading of libraries added to the
# auto_path that is not relative to the core library or binary paths.
diff --git a/library/init.tcl b/library/init.tcl
index e836df9..2ebded6 100644
index 1ca6413..1aba664 100644
--- a/library/init.tcl
+++ b/library/init.tcl
@@ -46,16 +46,11 @@ if {![info exists auto_path]} {
@@ -47,16 +47,11 @@ if {![info exists auto_path]} {
}
namespace eval tcl {
variable Dir
@ -39,7 +39,7 @@ index e836df9..2ebded6 100644
foreach Dir $::tcl_pkgPath {
if {$Dir ni $::auto_path} {
diff --git a/unix/configure.in b/unix/configure.in
index 087bb05..7b9025c 100755
index 61ad30f..8b327c4 100755
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -883,9 +883,9 @@ if test "$FRAMEWORK_BUILD" = "1" ; then

View File

@ -1,8 +1,8 @@
diff --git a/unix/tcl.m4 b/unix/tcl.m4
index b13fddd..0797893 100644
index 194cf90..76773f3 100644
--- a/unix/tcl.m4
+++ b/unix/tcl.m4
@@ -1408,12 +1408,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
@@ -1415,12 +1415,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
# get rid of the warnings.
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
@ -17,12 +17,3 @@ index b13fddd..0797893 100644
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
AS_IF([test "`uname -m`" = "alpha"], [CFLAGS="$CFLAGS -mieee"])
AS_IF([test $do64bit = yes], [
@@ -1440,7 +1440,7 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
SHLIB_CFLAGS="-fPIC"
SHLIB_SUFFIX=".so"
- SHLIB_LD='${CC} -shared'
+ SHLIB_LD='${CC} ${CFLAGS} -shared -fPIC'
DL_OBJS=""
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"

View File

@ -1,8 +1,8 @@
diff --git a/generic/tclInt.h b/generic/tclInt.h
index 1d04c82..3127024 100644
index 380284f..7bb5eb9 100644
--- a/generic/tclInt.h
+++ b/generic/tclInt.h
@@ -3232,7 +3232,7 @@ MODULE_SCOPE void TclClockInit(Tcl_Interp *interp);
@@ -3160,7 +3160,7 @@ MODULE_SCOPE void TclClockInit(Tcl_Interp *interp);
MODULE_SCOPE int TclClockOldscanObjCmd(
ClientData clientData, Tcl_Interp *interp,
int objc, Tcl_Obj *const objv[]);
@ -11,7 +11,7 @@ index 1d04c82..3127024 100644
Tcl_Interp *interp, int objc,
Tcl_Obj *const objv[]);
MODULE_SCOPE int Tcl_ConcatObjCmd(ClientData clientData,
@@ -3415,7 +3415,7 @@ MODULE_SCOPE int Tcl_RenameObjCmd(ClientData clientData,
@@ -3343,7 +3343,7 @@ MODULE_SCOPE int Tcl_RenameObjCmd(ClientData clientData,
MODULE_SCOPE int Tcl_RepresentationCmd(ClientData clientData,
Tcl_Interp *interp, int objc,
Tcl_Obj *const objv[]);
@ -21,15 +21,15 @@ index 1d04c82..3127024 100644
Tcl_Obj *const objv[]);
MODULE_SCOPE int Tcl_ScanObjCmd(ClientData clientData,
diff --git a/generic/tclPort.h b/generic/tclPort.h
index 7021b8d..9ac1959 100644
index 12a60db..d817154 100644
--- a/generic/tclPort.h
+++ b/generic/tclPort.h
@@ -22,7 +22,7 @@
#endif
#include "tcl.h"
#if !defined(_WIN32)
@@ -20,7 +20,7 @@
#if defined(_WIN32)
# include "tclWinPort.h"
#else
-# include "tclUnixPort.h"
+# include "../unix/tclUnixPort.h"
#endif
#include "tcl.h"
#if !defined(LLONG_MIN)

View File

@ -1,5 +1,5 @@
%define majorver 8.6
%define vers %{majorver}.0
%define vers %{majorver}.1
%{!?sdt:%define sdt 1}
Summary: Tool Command Language, pronounced tickle
@ -15,9 +15,9 @@ Buildrequires: autoconf
Provides: tcl(abi) = %{majorver}
Obsoletes: tcl-tcldict <= %{vers}
Provides: tcl-tcldict = %{vers}
Patch0: tcl-8.6.0-autopath.patch
Patch1: tcl-8.6.0-conf.patch
Patch2: tcl-8.6.0-hidden.patch
Patch0: tcl-8.6.1-autopath.patch
Patch1: tcl-8.6.1-conf.patch
Patch2: tcl-8.6.1-hidden.patch
%if %sdt
BuildRequires: systemtap-sdt-devel
@ -134,6 +134,10 @@ rm -rf %{buildroot}/%{_datadir}/%{name}%{majorver}/ldAix
%{_datadir}/%{name}%{majorver}/tclAppInit.c
%changelog
* Thu Apr 24 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.6.1-1
- New version
- Defuzzified patches
* Thu Aug 15 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.6.0-1
- New version
Resolves: rhbz#889201