New version

This commit is contained in:
Jaroslav Škarvada 2013-08-15 10:51:20 +02:00
parent 9bcf40fe35
commit efa1916d3e
5 changed files with 48 additions and 47 deletions

View File

@ -1 +1 @@
fa3a9bf9b2d6ed2431f1baa46f4058b8 tcl8.5.13-src.tar.gz
44b50e58ab45dd272f6714dce2129123 tcl8.5.14-src.tar.gz

View File

@ -1,7 +1,8 @@
diff -up tcl8.5.7/library/auto.tcl.old tcl8.5.7/library/auto.tcl
--- tcl8.5.7/library/auto.tcl.old 2006-11-03 01:34:52.000000000 +0100
+++ tcl8.5.7/library/auto.tcl 2009-05-18 10:28:16.337102378 +0200
@@ -85,6 +85,13 @@ proc tcl_findLibrary {basename version p
diff --git a/library/auto.tcl b/library/auto.tcl
index f7cf5f0..feb0a22 100644
--- a/library/auto.tcl
+++ b/library/auto.tcl
@@ -84,6 +84,13 @@ proc tcl_findLibrary {basename version patch initScript enVarName varName} {
lappend dirs $value
}
@ -15,10 +16,11 @@ diff -up tcl8.5.7/library/auto.tcl.old tcl8.5.7/library/auto.tcl
# 3. Relative to auto_path directories. This checks relative to the
# Tcl library as well as allowing loading of libraries added to the
# auto_path that is not relative to the core library or binary paths.
diff -up tcl8.5.7/library/init.tcl.old tcl8.5.7/library/init.tcl
--- tcl8.5.7/library/init.tcl.old 2009-04-10 18:54:51.000000000 +0200
+++ tcl8.5.7/library/init.tcl 2009-05-18 10:25:25.904853164 +0200
@@ -48,16 +48,11 @@ if {![info exists auto_path]} {
diff --git a/library/init.tcl b/library/init.tcl
index 071e6df..7713d3e 100644
--- a/library/init.tcl
+++ b/library/init.tcl
@@ -47,16 +47,11 @@ if {![info exists auto_path]} {
}
namespace eval tcl {
variable Dir
@ -36,10 +38,11 @@ diff -up tcl8.5.7/library/init.tcl.old tcl8.5.7/library/init.tcl
catch {
foreach Dir $::tcl_pkgPath {
if {$Dir ni $::auto_path} {
diff -up tcl8.5.7/unix/configure.in.old tcl8.5.7/unix/configure.in
--- tcl8.5.7/unix/configure.in.old 2009-04-15 21:30:05.000000000 +0200
+++ tcl8.5.7/unix/configure.in 2009-05-18 10:21:30.987855050 +0200
@@ -833,9 +833,9 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
diff --git a/unix/configure.in b/unix/configure.in
index e22a7d3..658b3ed 100755
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -840,9 +840,9 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
test -z "$TCL_MODULE_PATH" && \
TCL_MODULE_PATH="~/Library/Tcl /Library/Tcl /System/Library/Tcl"
elif test "$prefix/lib" != "$libdir"; then

View File

@ -1,6 +1,8 @@
--- tcl8.5.0/unix/tcl.m4.conf 2007-12-20 10:48:05.000000000 +0100
+++ tcl8.5.0/unix/tcl.m4 2007-12-20 10:48:52.000000000 +0100
@@ -1427,12 +1427,12 @@ dnl AC_CHECK_TOOL(AR, ar)
diff --git a/unix/tcl.m4 b/unix/tcl.m4
index 668fa2f..a50e4d1 100644
--- a/unix/tcl.m4
+++ b/unix/tcl.m4
@@ -1420,12 +1420,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
# get rid of the warnings.
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
@ -15,12 +17,3 @@
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
AS_IF([test "`uname -m`" = "alpha"], [CFLAGS="$CFLAGS -mieee"])
AS_IF([test $do64bit = yes], [
@@ -1464,7 +1464,7 @@ dnl AC_CHECK_TOOL(AR, ar)
SHLIB_CFLAGS="-fPIC"
SHLIB_SUFFIX=".so"
- SHLIB_LD='${CC} -shared'
+ SHLIB_LD='${CC} ${CFLAGS} -shared -fPIC'
DL_OBJS=""
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"

View File

@ -1,19 +1,8 @@
diff -up tcl8.5.6/generic/tclPort.h.old tcl8.5.6/generic/tclPort.h
--- tcl8.5.6/generic/tclPort.h.old 2009-02-09 16:40:08.000000000 +0100
+++ tcl8.5.6/generic/tclPort.h 2009-02-09 16:40:26.000000000 +0100
@@ -24,7 +24,7 @@
#endif
#include "tcl.h"
#if !defined(_WIN32)
-# include "tclUnixPort.h"
+# include "../unix/tclUnixPort.h"
#endif
#if !defined(LLONG_MIN)
diff -up tcl8.5.6/generic/tclInt.h.bbb tcl8.5.6/generic/tclInt.h
--- tcl8.5.6/generic/tclInt.h.bbb 2008-11-14 01:22:39.000000000 +0100
+++ tcl8.5.6/generic/tclInt.h 2009-02-11 13:05:13.000000000 +0100
@@ -2773,7 +2773,7 @@ MODULE_SCOPE void TclClockInit(Tcl_Inter
diff --git a/generic/tclInt.h b/generic/tclInt.h
index 92251fe..b79edf6 100644
--- a/generic/tclInt.h
+++ b/generic/tclInt.h
@@ -2807,7 +2807,7 @@ MODULE_SCOPE void TclClockInit(Tcl_Interp *interp);
MODULE_SCOPE int TclClockOldscanObjCmd(
ClientData clientData, Tcl_Interp *interp,
int objc, Tcl_Obj *const objv[]);
@ -22,7 +11,7 @@ diff -up tcl8.5.6/generic/tclInt.h.bbb tcl8.5.6/generic/tclInt.h
Tcl_Interp *interp, int objc,
Tcl_Obj *const objv[]);
MODULE_SCOPE int Tcl_ConcatObjCmd(ClientData clientData,
@@ -2934,7 +2934,7 @@ MODULE_SCOPE int Tcl_RegsubObjCmd(Client
@@ -2968,7 +2968,7 @@ MODULE_SCOPE int Tcl_RegsubObjCmd(ClientData clientData,
MODULE_SCOPE int Tcl_RenameObjCmd(ClientData clientData,
Tcl_Interp *interp, int objc,
Tcl_Obj *const objv[]);
@ -31,3 +20,16 @@ diff -up tcl8.5.6/generic/tclInt.h.bbb tcl8.5.6/generic/tclInt.h
Tcl_Interp *interp, int objc,
Tcl_Obj *const objv[]);
MODULE_SCOPE int Tcl_ScanObjCmd(ClientData clientData,
diff --git a/generic/tclPort.h b/generic/tclPort.h
index 12a60db..d817154 100644
--- a/generic/tclPort.h
+++ b/generic/tclPort.h
@@ -20,7 +20,7 @@
#if defined(_WIN32)
# include "tclWinPort.h"
#else
-# include "tclUnixPort.h"
+# include "../unix/tclUnixPort.h"
#endif
#include "tcl.h"

View File

@ -1,11 +1,11 @@
%define majorver 8.5
%define vers %{majorver}.13
%define vers %{majorver}.14
%{!?sdt:%define sdt 1}
Summary: Tool Command Language, pronounced tickle
Name: tcl
Version: %{vers}
Release: 3%{?dist}
Release: 1%{?dist}
Epoch: 1
License: TCL
Group: Development/Languages
@ -16,9 +16,9 @@ Buildrequires: autoconf
Provides: tcl(abi) = %{majorver}
Obsoletes: tcl-tcldict <= %{vers}
Provides: tcl-tcldict = %{vers}
Patch0: tcl-8.5.1-autopath.patch
Patch1: tcl-8.5.10-conf.patch
Patch2: tcl-8.5.12-hidden.patch
Patch0: tcl-8.5.14-autopath.patch
Patch1: tcl-8.5.14-conf.patch
Patch2: tcl-8.5.14-hidden.patch
%if %sdt
BuildRequires: systemtap-sdt-devel
@ -137,6 +137,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/%{name}%{majorver}/tclAppInit.c
%changelog
* Thu Aug 15 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.5.14-1
- New version
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.5.13-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild