- fix hidden patch for functional expect
This commit is contained in:
parent
79c0c28cae
commit
e058234907
@ -10,3 +10,24 @@ diff -up tcl8.5.6/generic/tclPort.h.old tcl8.5.6/generic/tclPort.h
|
||||
#endif
|
||||
|
||||
#if !defined(LLONG_MIN)
|
||||
diff -up tcl8.5.6/generic/tclInt.h.bbb tcl8.5.6/generic/tclInt.h
|
||||
--- tcl8.5.6/generic/tclInt.h.bbb 2008-11-14 01:22:39.000000000 +0100
|
||||
+++ tcl8.5.6/generic/tclInt.h 2009-02-11 13:05:13.000000000 +0100
|
||||
@@ -2773,7 +2773,7 @@ MODULE_SCOPE void TclClockInit(Tcl_Inter
|
||||
MODULE_SCOPE int TclClockOldscanObjCmd(
|
||||
ClientData clientData, Tcl_Interp *interp,
|
||||
int objc, Tcl_Obj *const objv[]);
|
||||
-MODULE_SCOPE int Tcl_CloseObjCmd(ClientData clientData,
|
||||
+extern int Tcl_CloseObjCmd(ClientData clientData,
|
||||
Tcl_Interp *interp, int objc,
|
||||
Tcl_Obj *const objv[]);
|
||||
MODULE_SCOPE int Tcl_ConcatObjCmd(ClientData clientData,
|
||||
@@ -2934,7 +2934,7 @@ MODULE_SCOPE int Tcl_RegsubObjCmd(Client
|
||||
MODULE_SCOPE int Tcl_RenameObjCmd(ClientData clientData,
|
||||
Tcl_Interp *interp, int objc,
|
||||
Tcl_Obj *const objv[]);
|
||||
-MODULE_SCOPE int Tcl_ReturnObjCmd(ClientData clientData,
|
||||
+extern int Tcl_ReturnObjCmd(ClientData clientData,
|
||||
Tcl_Interp *interp, int objc,
|
||||
Tcl_Obj *const objv[]);
|
||||
MODULE_SCOPE int Tcl_ScanObjCmd(ClientData clientData,
|
||||
|
5
tcl.spec
5
tcl.spec
@ -4,7 +4,7 @@
|
||||
Summary: Tool Command Language, pronounced tickle
|
||||
Name: tcl
|
||||
Version: %{vers}
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Epoch: 1
|
||||
License: TCL
|
||||
Group: Development/Languages
|
||||
@ -124,6 +124,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/%{name}8.5/%{name}Config.sh
|
||||
|
||||
%changelog
|
||||
* Wed Feb 11 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:8.5.6-3
|
||||
- fix hidden patch for functional expect
|
||||
|
||||
* Mon Feb 9 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:8.5.6-1
|
||||
- update to 8.5.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user