Upgraded to tcl-8.4.13.
This commit is contained in:
parent
5bc80bbca2
commit
bffce3d4dc
@ -2,3 +2,5 @@ tcl8.4.11-src.tar.gz
|
||||
tcl8.4.11-html.tar.gz
|
||||
tcl8.4.12-src.tar.gz
|
||||
tk8.4.12-src.tar.gz
|
||||
tcl8.4.13-src.tar.gz
|
||||
tk8.4.13-src.tar.gz
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
7480432d8730263f267952788eb4839b tcl8.4.12-src.tar.gz
|
||||
316491cb82d898b434842353aed1f0d6 tk8.4.12-src.tar.gz
|
||||
f3420b9439bcc769992c1367934a060d tcl8.4.13-src.tar.gz
|
||||
0a16d4d9398e43cbb85784c85fb807a4 tk8.4.13-src.tar.gz
|
||||
|
67
tcl-8.4.13-autoconf.patch
Normal file
67
tcl-8.4.13-autoconf.patch
Normal file
@ -0,0 +1,67 @@
|
||||
--- tcl8.4.13/unix/configure.in.ac123 2006-04-19 17:39:42.000000000 -0400
|
||||
+++ tcl8.4.13/unix/configure.in 2006-04-19 17:41:29.000000000 -0400
|
||||
@@ -211,7 +211,7 @@
|
||||
}], tcl_cv_strstr_unbroken=ok, tcl_cv_strstr_unbroken=broken,
|
||||
tcl_cv_strstr_unbroken=broken)])
|
||||
if test $tcl_cv_strstr_unbroken = broken; then
|
||||
- LIBOBJS="$LIBOBJS strstr.o"
|
||||
+ AC_LIBOBJ(strstr)
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -243,7 +243,7 @@
|
||||
fi
|
||||
fi
|
||||
if test $tcl_ok = 0; then
|
||||
- LIBOBJS="$LIBOBJS strtoul.o"
|
||||
+ AC_LIBOBJ(strtoul)
|
||||
fi
|
||||
|
||||
#--------------------------------------------------------------------
|
||||
@@ -273,7 +273,7 @@
|
||||
fi
|
||||
fi
|
||||
if test $tcl_ok = 0; then
|
||||
- LIBOBJS="$LIBOBJS strtod.o"
|
||||
+ AC_LIBOBJ(strtod)
|
||||
fi
|
||||
|
||||
#--------------------------------------------------------------------
|
||||
@@ -352,7 +352,7 @@
|
||||
AC_CHECK_LIB(inet, strncasecmp, tcl_ok=1, tcl_ok=0)
|
||||
fi
|
||||
if test "$tcl_ok" = 0; then
|
||||
- LIBOBJS="$LIBOBJS strncasecmp.o"
|
||||
+ AC_LIBOBJ(strncasecmp)
|
||||
fi
|
||||
|
||||
#--------------------------------------------------------------------
|
||||
--- tcl8.4.13/unix/tcl.m4.ac123 2006-04-19 17:39:42.000000000 -0400
|
||||
+++ tcl8.4.13/unix/tcl.m4 2006-04-19 17:40:31.000000000 -0400
|
||||
@@ -1123,7 +1123,7 @@
|
||||
|
||||
# AIX v<=4.1 has some different flags than 4.2+
|
||||
if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
|
||||
- LIBOBJS="$LIBOBJS tclLoadAix.o"
|
||||
+ AC_LIBOBJ(tclLoadAix)
|
||||
DL_LIBS="-lld"
|
||||
fi
|
||||
|
||||
@@ -1365,7 +1365,7 @@
|
||||
# is kind of overkill but it works.
|
||||
# Disable inlining only when one of the
|
||||
# files in compat/*.c is being linked in.
|
||||
- if test x"${LIBOBJS}" != x ; then
|
||||
+ if test x"${LIB@&t@OBJS}" != x ; then
|
||||
CFLAGS="$CFLAGS -fno-inline"
|
||||
fi
|
||||
|
||||
@@ -2571,7 +2571,7 @@
|
||||
}], tcl_cv_strtod_buggy=ok, tcl_cv_strtod_buggy=buggy,
|
||||
tcl_cv_strtod_buggy=buggy)])
|
||||
if test "$tcl_cv_strtod_buggy" = buggy; then
|
||||
- LIBOBJS="$LIBOBJS fixstrtod.o"
|
||||
+ AC_LIBOBJ(fixstrtod)
|
||||
AC_DEFINE(strtod, fixstrtod)
|
||||
fi
|
||||
fi
|
11
tcl.spec
11
tcl.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Tcl scripting language development environment
|
||||
Name: tcl
|
||||
Version: %{majorver}.12
|
||||
Release: 4
|
||||
Version: %{majorver}.13
|
||||
Release: 1
|
||||
License: BSD
|
||||
Group: Development/Languages
|
||||
URL: http://tcl.sourceforge.net/
|
||||
@ -15,8 +15,7 @@ Patch1: tcl-8.3.5-tclm4-soname.patch
|
||||
Patch2: tcl-8.4.5-lib-perm.patch
|
||||
Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
|
||||
Patch4: tcl-8.4-no_rpath.patch
|
||||
Patch5: tcl-8.4-autoconf.patch
|
||||
Patch6: tcl-8.4.12-relid.patch
|
||||
Patch5: tcl-8.4.13-autoconf.patch
|
||||
|
||||
%description
|
||||
The Tcl (Tool Command Language) provides a powerful platform for
|
||||
@ -67,7 +66,6 @@ cd %{name}%{version}
|
||||
%patch3 -p1 -b .3-pkgpath
|
||||
%patch4 -p1 -b .4-rpath
|
||||
%patch5 -p1 -b .5-ac213
|
||||
%patch6 -p1 -b .6-relid
|
||||
|
||||
# patch1 touches tcl.m4, and patch3 touches configure.in
|
||||
cd unix
|
||||
@ -150,6 +148,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc %{name}%{version}/html/*
|
||||
|
||||
%changelog
|
||||
* Wed Apr 19 2006 David Cantrell <dcantrell@redhat.com> - 8.4.13-1
|
||||
- Upgraded to Tcl 8.4.13
|
||||
|
||||
* Fri Feb 17 2006 David Cantrell <dcantrell@redhat.com> - 8.4.12-4
|
||||
- Enable threads (#181871)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user