Replace patches.

This commit is contained in:
Marcela Mašláňová 2006-12-19 13:42:58 +00:00
parent 49ad7835fa
commit 5f4dbc64fb
5 changed files with 15 additions and 36 deletions

View File

@ -1 +1,2 @@
tcl8.5a5-src.tar.gz
tk8.5a5-src.tar.gz

View File

@ -1 +1,2 @@
fe9e399c1f186f8c605de8d2e262881e tcl8.5a5-src.tar.gz
8118677251db51faf49bb3333ed6db16 tk8.5a5-src.tar.gz

View File

@ -1,12 +0,0 @@
diff -u tcl8.3.5/unix/tcl.m4~ tcl8.3.5/unix/tcl.m4
--- tcl8.3.5/unix/tcl.m4~ 2003-01-14 20:42:53.000000000 +0900
+++ tcl8.3.5/unix/tcl.m4 2003-01-14 20:42:53.000000000 +0900
@@ -954,7 +954,7 @@
CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD="${CC} -shared"
+ SHLIB_LD='${CC} -shared -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="-rdynamic"

View File

@ -1,11 +0,0 @@
--- tcl8.4.7/unix/tcl.m4~ 2004-07-30 16:13:56.891203387 +0900
+++ tcl8.4.7/unix/tcl.m4 2004-07-30 16:19:10.682145185 +0900
@@ -1141,7 +1141,7 @@
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ CC_SEARCH_FLAGS=''
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
else
AC_CHECK_HEADER(dld.h, [

View File

@ -10,15 +10,15 @@ License: BSD
Group: Development/Languages
URL: http://tcl.sourceforge.net/
Source0: http://puzzle.dl.sourceforge.net/sourceforge/tcl/tcl%{version}-src.tar.gz
#Source1: http://download.sourceforge.net/tcl/tk%{version}-src.tar.gz
Source1: http://switch.dl.sourceforge.net/sourceforge/tcl/tk%{version}-src.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
Buildrequires: autoconf, sed
Patch1: tcl-8.3.5-tclm4-soname.patch
Patch1: tcl-8.5a5-tclm4-soname.patch
Patch2: tcl-8.4.5-lib-perm.patch
Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
Patch4: tcl-8.4-no_rpath.patch
Patch4: tcl-8.5a5-no_rpath.patch
#Patch5: tcl-8.4.13-autoconf.patch
Patch6: tcl-8.4.13-cflags.patch
#Patch6: tcl-8.4.13-cflags.patch
%description
The Tcl (Tool Command Language) provides a powerful platform for
@ -58,34 +58,34 @@ Tcl/Tk is a powerful scripting language and GUI toolkit.
This package contains the html manual.
prep
%prep
%setup -T -D -c %{name}-%{version} -q -a 0
##-a 1
ls
cd %{name}%{version}
# define DT SONAME in shared lib
%patch1 -p1 -b .1-soname
%patch1 -p1 -b .soname
#%patch2 -p1 -b .2-ro-lib
%patch3 -p1 -b .3-pkgpath
%patch4 -p1 -b .4-rpath
#%patch5 -p1 -b .5-ac213
pushd ..
%patch6 -p1 -b .6-cflags
popd
#pushd ..
#%patch6 -p1 -b .6-cflags
#popd
# patch1 touches tcl.m4, and patch3 touches configure.in
cd unix
autoconf
%build
ls %{_tmppath}
cd %{name}%{version}/unix
%configure --enable-threads
make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
# run "make test" by default
%{?_without_check: %define _without_check 1}
%{!?_without_check: %define _without_check 0}
# don't run "make test" by default
%{?_without_check: %define _without_check 0}
%{!?_without_check: %define _without_check 1}
%if ! %{_without_check}
make test