- Fix cflags patch so it applies correctly

- Changes $(CFLAGS) to ${CFLAGS} in cflags patch
This commit is contained in:
David Cantrell 2006-07-20 19:20:34 +00:00
parent 5daccacbff
commit 58f463b5e7
2 changed files with 25 additions and 19 deletions

View File

@ -1,22 +1,22 @@
--- tcl8.4.13/unix/tcl.m4.BAD 2006-07-13 14:05:38.000000000 -0400
+++ tcl8.4.13/unix/tcl.m4 2006-07-13 14:07:58.000000000 -0400
--- tcl-8.4.13/tcl8.4.13/unix/tcl.m4.6-cflags 2006-07-20 15:11:19.000000000 -0400
+++ tcl-8.4.13/tcl8.4.13/unix/tcl.m4 2006-07-20 15:12:40.000000000 -0400
@@ -1340,7 +1340,7 @@
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD='${CC} -shared -Wl,-soname,${@}'
+ SHLIB_LD='${CC} $(CFLAGS) -shared -Wl,-soname,${@}'
+ SHLIB_LD='${CC} ${CFLAGS} -shared -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
--- tk8.4.13/unix/tcl.m4.BAD 2006-07-13 13:57:14.000000000 -0400
+++ tk8.4.13/unix/tcl.m4 2006-07-13 13:57:26.000000000 -0400
--- tcl-8.4.13/tk8.4.13/unix/tcl.m4.6-cflags 2006-04-19 08:29:38.000000000 -0400
+++ tcl-8.4.13/tk8.4.13/unix/tcl.m4 2006-07-20 15:13:04.000000000 -0400
@@ -1340,7 +1340,7 @@
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD="${CC} -shared"
+ SHLIB_LD="${CC} $(CFLAGS) -shared"
+ SHLIB_LD="${CC} ${CFLAGS} -shared"
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"

View File

@ -3,7 +3,7 @@
Summary: Tcl scripting language development environment
Name: tcl
Version: %{majorver}.13
Release: 2%{?dist}
Release: 3%{?dist}
License: BSD
Group: Development/Languages
URL: http://tcl.sourceforge.net/
@ -67,7 +67,9 @@ cd %{name}%{version}
%patch3 -p1 -b .3-pkgpath
%patch4 -p1 -b .4-rpath
%patch5 -p1 -b .5-ac213
pushd ..
%patch6 -p1 -b .6-cflags
popd
# patch1 touches tcl.m4, and patch3 touches configure.in
cd unix
@ -150,6 +152,10 @@ rm -rf $RPM_BUILD_ROOT
%doc %{name}%{version}/html/*
%changelog
* Thu Jul 20 2006 David Cantrell <dcantrell@redhat.com> - 8.4.13-3
- Fix cflags patch so it applies correctly
- Changes $(CFLAGS) to ${CFLAGS} in cflags patch
* Thu Jul 20 2006 David Cantrell <dcantrell@redhat.com> - 8.4.13-2
- Patch from Dennis Gilmore <dennis@ausil.us> for sparc64 (#199375)