- #436567 change auto path, tk can't be found.
- #437399 fix files permission
This commit is contained in:
parent
314d98d6f4
commit
3e0b2308db
53
tcl-8.5.1-autopath.patch
Normal file
53
tcl-8.5.1-autopath.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
diff -up tcl8.5.1/unix/configure.in.autopath tcl8.5.1/unix/configure.in
|
||||||
|
--- tcl8.5.1/unix/configure.in.autopath 2008-02-05 18:00:35.000000000 +0100
|
||||||
|
+++ tcl8.5.1/unix/configure.in 2008-03-17 14:57:24.000000000 +0100
|
||||||
|
@@ -795,9 +795,9 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
|
||||||
|
test -z "$TCL_MODULE_PATH" && \
|
||||||
|
TCL_MODULE_PATH="~/Library/Tcl /Library/Tcl /Network/Library/Tcl /System/Library/Tcl"
|
||||||
|
elif test "$prefix/lib" != "$libdir"; then
|
||||||
|
- TCL_PACKAGE_PATH="${libdir} ${prefix}/lib ${TCL_PACKAGE_PATH}"
|
||||||
|
+ TCL_PACKAGE_PATH="${libdir}/tcl8.5 ${libdir}/tk8.5 ${prefix}/lib/tcl8.5 ${prefix}/lib/tk8.5 ${prefix}/share/tcl8.5 ${TCL_PACKAGE_PATH}"
|
||||||
|
else
|
||||||
|
- TCL_PACKAGE_PATH="${prefix}/lib ${TCL_PACKAGE_PATH}"
|
||||||
|
+ TCL_PACKAGE_PATH="${libdir}/tcl8.5 ${prefix}/share/tcl8.5 ${libdir}/tk8.5 ${TCL_PACKAGE_PATH}"
|
||||||
|
fi
|
||||||
|
|
||||||
|
#--------------------------------------------------------------------
|
||||||
|
diff -up tcl8.5.1/library/init.tcl.autopath tcl8.5.1/library/init.tcl
|
||||||
|
--- tcl8.5.1/library/init.tcl.autopath 2008-02-04 18:29:11.000000000 +0100
|
||||||
|
+++ tcl8.5.1/library/init.tcl 2008-02-19 09:11:51.000000000 +0100
|
||||||
|
@@ -48,16 +48,11 @@ if {![info exists auto_path]} {
|
||||||
|
}
|
||||||
|
namespace eval tcl {
|
||||||
|
variable Dir
|
||||||
|
- foreach Dir [list $::tcl_library [file dirname $::tcl_library]] {
|
||||||
|
+ foreach Dir [list $::tcl_library] {
|
||||||
|
if {$Dir ni $::auto_path} {
|
||||||
|
lappend ::auto_path $Dir
|
||||||
|
}
|
||||||
|
}
|
||||||
|
- set Dir [file join [file dirname [file dirname \
|
||||||
|
- [info nameofexecutable]]] lib]
|
||||||
|
- if {$Dir ni $::auto_path} {
|
||||||
|
- lappend ::auto_path $Dir
|
||||||
|
- }
|
||||||
|
catch {
|
||||||
|
foreach Dir $::tcl_pkgPath {
|
||||||
|
if {$Dir ni $::auto_path} {
|
||||||
|
diff -up tcl8.5.1/library/auto.tcl.autopath tcl8.5.1/library/auto.tcl
|
||||||
|
--- tcl8.5.1/library/auto.tcl.autopath 2006-11-03 01:34:52.000000000 +0100
|
||||||
|
+++ tcl8.5.1/library/auto.tcl 2008-02-19 09:11:51.000000000 +0100
|
||||||
|
@@ -85,6 +85,13 @@ proc tcl_findLibrary {basename version p
|
||||||
|
lappend dirs $value
|
||||||
|
}
|
||||||
|
|
||||||
|
+ # 2a. As a sibling of Tcl's script directory
|
||||||
|
+ if {[catch {
|
||||||
|
+ ::tcl::pkgconfig get scriptdir,runtime
|
||||||
|
+ } value] == 0} {
|
||||||
|
+ lappend dirs [file join [file dirname $value] $basename$version]
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
# 3. Relative to auto_path directories. This checks relative to the
|
||||||
|
# Tcl library as well as allowing loading of libraries added to the
|
||||||
|
# auto_path that is not relative to the core library or binary paths.
|
101
tcl-confi.patch
101
tcl-confi.patch
@ -1,101 +0,0 @@
|
|||||||
--- tcl8.4.15/unix/configure.in.confi 2007-05-24 22:40:13.000000000 +0200
|
|
||||||
+++ tcl8.4.15/unix/configure.in 2007-08-08 12:50:16.000000000 +0200
|
|
||||||
@@ -246,7 +246,7 @@
|
|
||||||
}], tcl_cv_strstr_unbroken=ok, tcl_cv_strstr_unbroken=broken,
|
|
||||||
tcl_cv_strstr_unbroken=broken)])
|
|
||||||
if test $tcl_cv_strstr_unbroken = broken; then
|
|
||||||
- LIBOBJS="$LIBOBJS strstr.o"
|
|
||||||
+ AC_LIBOBJ([strstr])
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
@@ -278,7 +278,7 @@
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
if test $tcl_ok = 0; then
|
|
||||||
- LIBOBJS="$LIBOBJS strtoul.o"
|
|
||||||
+ AC_LIBOBJ([strtoul])
|
|
||||||
fi
|
|
||||||
|
|
||||||
#--------------------------------------------------------------------
|
|
||||||
@@ -308,7 +308,7 @@
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
if test $tcl_ok = 0; then
|
|
||||||
- LIBOBJS="$LIBOBJS strtod.o"
|
|
||||||
+ AC_LIBOBJ([strtod])
|
|
||||||
fi
|
|
||||||
|
|
||||||
#--------------------------------------------------------------------
|
|
||||||
@@ -387,7 +387,7 @@
|
|
||||||
AC_CHECK_LIB(inet, strncasecmp, tcl_ok=1, tcl_ok=0)
|
|
||||||
fi
|
|
||||||
if test "$tcl_ok" = 0; then
|
|
||||||
- LIBOBJS="$LIBOBJS strncasecmp.o"
|
|
||||||
+ AC_LIBOBJ([strncasecmp])
|
|
||||||
fi
|
|
||||||
|
|
||||||
#--------------------------------------------------------------------
|
|
||||||
@@ -642,7 +642,7 @@
|
|
||||||
elif test "$prefix" != "$exec_prefix"; then
|
|
||||||
TCL_PACKAGE_PATH="${libdir} ${prefix}/lib"
|
|
||||||
else
|
|
||||||
- TCL_PACKAGE_PATH="${prefix}/lib"
|
|
||||||
+ TCL_PACKAGE_PATH="${libdir} ${prefix}/share ${prefix}/share/tcl8.4 ${libdir}/tcl8.4"
|
|
||||||
fi
|
|
||||||
|
|
||||||
#--------------------------------------------------------------------
|
|
||||||
--- tcl8.4.15/unix/tcl.m4.confi 2007-05-24 22:40:13.000000000 +0200
|
|
||||||
+++ tcl8.4.15/unix/tcl.m4 2007-08-09 07:51:59.000000000 +0200
|
|
||||||
@@ -1124,7 +1124,7 @@
|
|
||||||
|
|
||||||
# AIX v<=4.1 has some different flags than 4.2+
|
|
||||||
if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
|
|
||||||
- LIBOBJS="$LIBOBJS tclLoadAix.o"
|
|
||||||
+ AC_LIBOBJ([tclLoadAix])
|
|
||||||
DL_LIBS="-lld"
|
|
||||||
fi
|
|
||||||
|
|
||||||
@@ -1345,11 +1345,11 @@
|
|
||||||
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
|
|
||||||
|
|
||||||
if test "$have_dl" = yes; then
|
|
||||||
- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
|
|
||||||
+ SHLIB_LD='${CC} ${CFLAGS} -shared ${LDFLAGS} -Wl,-soname,${@}'
|
|
||||||
DL_OBJS="tclLoadDl.o"
|
|
||||||
DL_LIBS="-ldl"
|
|
||||||
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
|
|
||||||
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
|
|
||||||
+ CC_SEARCH_FLAGS=''
|
|
||||||
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
|
|
||||||
else
|
|
||||||
AC_CHECK_HEADER(dld.h, [
|
|
||||||
@@ -1381,7 +1381,7 @@
|
|
||||||
# is kind of overkill but it works.
|
|
||||||
# Disable inlining only when one of the
|
|
||||||
# files in compat/*.c is being linked in.
|
|
||||||
- if test x"${LIBOBJS}" != x ; then
|
|
||||||
+ if test x"${LIB@&t@OBJS}" != x ; then
|
|
||||||
CFLAGS="$CFLAGS -fno-inline"
|
|
||||||
fi
|
|
||||||
|
|
||||||
@@ -2633,7 +2633,7 @@
|
|
||||||
}], tcl_cv_strtod_buggy=ok, tcl_cv_strtod_buggy=buggy,
|
|
||||||
tcl_cv_strtod_buggy=buggy)])
|
|
||||||
if test "$tcl_cv_strtod_buggy" = buggy; then
|
|
||||||
- LIBOBJS="$LIBOBJS fixstrtod.o"
|
|
||||||
+ AC_LIBOBJ([fixstrtod])
|
|
||||||
AC_DEFINE(strtod, fixstrtod)
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
--- tcl8.4.15/unix/Makefile.in.confi 2007-05-24 22:40:13.000000000 +0200
|
|
||||||
+++ tcl8.4.15/unix/Makefile.in 2007-08-08 12:50:16.000000000 +0200
|
|
||||||
@@ -628,7 +628,7 @@
|
|
||||||
fi
|
|
||||||
@echo "Installing $(LIB_FILE) to $(LIB_INSTALL_DIR)/"
|
|
||||||
@@INSTALL_LIB@
|
|
||||||
- @chmod 555 $(LIB_INSTALL_DIR)/$(LIB_FILE)
|
|
||||||
+ @chmod 755 $(LIB_INSTALL_DIR)/$(LIB_FILE)
|
|
||||||
@if test "$(TCL_BUILD_EXP_FILE)" != ""; then \
|
|
||||||
echo "Installing $(TCL_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
|
|
||||||
$(INSTALL_DATA) $(TCL_BUILD_EXP_FILE) \
|
|
8
tcl.spec
8
tcl.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: Tcl scripting language development environment
|
Summary: Tcl scripting language development environment
|
||||||
Name: tcl
|
Name: tcl
|
||||||
Version: %{majorver}.1
|
Version: %{majorver}.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: TCL
|
License: TCL
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -14,7 +14,7 @@ Buildrequires: autoconf
|
|||||||
Provides: tcl(abi) = %{majorver}
|
Provides: tcl(abi) = %{majorver}
|
||||||
Obsoletes: tcl-tcldict <= 8.5.2
|
Obsoletes: tcl-tcldict <= 8.5.2
|
||||||
Provides: tcl-tcldict = 8.5.2
|
Provides: tcl-tcldict = 8.5.2
|
||||||
Patch0: tcl-8.5.0-autopath.patch
|
Patch0: tcl-8.5.1-autopath.patch
|
||||||
Patch1: tcl-8.5.0-conf.patch
|
Patch1: tcl-8.5.0-conf.patch
|
||||||
Patch2: tcl-8.5.0-make.patch
|
Patch2: tcl-8.5.0-make.patch
|
||||||
Patch3: tcl-8.5.0-hidden.patch
|
Patch3: tcl-8.5.0-hidden.patch
|
||||||
@ -121,6 +121,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/%{name}Config.sh
|
%{_libdir}/%{name}Config.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 17 2008 Marcela Maslanova <mmaslano@redhat.com> - 1:8.5.1-3
|
||||||
|
- #436567 change auto path, tk can't be found.
|
||||||
|
- #437399 fix files permission
|
||||||
|
|
||||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:8.5.1-2
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:8.5.1-2
|
||||||
- Autorebuild for GCC 4.3
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user