Forgot to add patches in the previous commit.

This commit is contained in:
Marcela Mašláňová 2008-01-02 12:43:01 +00:00
parent ddc56a9fe3
commit 1d4788a4f0
3 changed files with 167 additions and 0 deletions

50
tcl-8.5.0-autopath.patch Normal file
View File

@ -0,0 +1,50 @@
--- tcl8.5.0/unix/configure.in.orig 2007-12-19 13:50:13.000000000 -0800
+++ tcl8.5.0/unix/configure.in 2007-12-21 19:25:04.000000000 -0800
@@ -795,9 +795,9 @@
test -z "$TCL_MODULE_PATH" && \
TCL_MODULE_PATH="~/Library/Tcl /Library/Tcl /Network/Library/Tcl /System/Library/Tcl"
elif test "$prefix/lib" != "$libdir"; then
- TCL_PACKAGE_PATH="${libdir} ${prefix}/lib ${TCL_PACKAGE_PATH}"
+ TCL_PACKAGE_PATH="${libdir}/tcl8.5 ${prefix}/share/tcl8.5 ${TCL_PACKAGE_PATH}"
else
- TCL_PACKAGE_PATH="${prefix}/lib ${TCL_PACKAGE_PATH}"
+ TCL_PACKAGE_PATH="${libdir}/tcl8.5 ${prefix}/share/tcl8.5 ${TCL_PACKAGE_PATH}"
fi
#--------------------------------------------------------------------
--- tcl8.5.0/library/init.tcl.orig 2007-12-21 19:43:12.000000000 -0800
+++ tcl8.5.0/library/init.tcl 2007-12-21 19:43:28.000000000 -0800
@@ -48,16 +48,11 @@
}
namespace eval tcl {
variable Dir
- foreach Dir [list $::tcl_library [file dirname $::tcl_library]] {
+ foreach Dir [list $::tcl_library] {
if {$Dir ni $::auto_path} {
lappend ::auto_path $Dir
}
}
- set Dir [file join [file dirname [file dirname \
- [info nameofexecutable]]] lib]
- if {$Dir ni $::auto_path} {
- lappend ::auto_path $Dir
- }
catch {
foreach Dir $::tcl_pkgPath {
if {$Dir ni $::auto_path} {
--- tcl8.5a5/library/auto.tcl.orig 2007-02-08 17:03:44.000000000 -0800
+++ tcl8.5a5/library/auto.tcl 2007-02-08 17:04:03.000000000 -0800
@@ -85,6 +85,13 @@
lappend dirs $value
}
+ # 2a. As a sibling of Tcl's script directory
+ if {[catch {
+ ::tcl::pkgconfig get scriptdir,runtime
+ } value] == 0} {
+ lappend dirs [file join [file dirname $value] $basename$version]
+ }
+
# 3. Relative to auto_path directories. This checks relative to the
# Tcl library as well as allowing loading of libraries added to the
# auto_path that is not relative to the core library or binary paths.

26
tcl-8.5.0-conf.patch Normal file
View File

@ -0,0 +1,26 @@
--- tcl8.5.0/unix/tcl.m4.conf 2007-12-20 10:48:05.000000000 +0100
+++ tcl8.5.0/unix/tcl.m4 2007-12-20 10:48:52.000000000 +0100
@@ -1427,12 +1427,12 @@ dnl AC_CHECK_TOOL(AR, ar)
# get rid of the warnings.
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
+ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -fPIC -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
AS_IF([test $doRpath = yes], [
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'])
+ CC_SEARCH_FLAGS=''])
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
AS_IF([test "`uname -m`" = "alpha"], [CFLAGS="$CFLAGS -mieee"])
AS_IF([test $do64bit = yes], [
@@ -1464,7 +1464,7 @@ dnl AC_CHECK_TOOL(AR, ar)
SHLIB_LD_LIBS='${LIBS}'
SHLIB_SUFFIX=".so"
- SHLIB_LD='${CC} -shared'
+ SHLIB_LD='${CC} ${CFLAGS} -shared -fPIC'
DL_OBJS=""
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"

91
tcl-8.5.0-make.patch Normal file
View File

@ -0,0 +1,91 @@
--- tcl8.5.0/unix/Makefile.in.make 2007-12-19 22:50:13.000000000 +0100
+++ tcl8.5.0/unix/Makefile.in 2007-12-20 11:11:07.000000000 +0100
@@ -731,8 +731,8 @@ install-binaries: binaries
$(INSTALL_DATA) $(TCL_BUILD_EXP_FILE) \
$(LIB_INSTALL_DIR)/$(TCL_EXP_FILE); \
fi
- @echo "Installing tclsh as $(BIN_INSTALL_DIR)/tclsh$(VERSION)"
- @$(INSTALL_PROGRAM) tclsh $(BIN_INSTALL_DIR)/tclsh$(VERSION)
+ @echo "Installing tclsh as $(BIN_INSTALL_DIR)/tclsh"
+ @$(INSTALL_PROGRAM) tclsh $(BIN_INSTALL_DIR)/tclsh
@echo "Installing tclConfig.sh to $(LIB_INSTALL_DIR)/"
@$(INSTALL_DATA) tclConfig.sh $(LIB_INSTALL_DIR)/tclConfig.sh
@if test "$(STUB_LIB_FILE)" != "" ; then \
@@ -783,7 +783,7 @@ install-libraries: libraries $(INSTALL_T
$(INSTALL_DATA) $$j $(SCRIPT_INSTALL_DIR)/http1.0; \
done;
@echo "Installing package http 2.5.3 as a Tcl Module";
- @$(INSTALL_DATA) $(TOP_DIR)/library/http/http.tcl $(SCRIPT_INSTALL_DIR)/../tcl8/8.4/http-2.5.3.tm;
+ @$(INSTALL_DATA) $(TOP_DIR)/library/http/http.tcl $(SCRIPT_INSTALL_DIR)/../tcl8/8.5/http-2.5.3.tm;
@echo "Installing library opt0.4 directory";
@for j in $(TOP_DIR)/library/opt/*.tcl ; \
do \
@@ -795,9 +795,9 @@ install-libraries: libraries $(INSTALL_T
@$(INSTALL_DATA) $(TOP_DIR)/library/tcltest/tcltest.tcl $(SCRIPT_INSTALL_DIR)/../tcl8/8.5/tcltest-2.3.0.tm;
@echo "Installing package platform 1.0.3 as a Tcl Module";
- @$(INSTALL_DATA) $(TOP_DIR)/library/platform/platform.tcl $(SCRIPT_INSTALL_DIR)/../tcl8/8.4/platform-1.0.3.tm;
+ @$(INSTALL_DATA) $(TOP_DIR)/library/platform/platform.tcl $(SCRIPT_INSTALL_DIR)/../tcl8/8.5/platform-1.0.3.tm;
@echo "Installing package platform::shell 1.1.3 as a Tcl Module";
- @$(INSTALL_DATA) $(TOP_DIR)/library/platform/shell.tcl $(SCRIPT_INSTALL_DIR)/../tcl8/8.4/platform/shell-1.1.3.tm;
+ @$(INSTALL_DATA) $(TOP_DIR)/library/platform/shell.tcl $(SCRIPT_INSTALL_DIR)/../tcl8/8.5/platform/shell-1.1.3.tm;
@echo "Installing library encoding directory";
@for i in $(TOP_DIR)/library/encoding/*.enc ; do \
@@ -1750,21 +1750,41 @@ allpatch: dist
# tk8.* up two directories from the TOOL_DIR.
#
-html: tclsh
- $(BUILD_HTML)
- @EXTRA_BUILD_HTML@
-html-tcl: tclsh
- $(BUILD_HTML) --tcl
- @EXTRA_BUILD_HTML@
-html-tk: tclsh
- $(BUILD_HTML) --tk
- @EXTRA_BUILD_HTML@
-
-BUILD_HTML = \
- @@LD_LIBRARY_PATH_VAR@=`pwd`:$${@LD_LIBRARY_PATH_VAR@}; export @LD_LIBRARY_PATH_VAR@; \
- TCL_LIBRARY="${TCL_BUILDTIME_LIBRARY}"; export TCL_LIBRARY; \
- ./tclsh $(TOOL_DIR)/tcltk-man2html.tcl --htmldir=$(HTML_INSTALL_DIR) \
- --srcdir=$(TOP_DIR)/.. $(BUILD_HTML_FLAGS)
+html:
+ echo "Building html" \
+ echo "adresar $(HTML_DIR)"; \
+ mkdir -p ../htmll; \
+ mkdir -p ../html; \
+ mkdir -p ../html/TclCmd;
+ mkdir -p ../html/TclLib;
+ mkdir -p ../html/TkCmd;
+ mkdir -p ../html/TkLib;
+ mkdir -p ../html/UserCmd;
+ cd ..; \
+ for i in `ls doc`; do \
+ j=`echo $$i | sed s/[0-9n]$$/htm/`; \
+ man2html doc/$$i > htmll/$$j 2> /dev/null ; \
+ done;
+ for i in `ls ../../tk8.5b1/doc`; do \
+ j=`echo $$i | sed s/[0-9n]$$/htm/`; \
+ man2html ../../tk8.5b1/doc/$$i > ../htmll/$$j 2> /dev/null; \
+ done;
+ for i in `cat lst/tclcmd_list`; do \
+ cp ../htmll/$$i ../html/TclCmd/$$i; \
+ done;
+ for i in `cat lst/tcllib_list`; do \
+ cp ../htmll/$$i ../html/TclLib/$$i; \
+ done;
+ for i in `cat lst/tkcmd_list`; do \
+ cp ../htmll/$$i ../html/TkCmd/$$i; \
+ done;
+ for i in `cat lst/tklib_list`; do \
+ cp ../htmll/$$i ../html/TkLib/$$i; \
+ done;
+ for i in `cat lst/usercmd_list`; do \
+ cp ../htmll/$$i ../html/UserCmd/$$i; \
+ done;
+ rm -r ../htmll;
#
# Targets to build Solaris package of the distribution for the current