Rebase to 2018 update 2.

This commit is contained in:
Jerry James 2018-01-24 20:12:30 -07:00
parent 7d6d0e7e28
commit 92f73dee50
3 changed files with 30 additions and 14 deletions

View File

@ -1 +1 @@
SHA512 (2018_U1.tar.gz) = a975ab61b5eb0ca9b537f6836a61e8b5323fee5db04a9fafccd28dcf070caaf94c6772c482bdcdfe0e8769ab12fe7c6d2ce65ce4226052676c09e4c8d859250e
SHA512 (2018_U2.tar.gz) = a94b55bcabec47424be1c2d4b7bf3502a545bc714250a260e152b00431420094dbab64c0355bd0004ee9ad10d85c7b920969bf4b6d9a30b3697c7c5202518841

View File

@ -1,6 +1,6 @@
diff -up tbb2017_20160722oss/build/linux.gcc.inc~ tbb2017_20160722oss/build/linux.gcc.inc
--- tbb2017_20160722oss/build/linux.gcc.inc.orig 2016-08-17 06:57:29.000000000 -0600
+++ tbb2017_20160722oss/build/linux.gcc.inc 2016-09-08 15:02:27.054318551 -0600
diff -up tbb-2018_U2/build/linux.gcc.inc\~ tbb-2018_U2/build/linux.gcc.inc
--- tbb-2018_U2/build/linux.gcc.inc~ 2017-12-06 10:29:49.000000000 -0700
+++ tbb-2018_U2/build/linux.gcc.inc 2018-01-22 20:47:07.148422967 -0700
@@ -68,10 +68,10 @@ ifneq (,$(shell gcc -dumpversion | egrep
endif
@ -14,9 +14,9 @@ diff -up tbb2017_20160722oss/build/linux.gcc.inc~ tbb2017_20160722oss/build/linu
endif
TBB_ASM.OBJ=
diff -up tbb2017_20160722oss/build/Makefile.tbbmalloc~ tbb2017_20160722oss/build/Makefile.tbbmalloc
--- tbb2017_20160722oss/build/Makefile.tbbmalloc.orig 2016-08-17 06:57:29.000000000 -0600
+++ tbb2017_20160722oss/build/Makefile.tbbmalloc 2016-09-08 15:02:27.060318066 -0600
diff -up tbb-2018_U2/build/Makefile.tbbmalloc\~ tbb-2018_U2/build/Makefile.tbbmalloc
--- tbb-2018_U2/build/Makefile.tbbmalloc~ 2017-12-06 10:29:49.000000000 -0700
+++ tbb-2018_U2/build/Makefile.tbbmalloc 2018-01-22 20:47:30.104350662 -0700
@@ -51,7 +51,7 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
@ -26,5 +26,12 @@ diff -up tbb2017_20160722oss/build/Makefile.tbbmalloc~ tbb2017_20160722oss/build
M_INCLUDES := $(INCLUDES) $(INCLUDE_KEY)$(MALLOC_ROOT) $(INCLUDE_KEY)$(MALLOC_SOURCE_ROOT)
# Suppress superfluous warnings for TBBMalloc compilation
Diff finished. Thu Sep 8 15:02:28 2016
@@ -86,7 +86,7 @@ $(MALLOC.DLL) $(MALLOCPROXY.DLL): CPLUS_
$(MALLOC.DLL) $(MALLOCPROXY.DLL): M_CPLUS_FLAGS += $(SDL_FLAGS)
$(MALLOC.DLL): BUILDING_LIBRARY = $(MALLOC.DLL)
$(MALLOC.DLL): $(MALLOC.OBJ) $(MALLOC.RES) $(MALLOC_NO_VERSION.DLL)
- $(subst $(CPLUS),$(CONLY),$(LIB_LINK_CMD)) $(LIB_OUTPUT_KEY)$(MALLOC.DLL) $(MALLOC.OBJ) $(MALLOC.RES) $(LIB_LINK_LIBS) $(MALLOC_LINK_FLAGS)
+ $(LIB_LINK_CMD) $(LIB_OUTPUT_KEY)$(MALLOC.DLL) $(MALLOC.OBJ) $(MALLOC.RES) $(LIB_LINK_LIBS) $(MALLOC_LINK_FLAGS)
ifneq (,$(MALLOCPROXY.DEF))
tbbmallocproxy.def: $(MALLOCPROXY.DEF)

View File

@ -1,5 +1,5 @@
%global upver 2018
%global uprel 1
%global uprel 2
%if 0%{?fedora} || 0%{?rhel} >= 8
%global with_python3 1
@ -111,19 +111,21 @@ fi
# Prepare to build the python module for both python 2 and python 3
cp -a python python3
sed -i 's,python,python3,g' python3/Makefile python3/rml/Makefile
%build
%ifarch %{ix86}
# Build an SSE2-enabled version so the mfence instruction can be used
cp -a build build.orig
make %{?_smp_mflags} tbb_build_prefix=obj stdver=c++14 \
CXXFLAGS="$RPM_OPT_FLAGS -march=pentium4 -msse2" LDFLAGS="$RPM_LD_FLAGS"
CXXFLAGS="$RPM_OPT_FLAGS -march=pentium4 -msse2" \
LDFLAGS="-Wl,--as-needed $RPM_LD_FLAGS"
mv build build.sse2
mv build.orig build
%endif
make %{?_smp_mflags} tbb_build_prefix=obj stdver=c++14 \
CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS"
CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-Wl,--as-needed $RPM_LD_FLAGS"
for file in %{SOURCE6} %{SOURCE7} %{SOURCE8}; do
base=$(basename ${file})
sed 's/_FEDORA_VERSION/%{version}/' ${file} > ${base}
@ -133,12 +135,16 @@ done
# Build for python 2
. build/obj_release/tbbvars.sh
pushd python
make %{?_smp_mflags} -C rml
cp -p rml/libirml.so* .
%py2_build
popd
%if 0%{?with_python3}
# Build for python 3
pushd python3
make %{?_smp_mflags} -C rml
cp -p rml/libirml.so* .
%py3_build
popd
%endif
@ -224,17 +230,20 @@ rm $RPM_BUILD_ROOT%{_libdir}/cmake/%{name}/README.rst
%files -n python2-%{name}
%doc python/index.html
%{python2_sitearch}/TBB*
%{python2_sitearch}/_TBB.so
%{python2_sitearch}/tbb/
%if 0%{?with_python3}
%files -n python3-%{name}
%doc python3/index.html
%{python3_sitearch}/TBB*
%{python3_sitearch}/_TBB.*.so
%{python3_sitearch}/tbb/
%{python3_sitearch}/__pycache__/TBB*
%endif
%changelog
* Wed Jan 24 2018 Jerry James <loganjerry@gmail.com> - 2018.2-1
- Rebase to 2018 update 2
* Sat Nov 25 2017 Jerry James <loganjerry@gmail.com> - 2018.1-1
- Rebase to 2018 update 1