release 2.2.1; with docs but sans java

This commit is contained in:
Frank Ch. Eigler 2013-05-16 10:42:54 -04:00
parent 84bc71fedc
commit e9cdd21299
3 changed files with 7 additions and 33 deletions

View File

@ -1,24 +0,0 @@
commit 47a606a768b695b08afce63747b32336d9b7fff2
Author: Frank Ch. Eigler <fche@redhat.com>
Date: Tue May 14 13:09:55 2013 -0400
java support: snuff gcc warnings on non-HAVE_JAVA builds
diff --git a/tapset-method.cxx b/tapset-method.cxx
index 14ae6dd..bce3382 100644
--- a/tapset-method.cxx
+++ b/tapset-method.cxx
@@ -428,10 +428,12 @@ java_builder::build (systemtap_session & sess,
void
register_tapset_java (systemtap_session& s)
{
+ (void) s;
+
+#ifdef HAVE_JAVA
match_node* root = s.pattern_root;
derived_probe_builder *builder = new java_builder ();
-#ifdef HAVE_JAVA
root->bind_str (TOK_JAVA)
->bind_str (TOK_CLASS)->bind_str (TOK_METHOD)
->bind(builder);

View File

@ -1 +1 @@
e52c71d1736a1ccc2fe6367305d83d44 systemtap-2.2.tar.gz
5be8b55864c5b1b50fc361991bb9a4dd systemtap-2.2.1.tar.gz

View File

@ -1,5 +1,5 @@
%{!?with_sqlite: %global with_sqlite 1}
%{!?with_docs: %global with_docs 0}
%{!?with_docs: %global with_docs 1}
# crash is not available
%ifarch ppc ppc64 %{sparc}
%{!?with_crash: %global with_crash 0}
@ -14,7 +14,7 @@
%ifarch ppc ppc64 %{sparc}
%{!?with_publican: %global with_publican 0}
%else
%{!?with_publican: %global with_publican 0}
%{!?with_publican: %global with_publican 1}
%endif
%if 0%{?rhel}
%{!?publican_brand: %global publican_brand RedHat}
@ -31,7 +31,7 @@
%{!?with_java: %global with_java 0}
Name: systemtap
Version: 2.2
Version: 2.2.1
Release: 1%{?dist}
# for version, see also configure.ac
@ -109,7 +109,6 @@ BuildRequires: publican
BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
%endif
%endif
%if %{with_emacsvim}
BuildRequires: emacs
%endif
@ -117,8 +116,6 @@ BuildRequires: emacs
BuildRequires: jpackage-utils java-devel
%endif
Patch2: non-java.patch
# Install requirements
Requires: systemtap-client = %{version}-%{release}
Requires: systemtap-devel = %{version}-%{release}
@ -299,8 +296,6 @@ find . \( -name configure -o -name config.h.in \) -print | xargs touch
cd ..
%endif
%patch2 -p1
%build
%if %{with_bundled_elfutils}
@ -776,6 +771,9 @@ done
# ------------------------------------------------------------------------
%changelog
* Thu May 16 2013 Frank Ch. Eigler <fche@redhat.com> - 2.2.1-1
- Upstream release.
* Tue May 14 2013 Frank Ch. Eigler <fche@redhat.com> - 2.2-1
- Upstream release.