rhbz1439914

This commit is contained in:
Frank Ch. Eigler 2017-04-06 17:06:04 -04:00
parent 61c8529211
commit cdc8fbe05c
2 changed files with 43 additions and 1 deletions

36
bz1439914.patch Normal file
View File

@ -0,0 +1,36 @@
commit 272146660f54786bb61d388f6d3a4eb20e7d9369 (origin/master2, master2)
Author: Jakub Jelinek <jakub@redhat.com>
Date: Tue Mar 21 17:04:08 2017 -0400
gcc PR80115: sys/sdt.h: tweak i386 argument passing
Use %w[arg] to request that widened forms of register names be passed
to the sys/sdt.h macro operand strings, so as to avoid nominating
sub-registers such as %sil within -m32 code, which gcc <= 6 sometimes
buggily did.
diff --git a/includes/sys/sdt.h b/includes/sys/sdt.h
index 3b7eda7976d1..eff315bcd885 100644
--- a/includes/sys/sdt.h
+++ b/includes/sys/sdt.h
@@ -82,9 +82,11 @@
# define _SDT_ASM_STRING_1(x) _SDT_ASM_1(.asciz #x)
# define _SDT_ARGFMT(no) %n[_SDT_S##no]@_SDT_ARGTMPL(_SDT_A##no)
+
# ifndef STAP_SDT_ARG_CONSTRAINT
# define STAP_SDT_ARG_CONSTRAINT nor
# endif
+
# define _SDT_STRINGIFY(x) #x
# define _SDT_ARG_CONSTRAINT_STRING(x) _SDT_STRINGIFY(x)
# define _SDT_ARG(n, x) \
@@ -173,6 +175,8 @@ __extension__ extern unsigned long long __sdt_unsp;
#if defined __powerpc__ || defined __powerpc64__
# define _SDT_ARGTMPL(id) %I[id]%[id]
+#elif defined __i386__
+# define _SDT_ARGTMPL(id) %w[id] /* gcc.gnu.org/PR80115 */
#else
# define _SDT_ARGTMPL(id) %[id]
#endif

View File

@ -72,7 +72,7 @@
Name: systemtap
Version: 3.1
Release: 2%{?dist}
Release: 3%{?dist}
# for version, see also configure.ac
@ -186,6 +186,8 @@ BuildRequires: python3-devel
BuildRequires: python3-setuptools
%endif
Patch10: bz1439914.patch
# Install requirements
Requires: systemtap-client = %{version}-%{release}
Requires: systemtap-devel = %{version}-%{release}
@ -461,6 +463,7 @@ systemtap-runtime-virthost machine to execute systemtap scripts.
%prep
%setup -q %{?setup_elfutils}
%patch10 -p1
%if %{with_bundled_elfutils}
cd elfutils-%{elfutils_version}
@ -1139,6 +1142,9 @@ done
# PRERELEASE
%changelog
* Thu Apr 06 2017 Frank Ch. Eigler <fche@redhat.com> - 3.1-3
- Backport bz1439914 (sys/sdt.h argument encoding)
* Thu Mar 16 2017 Stan Cox <scox@redhat.com> - 3.1-2
- Rebuild for dyninst 9.3