Disable ICF when checking for available tracepoints.

This commit is contained in:
Josh Stone 2015-05-12 12:06:15 -07:00
parent 92cb4bf2ff
commit 60a3632305
2 changed files with 36 additions and 1 deletions

View File

@ -0,0 +1,28 @@
From 8bb62408827f88d3694cb519eb5bb48ed6216092 Mon Sep 17 00:00:00 2001
From: Josh Stone <jistone@redhat.com>
Date: Fri, 8 May 2015 13:17:36 -0700
Subject: [PATCH] PR18389: disable ICF on tracepoint queries
We want distinct representation of every tracepoint, even if they happen
to look identical to GCC with the same function prototype.
---
buildrun.cxx | 3 +++
1 file changed, 3 insertions(+)
diff --git a/buildrun.cxx b/buildrun.cxx
index 44cb8feac47a..c7d96591f5de 100644
--- a/buildrun.cxx
+++ b/buildrun.cxx
@@ -853,6 +853,9 @@ make_tracequeries(systemtap_session& s, const map<string,string>& contents)
// RHBZ 655231: later rhel6 kernels' module-signing kbuild logic breaks out-of-tree modules
omf << "CONFIG_MODULE_SIG := n" << endl;
+ // PR18389: disable GCC's Identical Code Folding, since the stubs may look identical
+ omf << "EXTRA_CFLAGS += $(call cc-option,-fno-ipa-icf)" << endl;
+
if (s.kernel_source_tree != "")
omf << "EXTRA_CFLAGS += -I" + s.kernel_source_tree << endl;
--
2.4.0

View File

@ -68,7 +68,7 @@
Name: systemtap
Version: 2.7
Release: 1%{?dist}
Release: 2%{?dist}
# for version, see also configure.ac
@ -103,6 +103,8 @@ License: GPLv2+
URL: http://sourceware.org/systemtap/
Source: ftp://sourceware.org/pub/systemtap/releases/systemtap-%{version}.tar.gz
Patch2: systemtap-2.7-disable-tracepoint-icf.patch
# Build*
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gcc-c++
@ -390,6 +392,8 @@ systemtap-runtime-virthost machine to execute systemtap scripts.
%prep
%setup -q %{?setup_elfutils}
%patch2 -p1
%if %{with_bundled_elfutils}
cd elfutils-%{elfutils_version}
%patch1 -p1
@ -1036,6 +1040,9 @@ done
# http://sourceware.org/systemtap/wiki/SystemTapReleases
%changelog
* Tue May 12 2015 Josh Stone <jistone@redhat.com> - 2.7-2
- Disable ICF when checking for available tracepoints.
* Wed Feb 18 2015 Frank Ch. Eigler <fche@redhat.com> - 2.7-1
- Upstream release.