bz840902 ppc build fix (related to bz837641)

This commit is contained in:
Josh Stone 2012-07-18 18:51:27 -07:00
parent 17dcdfd131
commit 4fb0fa448b
2 changed files with 34 additions and 6 deletions

View File

@ -1,4 +1,4 @@
(NB: changed paths in backport from master)
Squashed cherry-picks from upstream:
commit 037853b4644bb6ebd68e2f1fac11c3636f551d8e
Author: Josh Stone <jistone@redhat.com>
@ -24,11 +24,36 @@ Date: Mon Jul 9 12:07:48 2012 -0700
Those curious can watch this bug to see how the conflict is resolved:
https://bugzilla.redhat.com/show_bug.cgi?id=837641
commit d9b0c1c8712ff255d4b6171fdb0e1ec39f444501
Author: Josh Stone <jistone@redhat.com>
Date: Wed Jul 18 18:33:12 2012 -0700
Further tweak to glibc/kernel-headers workaround
... following commit 037853b4644bb6ebd68e2f1fac11c3636f551d8e, for
https://bugzilla.redhat.com/show_bug.cgi?id=840902
Seems it's not always possible to avoid linux/types.h for the conflict
it presents with sys/select.h. Now include linux/types.h very early, so
glibc can stomp over it with #undef and #define, rather than vice versa.
diff --git a/runtime/staprun/staprun.h b/runtime/staprun/staprun.h
index 28c7116..fe42cf2 100644
index d01a291..e9ce117 100644
--- a/runtime/staprun/staprun.h
+++ b/runtime/staprun/staprun.h
@@ -28,7 +28,6 @@
@@ -10,6 +10,11 @@
* Copyright (C) 2005-2008 Red Hat Inc.
*/
#define _FILE_OFFSET_BITS 64
+
+/* kernel-headers and glibc like to stomp on each other. We include this early
+ * so we can ensure glibc's own definitions will win. rhbz 837641 & 840902 */
+#include <linux/types.h>
+
#include <stdio.h>
#include <stdlib.h>
#include <ctype.h>
@@ -28,7 +33,6 @@
#include <sys/poll.h>
#include <pthread.h>
#include <sys/socket.h>

View File

@ -20,7 +20,7 @@
Name: systemtap
Version: 1.8
Release: 4%{?dist}
Release: 5%{?dist}
# for version, see also configure.ac
@ -90,7 +90,7 @@ BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
%endif
%endif
Patch2: bz837641-staprun-no-linux-types.patch
Patch2: bz837641-bz840902-linux-types.patch
Patch3: PR14348.patch
# Install requirements
@ -252,7 +252,7 @@ find . \( -name configure -o -name config.h.in \) -print | xargs touch
cd ..
%endif
# bz837641-staprun-no-linux-types.patch
# bz837641-bz840902-linux-types.patch
%patch2 -p1
%patch3 -p1
@ -586,6 +586,9 @@ exit 0
# ------------------------------------------------------------------------
%changelog
* Wed Jul 18 2012 Josh Stone <jistone@redhat.com> - 1.8-5
- bz840902 ppc build fix (related to bz837641)
* Fri Jul 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.8-4
- Fix ifarch statement
- use file based requires for glibc-devel on x86_64 so that we work in koji