Merge branch 'f22' into f21

* f22:
  systemtap 2.8 upstream release
  Automated weekly systemtap rawhide release: 0.20150601git1eed3df
  Automated weekly systemtap rawhide release: 0.20150525gita80691d
  Automated weekly systemtap rawhide release: 0.20150525git1f13f63
  Disable ICF when checking for available tracepoints.
  Automated weekly systemtap rawhide release: 0.20150504git6ca3ea7
  Automated weekly systemtap rawhide release: 0.20150427gitf80d9cd
  Automated weekly systemtap rawhide release: 0.20150420gitc054ce2
  Automated weekly systemtap rawhide release: 0.20150413git81e4501
  Automated weekly systemtap rawhide release: 0.20150330gitd31dab9
  Automated weekly systemtap rawhide release: 0.55.g07a1c230b47d
  Automated weekly systemtap rawhide release: 0.38.g3965aacd37c7
  Automated weekly systemtap rawhide release: 0.20.g784e796f37c8
  disable publican, pending bug triage
This commit is contained in:
Frank Ch. Eigler 2015-06-17 12:52:10 -04:00
commit 0c8ee78d92
4 changed files with 62 additions and 33 deletions

12
.gitignore vendored
View File

@ -139,3 +139,15 @@ systemtap-1.3.tar.gz
/systemtap-2.7-0.244.gc1a369fb16d9.tar.gz
/systemtap-2.7-0.284.gc1e8354302ba.tar.gz
/systemtap-2.7.tar.gz
/systemtap-2.8-0.20.g784e796f37c8.tar.gz
/systemtap-2.8-0.38.g3965aacd37c7.tar.gz
/systemtap-2.8-0.55.g07a1c230b47d.tar.gz
/systemtap-2.8-0.20150330gitd31dab9.tar.gz
/systemtap-2.8-0.20150413git81e4501.tar.gz
/systemtap-2.8-0.20150420gitc054ce2.tar.gz
/systemtap-2.8-0.20150427gitf80d9cd.tar.gz
/systemtap-2.8-0.20150504git6ca3ea7.tar.gz
/systemtap-2.8-0.20150525git1f13f63.tar.gz
/systemtap-2.8-0.20150525gita80691d.tar.gz
/systemtap-2.8-0.20150601git1eed3df.tar.gz
/systemtap-2.8.tar.gz

View File

@ -1 +1 @@
e0c3c36955323ae59be07a26a9563474 systemtap-2.7.tar.gz
2cb77a01b1522ecdb83df1c878160bc1 systemtap-2.8.tar.gz

View File

@ -0,0 +1,28 @@
From 8bb62408827f88d3694cb519eb5bb48ed6216092 Mon Sep 17 00:00:00 2001
From: Josh Stone <jistone@redhat.com>
Date: Fri, 8 May 2015 13:17:36 -0700
Subject: [PATCH] PR18389: disable ICF on tracepoint queries
We want distinct representation of every tracepoint, even if they happen
to look identical to GCC with the same function prototype.
---
buildrun.cxx | 3 +++
1 file changed, 3 insertions(+)
diff --git a/buildrun.cxx b/buildrun.cxx
index 44cb8feac47a..c7d96591f5de 100644
--- a/buildrun.cxx
+++ b/buildrun.cxx
@@ -853,6 +853,9 @@ make_tracequeries(systemtap_session& s, const map<string,string>& contents)
// RHBZ 655231: later rhel6 kernels' module-signing kbuild logic breaks out-of-tree modules
omf << "CONFIG_MODULE_SIG := n" << endl;
+ // PR18389: disable GCC's Identical Code Folding, since the stubs may look identical
+ omf << "EXTRA_CFLAGS += $(call cc-option,-fno-ipa-icf)" << endl;
+
if (s.kernel_source_tree != "")
omf << "EXTRA_CFLAGS += -I" + s.kernel_source_tree << endl;
--
2.4.0

View File

@ -11,16 +11,6 @@
%{!?elfutils_version: %global elfutils_version 0.142}
%{!?pie_supported: %global pie_supported 1}
%{!?with_boost: %global with_boost 0}
%ifarch ppc ppc64 %{sparc} aarch64 ppc64le
%{!?with_publican: %global with_publican 0}
%else
%{!?with_publican: %global with_publican 1}
%endif
%if 0%{?rhel}
%{!?publican_brand: %global publican_brand RedHat}
%else
%{!?publican_brand: %global publican_brand fedora}
%endif
%ifarch %{ix86} x86_64 ppc ppc64
%{!?with_dyninst: %global with_dyninst 0%{?fedora} >= 18 || 0%{?rhel} >= 7}
%else
@ -41,7 +31,7 @@
%endif
%{!?with_pyparsing: %global with_pyparsing 0%{?fedora} >= 18 || 0%{?rhel} >= 7}
%ifarch ppc64le
%ifarch ppc64le aarch64
%global with_virthost 0
%endif
@ -63,11 +53,10 @@
%endif
%endif
%define dracutlibdir %{_prefix}/lib/dracut
%define dracutstap %{dracutlibdir}/modules.d/99stap
%define dracutstap %{_prefix}/lib/dracut/modules.d/99stap
Name: systemtap
Version: 2.7
Version: 2.8
Release: 1%{?dist}
# for version, see also configure.ac
@ -103,6 +92,8 @@ License: GPLv2+
URL: http://sourceware.org/systemtap/
Source: ftp://sourceware.org/pub/systemtap/releases/systemtap-%{version}.tar.gz
Patch2: systemtap-2.7-disable-tracepoint-icf.patch
# Build*
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gcc-c++
@ -142,14 +133,6 @@ BuildRequires: tex(fullpage.sty) tex(fancybox.sty) tex(bchr7t.tfm)
# called 'xmlto-tex'. To avoid a specific F10 BuildReq, we'll do a
# file-based buildreq on '/usr/share/xmlto/format/fo/pdf'.
BuildRequires: xmlto /usr/share/xmlto/format/fo/pdf
%if %{with_publican}
BuildRequires: publican
BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
# A workaround for BZ920216 which requires an X server to build docs
# with publican.
BuildRequires: /usr/bin/xvfb-run
%endif
%endif
%if %{with_emacsvim}
BuildRequires: emacs
@ -390,6 +373,8 @@ systemtap-runtime-virthost machine to execute systemtap scripts.
%prep
%setup -q %{?setup_elfutils}
%patch2 -p1
%if %{with_bundled_elfutils}
cd elfutils-%{elfutils_version}
%patch1 -p1
@ -458,11 +443,6 @@ cd ..
%global pie_config --disable-pie
%endif
%if %{with_publican}
%global publican_config --enable-publican --with-publican-brand=%{publican_brand}
%else
%global publican_config --disable-publican
%endif
%if %{with_java}
%global java_config --with-java=%{_jvmdir}/java
@ -476,7 +456,13 @@ cd ..
%global virt_config --disable-virt
%endif
%configure %{?elfutils_config} %{dyninst_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{publican_config} %{rpm_config} %{java_config} %{virt_config} --disable-silent-rules --with-extra-version="rpm %{version}-%{release}"
%if %{with_dracut}
%global dracut_config --with-dracutstap=%{dracutstap}
%else
%global dracut_config
%endif
%configure %{?elfutils_config} %{dyninst_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{rpm_config} %{java_config} %{virt_config} %{dracut_config} --disable-silent-rules --with-extra-version="rpm %{version}-%{release}"
make %{?_smp_mflags}
%if %{with_emacsvim}
@ -520,10 +506,8 @@ cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
mkdir docs.installed
mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
%if %{with_publican}
mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
%endif
%endif
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/stap-server
@ -947,10 +931,8 @@ done
%if %{with_docs}
%doc docs.installed/*.pdf
%doc docs.installed/tapsets/*.html
%if %{with_publican}
%doc docs.installed/SystemTap_Beginners_Guide
%endif
%endif
%{_bindir}/stap
%{_bindir}/stap-prep
%{_bindir}/stap-report
@ -958,6 +940,7 @@ done
%{_mandir}/man1/stap-prep.1*
%{_mandir}/man1/stap-merge.1*
%{_mandir}/man1/stap-report.1*
%{_mandir}/man1/stapref.1*
%{_mandir}/man3/*
%{_mandir}/man7/error*
%{_mandir}/man7/stappaths.7*
@ -1036,6 +1019,12 @@ done
# http://sourceware.org/systemtap/wiki/SystemTapReleases
%changelog
* Wed Jun 17 2015 Abegail Jakop <ajakop@redhat.com> - 2.8-1
- Upstream release.
* Tue May 12 2015 Josh Stone <jistone@redhat.com> - 2.7-2
- Disable ICF when checking for available tracepoints.
* Wed Feb 18 2015 Frank Ch. Eigler <fche@redhat.com> - 2.7-1
- Upstream release.