systemd/0001-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
Colin Walters b1d608a2b3 Revert patch that breaks Atomic/OSTree (#1195761)
Conflicts:
	systemd.spec
2015-02-24 17:46:22 -05:00

28 lines
739 B
Diff

From eb7a760052667c5a35637901de9359c377263804 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Tue, 24 Feb 2015 10:12:28 -0500
Subject: [PATCH] Revert "core/mount: add dependencies to dynamically mounted
mounts too"
This reverts commit 06e97888883e2cc12eb6514e80c7f0014295f59b.
---
src/core/mount.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/core/mount.c b/src/core/mount.c
index 40037e7..cddb5e2 100644
--- a/src/core/mount.c
+++ b/src/core/mount.c
@@ -295,7 +295,7 @@ static int mount_add_device_links(Mount *m) {
assert(m);
- p = get_mount_parameters(m);
+ p = get_mount_parameters_fragment(m);
if (!p)
return 0;
--
1.8.3.1