systemd/0469-man-add-sd_event_set_n...

215 lines
7.5 KiB
Diff
Raw Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From 043f62949e6eb400ad42fd891a957ecf514c35f3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Thu, 2 Oct 2014 21:14:26 -0400
Subject: [PATCH] man: add sd_event_set_name(3)
---
Makefile-man.am | 7 +++
man/sd_event_set_name.xml | 151 ++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 158 insertions(+)
create mode 100644 man/sd_event_set_name.xml
diff --git a/Makefile-man.am b/Makefile-man.am
index aff5186c2d..a13e948bc8 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -735,6 +735,7 @@ MANPAGES += \
man/sd_event_add_time.3 \
man/sd_event_get_fd.3 \
man/sd_event_new.3 \
+ man/sd_event_set_name.3 \
man/systemd-bus-proxyd.8 \
man/systemd-bus-proxyd@.service.8
MANPAGES_ALIAS += \
@@ -795,6 +796,7 @@ MANPAGES_ALIAS += \
man/sd_event_add_exit.3 \
man/sd_event_add_post.3 \
man/sd_event_default.3 \
+ man/sd_event_get_name.3 \
man/sd_event_ref.3 \
man/sd_event_source_get_child_pid.3 \
man/sd_event_source_get_signal.3 \
@@ -862,6 +864,7 @@ man/sd_bus_unref.3: man/sd_bus_new.3
man/sd_event_add_exit.3: man/sd_event_add_defer.3
man/sd_event_add_post.3: man/sd_event_add_defer.3
man/sd_event_default.3: man/sd_event_new.3
+man/sd_event_get_name.3: man/sd_event_set_name.3
man/sd_event_ref.3: man/sd_event_new.3
man/sd_event_source_get_child_pid.3: man/sd_event_add_child.3
man/sd_event_source_get_signal.3: man/sd_event_add_signal.3
@@ -1043,6 +1046,9 @@ man/sd_event_add_post.html: man/sd_event_add_defer.html
man/sd_event_default.html: man/sd_event_new.html
$(html-alias)
+man/sd_event_get_name.html: man/sd_event_set_name.html
+ $(html-alias)
+
man/sd_event_ref.html: man/sd_event_new.html
$(html-alias)
@@ -1577,6 +1583,7 @@ EXTRA_DIST += \
man/sd_event_add_time.xml \
man/sd_event_get_fd.xml \
man/sd_event_new.xml \
+ man/sd_event_set_name.xml \
man/sd_get_seats.xml \
man/sd_id128_get_machine.xml \
man/sd_id128_randomize.xml \
diff --git a/man/sd_event_set_name.xml b/man/sd_event_set_name.xml
new file mode 100644
index 0000000000..406d124972
--- /dev/null
+++ b/man/sd_event_set_name.xml
@@ -0,0 +1,151 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+This file is part of systemd.
+
+Copyright 2014 Zbigniew Jędrzejewski-Szmek
+
+systemd is free software; you can redistribute it and/or modify it
+under the terms of the GNU Lesser General Public License as published by
+the Free Software Foundation; either version 2.1 of the License, or
+(at your option) any later version.
+
+systemd is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+Lesser General Public License for more details.
+
+You should have received a copy of the GNU Lesser General Public License
+along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="sd_event_get_fd" conditional="ENABLE_KDBUS"
+ xmlns:xi="http://www.w3.org/2001/XInclude">
+
+ <refentryinfo>
+ <title>sd_event_set_name</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>More text</contrib>
+ <firstname>Zbigniew</firstname>
+ <surname>Jędrzejewski-Szmek</surname>
+ <email>zbyszek@in.waw.pl</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>sd_event_set_name</refentrytitle>
+ <manvolnum>3</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>sd_event_set_name</refname>
+ <refname>sd_event_get_name</refname>
+
+ <refpurpose>Set human-readable names for event sources</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <funcsynopsis>
+ <funcsynopsisinfo>#include &lt;systemd/sd-bus.h&gt;</funcsynopsisinfo>
+
+ <funcprototype>
+ <funcdef>int <function>sd_event_set_name</function></funcdef>
+ <paramdef>sd_event_source *<parameter>source</parameter></paramdef>
+ <paramdef>const char *<parameter>name</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef>int <function>sd_event_get_name</function></funcdef>
+ <paramdef>sd_event_source *<parameter>source</parameter></paramdef>
+ <paramdef>const char **<parameter>name</parameter></paramdef>
+ </funcprototype>
+
+ </funcsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><function>sd_event_set_name()</function> can be used to set
+ an arbitrary name for the event source
+ <parameter>source</parameter>. This name will be used in error
+ messages generated by
+ <citerefentry><refentrytitle>sd-event</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ for this source. Specified <parameter>name</parameter> must point
+ to a <constant>NUL</constant>-terminated string or be
+ <constant>NULL</constant>. In the latter case, the name will be
+ unset. The string is copied internally, so the
+ <parameter>name</parameter> argument is not referenced after the
+ function returns.</para>
+
+ <para><function>sd_event_set_name()</function> can be used to
+ query the current name assigned to source
+ <parameter>source</parameter>. It returns a pointer to the current
+ name (possibly <constant>NULL</constant>) in
+ <parameter>name</parameter>.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Return Value</title>
+
+ <para>On success, <function>sd_event_set_name()</function> and
+ <function>sd_event_get_name()</function> return a
+ non-negative integer. On failure, they return a negative
+ errno-style error code.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Errors</title>
+
+ <para>Returned errors may indicate the following problems:</para>
+
+ <variablelist>
+ <varlistentry>
+ <term><constant>-EINVAL</constant></term>
+
+ <listitem><para><parameter>source</parameter> is not a valid
+ pointer to an <structname>sd_event_source</structname>
+ structure or the <parameter>name</parameter> argument for
+ <function>sd_event_get_name()</function> is
+ <constant>NULL</constant>.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term><constant>-ENOMEM</constant></term>
+
+ <listitem><para>Not enough memory to copy the
+ name.</para></listitem>
+ </varlistentry>
+ </variablelist>
+ </refsect1>
+
+ <refsect1>
+ <title>Notes</title>
+
+ <para>Functions described here are available as a
+ shared library, which can be compiled and linked to with the
+ <constant>libsystemd</constant> <citerefentry
+ project='die-net'><refentrytitle>pkg-config</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+ file.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+
+ <para>
+ <citerefentry><refentrytitle>sd-event</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_event_add_time</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_event_add_child</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_event_add_signal</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_event_add_defer</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_event_run</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>