systemd/0082-man-add-docs-for-sd_is...

135 lines
5.1 KiB
Diff

From 82e54a15fa202a67c9a9d2e53aad660f8a5ff36c Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Thu, 7 Nov 2013 17:51:09 +0100
Subject: [PATCH] man: add docs for sd_is_special() and some man page symlinks
Conflicts:
Makefile.am
---
Makefile-man.am | 15 +++++++++++++++
man/sd_is_fifo.xml | 17 +++++++++++++++++
man/sd_seat_get_active.xml | 2 ++
3 files changed, 34 insertions(+)
diff --git a/Makefile-man.am b/Makefile-man.am
index c8a4342..b8c8acc 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -138,6 +138,7 @@ MANPAGES_ALIAS += \
man/sd_is_socket.3 \
man/sd_is_socket_inet.3 \
man/sd_is_socket_unix.3 \
+ man/sd_is_special.3 \
man/sd_journal.3 \
man/sd_journal_add_conjunction.3 \
man/sd_journal_add_disjunction.3 \
@@ -238,6 +239,7 @@ man/sd_is_mq.3: man/sd_is_fifo.3
man/sd_is_socket.3: man/sd_is_fifo.3
man/sd_is_socket_inet.3: man/sd_is_fifo.3
man/sd_is_socket_unix.3: man/sd_is_fifo.3
+man/sd_is_special.3: man/sd_is_fifo.3
man/sd_journal.3: man/sd_journal_open.3
man/sd_journal_add_conjunction.3: man/sd_journal_add_match.3
man/sd_journal_add_disjunction.3: man/sd_journal_add_match.3
@@ -410,6 +412,9 @@ man/sd_is_socket_inet.html: man/sd_is_fifo.html
man/sd_is_socket_unix.html: man/sd_is_fifo.html
$(html-alias)
+man/sd_is_special.html: man/sd_is_fifo.html
+ $(html-alias)
+
man/sd_journal.html: man/sd_journal_open.html
$(html-alias)
@@ -844,7 +849,9 @@ MANPAGES_ALIAS += \
man/sd_pid_get_slice.3 \
man/sd_pid_get_unit.3 \
man/sd_pid_get_user_unit.3 \
+ man/sd_seat_can_graphical.3 \
man/sd_seat_can_multi_session.3 \
+ man/sd_seat_can_tty.3 \
man/sd_seat_get_sessions.3 \
man/sd_session_get_class.3 \
man/sd_session_get_display.3 \
@@ -873,7 +880,9 @@ man/sd_pid_get_owner_uid.3: man/sd_pid_get_session.3
man/sd_pid_get_slice.3: man/sd_pid_get_session.3
man/sd_pid_get_unit.3: man/sd_pid_get_session.3
man/sd_pid_get_user_unit.3: man/sd_pid_get_session.3
+man/sd_seat_can_graphical.3: man/sd_seat_get_active.3
man/sd_seat_can_multi_session.3: man/sd_seat_get_active.3
+man/sd_seat_can_tty.3: man/sd_seat_get_active.3
man/sd_seat_get_sessions.3: man/sd_seat_get_active.3
man/sd_session_get_class.3: man/sd_session_is_active.3
man/sd_session_get_display.3: man/sd_session_is_active.3
@@ -930,9 +939,15 @@ man/sd_pid_get_unit.html: man/sd_pid_get_session.html
man/sd_pid_get_user_unit.html: man/sd_pid_get_session.html
$(html-alias)
+man/sd_seat_can_graphical.html: man/sd_seat_get_active.html
+ $(html-alias)
+
man/sd_seat_can_multi_session.html: man/sd_seat_get_active.html
$(html-alias)
+man/sd_seat_can_tty.html: man/sd_seat_get_active.html
+ $(html-alias)
+
man/sd_seat_get_sessions.html: man/sd_seat_get_active.html
$(html-alias)
diff --git a/man/sd_is_fifo.xml b/man/sd_is_fifo.xml
index 2bc860c..4d9cd79 100644
--- a/man/sd_is_fifo.xml
+++ b/man/sd_is_fifo.xml
@@ -48,6 +48,7 @@
<refname>sd_is_socket_inet</refname>
<refname>sd_is_socket_unix</refname>
<refname>sd_is_mq</refname>
+ <refname>sd_is_special</refname>
<refpurpose>Check the type of a file descriptor</refpurpose>
</refnamediv>
@@ -93,6 +94,12 @@
<paramdef>const char *<parameter>path</parameter></paramdef>
</funcprototype>
+ <funcprototype>
+ <funcdef>int <function>sd_is_special</function></funcdef>
+ <paramdef>int <parameter>fd</parameter></paramdef>
+ <paramdef>const char *<parameter>path</parameter></paramdef>
+ </funcprototype>
+
</funcsynopsis>
</refsynopsisdiv>
@@ -153,6 +160,16 @@
<parameter>path</parameter> parameter is not
<constant>NULL</constant>, it is checked whether the
message queue is bound to the specified name.</para>
+
+ <para><function>sd_is_special()</function> may be
+ called to check whether the specified file descriptor
+ refers to a special file. If the
+ <parameter>path</parameter> parameter is not
+ <constant>NULL</constant>, it is checked whether file
+ descriptor is bound to the specified file
+ name. Special files in this context are character
+ device nodes and files in <filename>/proc</filename>
+ or <filename>/sys</filename>.</para>
</refsect1>
<refsect1>
diff --git a/man/sd_seat_get_active.xml b/man/sd_seat_get_active.xml
index 1610d3e..cd87696 100644
--- a/man/sd_seat_get_active.xml
+++ b/man/sd_seat_get_active.xml
@@ -46,6 +46,8 @@
<refname>sd_seat_get_active</refname>
<refname>sd_seat_get_sessions</refname>
<refname>sd_seat_can_multi_session</refname>
+ <refname>sd_seat_can_tty</refname>
+ <refname>sd_seat_can_graphical</refname>
<refpurpose>Determine state of a specific seat</refpurpose>
</refnamediv>