systemd/0059-zsh-completion-add-sys...

61 lines
2.0 KiB
Diff

From 0f25880b6e0feea046923d2d796e6e10abdd7c6a Mon Sep 17 00:00:00 2001
From: Ronny Chevalier <chevalier.ronny@gmail.com>
Date: Wed, 30 Oct 2013 21:57:44 +0100
Subject: [PATCH] zsh-completion: add systemd-run
---
Makefile.am | 1 +
shell-completion/zsh/_systemd-run | 31 +++++++++++++++++++++++++++++++
2 files changed, 32 insertions(+)
create mode 100644 shell-completion/zsh/_systemd-run
diff --git a/Makefile.am b/Makefile.am
index 5e3e5d2..7ab345a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -352,6 +352,7 @@ dist_zshcompletion_DATA = \
shell-completion/zsh/_kernel-install \
shell-completion/zsh/_systemd-nspawn \
shell-completion/zsh/_systemd-analyze \
+ shell-completion/zsh/_systemd-run \
shell-completion/zsh/_sd_hosts_or_user_at_host \
shell-completion/zsh/_systemd-delta \
shell-completion/zsh/_systemd
diff --git a/shell-completion/zsh/_systemd-run b/shell-completion/zsh/_systemd-run
new file mode 100644
index 0000000..0c81c54
--- /dev/null
+++ b/shell-completion/zsh/_systemd-run
@@ -0,0 +1,31 @@
+#compdef systemd-run
+
+__systemctl() {
+ local -a _modes
+ _modes=("--user" "--system")
+ systemctl ${words:*_modes} --full --no-legend --no-pager "$@" 2>/dev/null
+}
+
+__get_slices () {
+ __systemctl list-units --all -t slice \
+ | { while read -r a b; do echo $a; done; };
+}
+
+__slices () {
+ local -a _slices
+ _slices=(${(fo)"$(__get_slices)"})
+ typeset -U _slices
+ _describe 'slices' _slices
+}
+
+_arguments \
+ {-h,--help}'[Show help message]' \
+ '--version[Show package version]' \
+ '--user[Run as user unit]' \
+ '--scope[Run this as scope rather than service]' \
+ '--unit=[Run under the specified unit name]:unit name' \
+ '--description=[Description for unit]:description' \
+ '--slice=[Run in the specified slice]:slices:__slices' \
+ {-r,--remain-after-exit}'[Leave service around until explicitly stopped]' \
+ '--send-sighup[Send SIGHUP when terminating]' \
+ '*::command:_command'