systemd/0013-build-sys-don-t-hard-c...

120 lines
4.6 KiB
Diff

From 7b40ce553f0ec9487077e53f5bdc46580025901c Mon Sep 17 00:00:00 2001
From: Michael Biebl <biebl@debian.org>
Date: Sat, 9 Mar 2013 09:46:11 +0100
Subject: [PATCH] build-sys: don't hard-code binary paths in initrd-*.service
Instead use @bindir@ for udevadm and @rootbindir@ for systemctl.
---
Makefile.am | 16 ++++++++++------
...{initrd-cleanup.service => initrd-cleanup.service.in} | 2 +-
...trd-parse-etc.service => initrd-parse-etc.service.in} | 6 +++---
...switch-root.service => initrd-switch-root.service.in} | 2 +-
...p-db.service => initrd-udevadm-cleanup-db.service.in} | 2 +-
5 files changed, 16 insertions(+), 12 deletions(-)
rename units/{initrd-cleanup.service => initrd-cleanup.service.in} (87%)
rename units/{initrd-parse-etc.service => initrd-parse-etc.service.in} (75%)
rename units/{initrd-switch-root.service => initrd-switch-root.service.in} (88%)
rename units/{initrd-udevadm-cleanup-db.service => initrd-udevadm-cleanup-db.service.in} (93%)
diff --git a/Makefile.am b/Makefile.am
index 05bf582..afd259a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -382,11 +382,7 @@ dist_systemunit_DATA = \
units/systemd-udevd-control.socket \
units/systemd-udevd-kernel.socket \
units/system-update.target \
- units/initrd-parse-etc.service \
- units/initrd-cleanup.service \
- units/initrd-switch-root.target \
- units/initrd-udevadm-cleanup-db.service \
- units/initrd-switch-root.service
+ units/initrd-switch-root.target
nodist_systemunit_DATA = \
units/getty@.service \
@@ -418,7 +414,11 @@ nodist_systemunit_DATA = \
units/systemd-udevd.service \
units/systemd-udev-trigger.service \
units/systemd-udev-settle.service \
- units/debug-shell.service
+ units/debug-shell.service \
+ units/initrd-parse-etc.service \
+ units/initrd-cleanup.service \
+ units/initrd-udevadm-cleanup-db.service \
+ units/initrd-switch-root.service
dist_userunit_DATA = \
units/user/default.target \
@@ -460,6 +460,10 @@ EXTRA_DIST += \
units/systemd-hybrid-sleep.service.in \
units/systemd-suspend.service.in \
units/quotaon.service.in \
+ units/initrd-parse-etc.service.in \
+ units/initrd-cleanup.service.in \
+ units/initrd-udevadm-cleanup-db.service.in \
+ units/initrd-switch-root.service.in \
introspect.awk \
man/custom-html.xsl
diff --git a/units/initrd-cleanup.service b/units/initrd-cleanup.service.in
similarity index 87%
rename from units/initrd-cleanup.service
rename to units/initrd-cleanup.service.in
index 8998696..e926a1e 100644
--- a/units/initrd-cleanup.service
+++ b/units/initrd-cleanup.service.in
@@ -15,4 +15,4 @@ After=local-fs.target swap.target
[Service]
Type=oneshot
-ExecStart=/usr/bin/systemctl --no-block isolate initrd-switch-root.target
+ExecStart=@rootbindir@/systemctl --no-block isolate initrd-switch-root.target
diff --git a/units/initrd-parse-etc.service b/units/initrd-parse-etc.service.in
similarity index 75%
rename from units/initrd-parse-etc.service
rename to units/initrd-parse-etc.service.in
index 3a71a7e..1a2711a 100644
--- a/units/initrd-parse-etc.service
+++ b/units/initrd-parse-etc.service.in
@@ -15,6 +15,6 @@ ConditionPathExists=/etc/initrd-release
[Service]
Type=oneshot
-ExecStartPre=/usr/bin/systemctl daemon-reload
-ExecStart=/usr/bin/systemctl start local-fs.target
-ExecStart=/usr/bin/systemctl --no-block start initrd-cleanup.service
+ExecStartPre=@rootbindir@/systemctl daemon-reload
+ExecStart=@rootbindir@/systemctl start local-fs.target
+ExecStart=@rootbindir@/systemctl --no-block start initrd-cleanup.service
diff --git a/units/initrd-switch-root.service b/units/initrd-switch-root.service.in
similarity index 88%
rename from units/initrd-switch-root.service
rename to units/initrd-switch-root.service.in
index e076b39..6740264 100644
--- a/units/initrd-switch-root.service
+++ b/units/initrd-switch-root.service.in
@@ -15,5 +15,5 @@ AllowIsolate=yes
[Service]
Type=oneshot
# we have to use "--force" here, otherwise systemd would umount /run
-ExecStart=/usr/bin/systemctl --no-block --force switch-root /sysroot
+ExecStart=@rootbindir@/systemctl --no-block --force switch-root /sysroot
KillMode=none
diff --git a/units/initrd-udevadm-cleanup-db.service b/units/initrd-udevadm-cleanup-db.service.in
similarity index 93%
rename from units/initrd-udevadm-cleanup-db.service
rename to units/initrd-udevadm-cleanup-db.service.in
index 983189e..b800c21 100644
--- a/units/initrd-udevadm-cleanup-db.service
+++ b/units/initrd-udevadm-cleanup-db.service.in
@@ -15,4 +15,4 @@ Before=initrd-switch-root.target
[Service]
Type=oneshot
-ExecStart=-/usr/bin/udevadm info --cleanup-db
+ExecStart=-@bindir@/udevadm info --cleanup-db
--
1.8.1