Fix FTBFS and cyclical rpm deps

- Fix cyclical dep between systemd and systemd-libs.
- Avoid broken build of test-journal-syslog.
- https://bugzilla.redhat.com/show_bug.cgi?id=873387
- https://bugzilla.redhat.com/show_bug.cgi?id=872638
This commit is contained in:
Michal Schmidt 2012-11-09 14:17:50 +01:00
parent 55f9207f1c
commit b42e57b4be
2 changed files with 34 additions and 2 deletions

View File

@ -0,0 +1,22 @@
Index: systemd-195/Makefile.in
===================================================================
--- systemd-195.orig/Makefile.in
+++ systemd-195/Makefile.in
@@ -83,7 +83,7 @@ noinst_PROGRAMS = test-engine$(EXEEXT) t
test-unit-file$(EXEEXT) test-date$(EXEEXT) \
test-libudev$(EXEEXT) test-udev$(EXEEXT) test-id128$(EXEEXT) \
test-journal$(EXEEXT) test-journal-send$(EXEEXT) \
- test-journal-syslog$(EXEEXT) test-journal-match$(EXEEXT) \
+ test-journal-match$(EXEEXT) \
test-journal-stream$(EXEEXT) test-journal-verify$(EXEEXT) \
test-mmap-cache$(EXEEXT) $(am__EXEEXT_4)
TESTS = test-job-type$(EXEEXT) test-env-replace$(EXEEXT) \
@@ -91,7 +91,7 @@ TESTS = test-job-type$(EXEEXT) test-env-
test-unit-file$(EXEEXT) test-date$(EXEEXT) test/udev-test.pl \
test/rules-test.sh $(am__append_40) test-id128$(EXEEXT) \
test-journal$(EXEEXT) test-journal-send$(EXEEXT) \
- test-journal-syslog$(EXEEXT) test-journal-match$(EXEEXT) \
+ test-journal-match$(EXEEXT) \
test-journal-stream$(EXEEXT) test-journal-verify$(EXEEXT) \
test-mmap-cache$(EXEEXT)
udevlibexec_PROGRAMS = ata_id$(EXEEXT) cdrom_id$(EXEEXT) \

View File

@ -22,7 +22,7 @@ Url: http://www.freedesktop.org/wiki/Software/systemd
# THIS PACKAGE FOR A NON-RAWHIDE DEVELOPMENT DISTRIBUTION!
Version: 195
Release: 5%{?gitcommit:.git%{gitcommit}}%{?dist}
Release: 6%{?gitcommit:.git%{gitcommit}}%{?dist}
# For a breakdown of the licensing, see README
License: LGPLv2+ and MIT and GPLv2+
Summary: A System and Service Manager
@ -67,6 +67,7 @@ Requires: dbus
Requires: hwdata
Requires: filesystem >= 3
Requires: nss-myhostname
Requires: %{name}-libs = %{version}-%{release}
%if %{defined gitcommit}
# Snapshot tarball can be created using: ./make-git-shapshot.sh [gitcommit]
Source0: %{name}-git%{gitcommit}.tar.xz
@ -85,6 +86,9 @@ Source4: listen.conf
# Prevent accidental removal of the systemd package
Source6: yum-protect-systemd.conf
# Temporary workaround for build error https://bugzilla.redhat.com/show_bug.cgi?id=872638
Patch0: disable-broken-test-build.patch
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
Provides: SysVinit = 2.86-24, sysvinit = 2.86-24
Provides: sysvinit-userspace
@ -122,7 +126,6 @@ work as a drop-in replacement for sysvinit.
%package libs
Summary: systemd libraries
License: LGPLv2+ and MIT
Requires: %{name} = %{version}-%{release}
Obsoletes: libudev < 183
Obsoletes: systemd < 185-4
Conflicts: systemd < 185-4
@ -192,6 +195,7 @@ glib-based applications using libudev functionality.
%prep
%setup -q %{?gitcommit:-n %{name}-git%{gitcommit}}
%patch0 -p1
%build
%{?gitcommit: ./autogen.sh }
@ -703,6 +707,12 @@ fi
%{_libdir}/pkgconfig/gudev-1.0*
%changelog
* Fri Nov 09 2012 Michal Schmidt <mschmidt@redhat.com> - 195-6
- Fix cyclical dep between systemd and systemd-libs.
- Avoid broken build of test-journal-syslog.
- https://bugzilla.redhat.com/show_bug.cgi?id=873387
- https://bugzilla.redhat.com/show_bug.cgi?id=872638
* Thu Oct 25 2012 Kay Sievers <kay@redhat.com> - 195-5
- require 'sed', limit HOSTNAME= match