Really fix build with gnu-efi-3.0.11-13

It turns out that the patch applied cleanly when backported to
v253-stable, but did not work.

[skip changelog]
This commit is contained in:
Zbigniew Jędrzejewski-Szmek 2023-03-03 20:11:48 +01:00
parent ddd4dcd1fe
commit 5227302c98
2 changed files with 17 additions and 6 deletions

View File

@ -1,15 +1,17 @@
From b3ec28645a2e02d03fa0d4a618802292540acf43 Mon Sep 17 00:00:00 2001
From e2f169f816809ad4db9ebca080c73b36810f7bdc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Fri, 3 Mar 2023 16:08:41 +0100
Subject: [PATCH] meson: adjust for removal of gnu-efi compat
gnu-efi-3.0.11-13.fc39 in Fedora dropped the old include paths.
/usr/include/efi/efi.h uses 'include "efibind.h"', so we cannot use -isystem.
---
src/boot/efi/meson.build | 24 ++++++++++++++----------
1 file changed, 14 insertions(+), 10 deletions(-)
src/boot/efi/meson.build | 26 +++++++++++++++-----------
1 file changed, 15 insertions(+), 11 deletions(-)
diff --git a/src/boot/efi/meson.build b/src/boot/efi/meson.build
index bf595c33901e..ea55f1c9fa52 100644
index 6c1934d9f1..68c5dd15dc 100644
--- a/src/boot/efi/meson.build
+++ b/src/boot/efi/meson.build
@@ -19,7 +19,7 @@ elif efi_arch == 'x86_64' and '-m32' in get_option('efi-cflags')
@ -56,7 +58,16 @@ index bf595c33901e..ea55f1c9fa52 100644
if get_option('gnu-efi') == 'true'
error('gnu-efi support requested, but found headers are too old (3.0.5+ required)')
@@ -313,7 +317,7 @@ summary({
@@ -184,7 +188,7 @@ efi_cflags = [
'-I', meson.current_source_dir(),
'-include', efi_config_h,
'-include', version_h,
- '-isystem', efi_incdir / efi_arch[1],
+ '-I', efi_archdir,
'-isystem', efi_incdir,
'-std=gnu11',
'-Wall',
@@ -315,7 +319,7 @@ summary({
'EFI LD' : efi_ld,
'EFI lds' : efi_lds,
'EFI crt0' : efi_crt0,

View File

@ -96,7 +96,7 @@ GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[
Patch0001: https://github.com/systemd/systemd/pull/26494.patch
# Fix build with gnu-efi-3.0.11-13.fc39
Patch0002: https://github.com/systemd/systemd/pull/26659.patch
Patch0002: https://github.com/systemd/systemd-stable/pull/265.patch
# Those are downstream-only patches, but we don't want them in packit builds:
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828