Add patch for new kernel headers
It's already included in systemd-stable, but v250.4 hasn't been tagged yet.
This commit is contained in:
parent
e48b9066b7
commit
4c2d7265ec
65
bbe53713455be38c0a587626439fd171f28c77fc.patch
Normal file
65
bbe53713455be38c0a587626439fd171f28c77fc.patch
Normal file
@ -0,0 +1,65 @@
|
||||
From bbe53713455be38c0a587626439fd171f28c77fc Mon Sep 17 00:00:00 2001
|
||||
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
||||
Date: Sun, 30 Jan 2022 23:40:05 +0100
|
||||
Subject: [PATCH] basic: update CIFS magic
|
||||
|
||||
Kernel commit dea2903719283c156b53741126228c4a1b40440f exposed (and
|
||||
renamed) CIFS_MAGIC_NUMBER as CIFS_SUPER_MAGIC along with
|
||||
SMB2_SUPER_MAGIC.
|
||||
|
||||
This fixes the following build fail on current Fedora Rawhide:
|
||||
```
|
||||
../src/basic/meson.build:389:8: ERROR: Problem encountered: found unknown filesystem(s) defined in kernel headers:
|
||||
|
||||
Filesystem found in kernel header but not in filesystems-gperf.gperf: CIFS_SUPER_MAGIC
|
||||
Filesystem found in kernel header but not in filesystems-gperf.gperf: SMB2_SUPER_MAGIC
|
||||
```
|
||||
---
|
||||
src/basic/filesystems-gperf.gperf | 4 ++--
|
||||
src/basic/missing_magic.h | 11 ++++++++---
|
||||
2 files changed, 10 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/basic/filesystems-gperf.gperf b/src/basic/filesystems-gperf.gperf
|
||||
index 08c8c445105a..e8c5357f9146 100644
|
||||
--- a/src/basic/filesystems-gperf.gperf
|
||||
+++ b/src/basic/filesystems-gperf.gperf
|
||||
@@ -40,7 +40,7 @@ ceph, {CEPH_SUPER_MAGIC}
|
||||
cgroup2, {CGROUP2_SUPER_MAGIC}
|
||||
# note that the cgroupfs magic got reassigned from cpuset
|
||||
cgroup, {CGROUP_SUPER_MAGIC}
|
||||
-cifs, {CIFS_MAGIC_NUMBER}
|
||||
+cifs, {CIFS_SUPER_MAGIC, SMB2_SUPER_MAGIC}
|
||||
coda, {CODA_SUPER_MAGIC}
|
||||
configfs, {CONFIGFS_MAGIC}
|
||||
cramfs, {CRAMFS_MAGIC}
|
||||
@@ -109,7 +109,7 @@ selinuxfs, {SELINUX_MAGIC}
|
||||
shiftfs, {SHIFTFS_MAGIC}
|
||||
smackfs, {SMACK_MAGIC}
|
||||
# smb3 is an alias for cifs
|
||||
-smb3, {CIFS_MAGIC_NUMBER}
|
||||
+smb3, {CIFS_SUPER_MAGIC}
|
||||
# smbfs was removed from the kernel in 2010, the magic remains
|
||||
smbfs, {SMB_SUPER_MAGIC}
|
||||
sockfs, {SOCKFS_MAGIC}
|
||||
diff --git a/src/basic/missing_magic.h b/src/basic/missing_magic.h
|
||||
index 7d9320bb6dc9..c104fcfba315 100644
|
||||
--- a/src/basic/missing_magic.h
|
||||
+++ b/src/basic/missing_magic.h
|
||||
@@ -38,9 +38,14 @@
|
||||
#define XFS_SB_MAGIC 0x58465342
|
||||
#endif
|
||||
|
||||
-/* Not exposed yet. Defined at fs/cifs/cifsglob.h */
|
||||
-#ifndef CIFS_MAGIC_NUMBER
|
||||
-#define CIFS_MAGIC_NUMBER 0xFF534D42
|
||||
+/* dea2903719283c156b53741126228c4a1b40440f (5.17) */
|
||||
+#ifndef CIFS_SUPER_MAGIC
|
||||
+#define CIFS_SUPER_MAGIC 0xFF534D42
|
||||
+#endif
|
||||
+
|
||||
+/* dea2903719283c156b53741126228c4a1b40440f (5.17) */
|
||||
+#ifndef SMB2_SUPER_MAGIC
|
||||
+#define SMB2_SUPER_MAGIC 0xFE534D42
|
||||
#endif
|
||||
|
||||
/* 257f871993474e2bde6c497b54022c362cf398e1 (4.5) */
|
@ -90,7 +90,7 @@ GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[
|
||||
# Any patches which are "in preparation" upstream should be listed
|
||||
# here, rather than in the next section. Packit CI will drop any
|
||||
# patches in this range before applying upstream pull requests.
|
||||
|
||||
Patch: https://github.com/systemd/systemd/commit/bbe53713455be38c0a587626439fd171f28c77fc.patch
|
||||
|
||||
# Downstream-only patches (5000–9999)
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828
|
||||
|
Loading…
Reference in New Issue
Block a user