sympy/sympy-0.7.2-strip-internal-mpmath.patch
Jerry James a2507d0743 Update to 0.7.2 (bz 866044).
Add python-pyglet R (bz 890312).
Package the TeXmacs integration.
Build and provide documentation.
Provide examples.
Minor spec file cleanups.
2013-07-01 15:03:59 -06:00

905 lines
34 KiB
Diff

--- ./examples/advanced/pidigits.py.orig 2012-08-30 11:54:11.000000000 -0600
+++ ./examples/advanced/pidigits.py 2013-06-18 09:08:54.085202508 -0600
@@ -6,8 +6,8 @@ Example shows arbitrary precision using
computation of the digits of pi.
"""
-from sympy.mpmath import libmp, pi
-from sympy.mpmath import functions as mpf_funs
+from mpmath import libmp, pi
+from mpmath import functions as mpf_funs
import math
from time import clock
--- ./examples/advanced/autowrap_ufuncify.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./examples/advanced/autowrap_ufuncify.py 2013-06-18 09:08:54.085202508 -0600
@@ -25,7 +25,7 @@ np = import_module('numpy')
if not np:
sys.exit("Cannot import numpy. Exiting.")
-import sympy.mpmath as mpmath
+import mpmath as mpmath
from sympy.utilities.autowrap import ufuncify
from sympy.utilities.lambdify import implemented_function
from sympy import symbols, legendre, Plot, pprint
--- ./setup.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./setup.py 2013-06-18 09:10:47.618994525 -0600
@@ -65,11 +65,6 @@ modules = [
'sympy.logic.utilities',
'sympy.matrices',
'sympy.matrices.expressions',
- 'sympy.mpmath',
- 'sympy.mpmath.calculus',
- 'sympy.mpmath.functions',
- 'sympy.mpmath.libmp',
- 'sympy.mpmath.matrices',
'sympy.ntheory',
'sympy.parsing',
'sympy.physics',
@@ -220,7 +215,6 @@ tests = [
'sympy.logic.tests',
'sympy.matrices.expressions.tests',
'sympy.matrices.tests',
- 'sympy.mpmath.tests',
'sympy.ntheory.tests',
'sympy.parsing.tests',
'sympy.physics.mechanics.tests',
--- ./sympy/utilities/tests/test_lambdify.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/utilities/tests/test_lambdify.py 2013-06-18 09:08:54.087202505 -0600
@@ -2,7 +2,7 @@ from sympy.utilities.pytest import XFAIL
from sympy import (symbols, lambdify, sqrt, sin, cos, pi, atan, Rational, Float,
Matrix, Lambda, exp, Integral, oo, I, Abs)
from sympy.printing.lambdarepr import LambdaPrinter
-from sympy import mpmath
+import mpmath
from sympy.utilities.lambdify import implemented_function
from sympy.utilities.pytest import skip
from sympy.utilities.decorator import conserve_mpmath_dps
--- ./sympy/utilities/decorator.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/utilities/decorator.py 2013-06-18 09:08:54.088202503 -0600
@@ -67,7 +67,7 @@ def xthreaded(func):
def conserve_mpmath_dps(func):
"""After the function finishes, resets the value of mpmath.mp.dps to the value it had before the function was run."""
import functools
- from sympy import mpmath
+ import mpmath
def func_wrapper():
dps = mpmath.mp.dps
--- ./sympy/utilities/lambdify.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/utilities/lambdify.py 2013-06-18 09:08:54.086202506 -0600
@@ -77,7 +77,7 @@ NUMPY_TRANSLATIONS = {
# Available modules:
MODULES = {
"math" : (MATH, MATH_DEFAULT, MATH_TRANSLATIONS, ("from math import *",)),
- "mpmath" : (MPMATH, MPMATH_DEFAULT, MPMATH_TRANSLATIONS, ("from sympy.mpmath import *",)),
+ "mpmath" : (MPMATH, MPMATH_DEFAULT, MPMATH_TRANSLATIONS, ("from mpmath import *",)),
"numpy" : (NUMPY, NUMPY_DEFAULT, NUMPY_TRANSLATIONS, ("import_module('numpy')",)),
"sympy" : (SYMPY, SYMPY_DEFAULT, {}, ("from sympy.functions import *",
"from sympy.matrices import Matrix",
--- ./sympy/utilities/runtests.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/utilities/runtests.py 2013-06-18 09:08:54.087202505 -0600
@@ -516,7 +516,7 @@ def _doctest(*paths, **kwargs):
blacklist = kwargs.get("blacklist", [])
blacklist.extend([
"doc/src/modules/mpmath", # needs to be fixed upstream
- "sympy/mpmath", # needs to be fixed upstream
+ "mpmath", # needs to be fixed upstream
"doc/src/modules/plotting.rst", # generates live plots
# "sympy/plotting", # generates live plots
"sympy/plotting/pygletplot", # generates live plots
--- ./sympy/solvers/tests/test_numeric.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/solvers/tests/test_numeric.py 2013-06-18 09:08:54.088202503 -0600
@@ -1,5 +1,5 @@
from sympy import Eq, Matrix, pi, sin, sqrt, Symbol, Integral, Piecewise, symbols
-from sympy.mpmath import mnorm, mpf
+from mpmath import mnorm, mpf
from sympy.solvers import nsolve
from sympy.utilities.lambdify import lambdify
from sympy.utilities.pytest import raises, XFAIL
--- ./sympy/solvers/solvers.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/solvers/solvers.py 2013-06-18 09:51:06.016185128 -0600
@@ -38,7 +38,7 @@ from sympy.functions.elementary.piecewis
from sympy.utilities.iterables import lazyDSU_sort
from sympy.utilities.lambdify import lambdify
from sympy.utilities.misc import default_sort_key, filldedent
-from sympy.mpmath import findroot
+from mpmath import findroot
from sympy.solvers.polysys import solve_poly_system
from sympy.solvers.inequalities import reduce_inequalities
@@ -1991,8 +1991,8 @@ def nsolve(*args, **kwargs):
Overdetermined systems are supported.
>>> from sympy import Symbol, nsolve
- >>> import sympy
- >>> sympy.mpmath.mp.dps = 15
+ >>> import mpmath, sympy
+ >>> mpmath.mp.dps = 15
>>> x1 = Symbol('x1')
>>> x2 = Symbol('x2')
>>> f1 = 3 * x1**2 - 2 * x2**2 - 1
--- ./sympy/ntheory/partitions_.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/ntheory/partitions_.py 2013-06-18 09:08:54.089202501 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath.libmp import (fzero,
+from mpmath.libmp import (fzero,
from_man_exp, from_int, from_rational,
fone, fhalf, bitcount, to_int, to_str, mpf_mul, mpf_div, mpf_sub,
mpf_add, mpf_sqrt, mpf_pi, mpf_cosh_sinh, pi_fixed, mpf_cos)
--- ./sympy/statistics/tests/test_statistics.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/statistics/tests/test_statistics.py 2013-06-18 09:08:54.089202501 -0600
@@ -3,7 +3,7 @@ from sympy.functions import erf
from operator import abs
-from sympy.mpmath import mp
+from mpmath import mp
# Disable sympy.statistics deprecation warning for the tests
# The warning is in __init__.py, so we only need to disable it for imports
--- ./sympy/statistics/distributions.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/statistics/distributions.py 2013-06-18 09:08:54.090202499 -0600
@@ -207,7 +207,7 @@ class Normal(ContinuousProbability):
# error function is not yet implemented in SymPy but can easily be
# computed numerically
- from sympy.mpmath import mpf, erfinv
+ from mpmath import mpf, erfinv
# calculate y = ierf(p) by solving erf(y) - p = 0
y = erfinv(mpf(p))
--- ./sympy/printing/repr.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/printing/repr.py 2013-06-18 09:08:54.090202499 -0600
@@ -6,8 +6,8 @@ relation eval(srepr(expr))=expr holds in
"""
from printer import Printer
-import sympy.mpmath.libmp as mlib
-from sympy.mpmath.libmp import prec_to_dps, repr_dps
+import mpmath.libmp as mlib
+from mpmath.libmp import prec_to_dps, repr_dps
class ReprPrinter(Printer):
printmethod = "_sympyrepr"
--- ./sympy/printing/str.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/printing/str.py 2013-06-18 09:08:54.091202497 -0600
@@ -7,8 +7,8 @@ from sympy.core.function import _coeff_i
from printer import Printer
from sympy.printing.precedence import precedence, PRECEDENCE
-import sympy.mpmath.libmp as mlib
-from sympy.mpmath.libmp import prec_to_dps
+import mpmath.libmp as mlib
+from mpmath.libmp import prec_to_dps
from sympy.polys.polyerrors import PolynomialError
--- ./sympy/printing/latex.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/printing/latex.py 2013-06-18 09:08:54.091202497 -0600
@@ -9,8 +9,8 @@ from conventions import split_super_sub
from sympy.simplify import fraction
from sympy.core.sympify import SympifyError
-import sympy.mpmath.libmp as mlib
-from sympy.mpmath.libmp import prec_to_dps
+import mpmath.libmp as mlib
+from mpmath.libmp import prec_to_dps
from sympy.utilities.misc import default_sort_key
from sympy.utilities.iterables import has_variety
--- ./sympy/combinatorics/permutations.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/combinatorics/permutations.py 2013-06-18 09:08:54.092202496 -0600
@@ -7,7 +7,7 @@ from sympy.utilities.iterables import (f
has_dups, runs)
from sympy.polys.polytools import lcm
from sympy.matrices import zeros
-from sympy.mpmath.libmp.libintmath import ifac
+from mpmath.libmp.libintmath import ifac
def _af_rmul(a, b):
"""
--- ./sympy/core/tests/test_evalf.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/core/tests/test_evalf.py 2013-06-18 09:08:54.094202492 -0600
@@ -2,9 +2,9 @@ from sympy import (Add, ceiling, cos, E,
Function, GoldenRatio, I, log, Mul, oo, pi, Pow, Rational,
sin, sqrt, sstr, Sum, sympify, S, integrate, atan, product)
from sympy.core.evalf import complex_accuracy, PrecisionExhausted, scaled_zero
-from sympy.mpmath import inf, ninf, nan
+from mpmath import inf, ninf, nan
from sympy.abc import n, x, y
-from sympy.mpmath.libmp.libmpf import from_float
+from mpmath.libmp.libmpf import from_float
from sympy.utilities.pytest import raises, XFAIL
def NS(e, n=15, **options):
--- ./sympy/core/tests/test_sympify.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/core/tests/test_sympify.py 2013-06-18 09:08:54.093202494 -0600
@@ -9,7 +9,7 @@ from sympy.utilities.decorator import co
from sympy.geometry import Point, Line
from sympy.functions.combinatorial.factorials import factorial, factorial2
-from sympy import mpmath
+import mpmath
def test_439():
v = sympify("exp(x)")
--- ./sympy/core/tests/test_numbers.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/core/tests/test_numbers.py 2013-06-18 09:08:54.095202490 -0600
@@ -7,7 +7,7 @@ from sympy.utilities.pytest import XFAIL
from sympy.core.numbers import igcd, ilcm, igcdex, seterr, _intcache
from sympy.utilities.pytest import raises
-from sympy import mpmath
+import mpmath
def test_integers_cache():
python_int = 2**65 + 3175259
@@ -499,7 +499,7 @@ def test_Infinity():
assert float(1) - oo == Float('-inf')
assert float(1) - -oo == Float('inf')
- from sympy.mpmath.libmp.libmpf import fnan
+ from mpmath.libmp.libmpf import fnan
assert (oo*Float('nan'))._mpf_ == fnan
assert (-oo*Float('nan'))._mpf_ == fnan
assert (oo/Float('nan'))._mpf_ == fnan
@@ -1159,8 +1159,8 @@ def test_issue_1073():
@XFAIL
def test_mpmath_issues():
- from sympy.mpmath.libmp.libmpf import _normalize
- import sympy.mpmath.libmp as mlib
+ from mpmath.libmp.libmpf import _normalize
+ import mpmath.libmp as mlib
rnd = mlib.round_nearest
mpf = (0, 0L, -123, -1, 53, rnd) # nan
assert _normalize(mpf, 53) != (0, 0L, 0, 0)
@@ -1169,7 +1169,7 @@ def test_mpmath_issues():
mpf = (1, 0L, -789, -3, 53, rnd) # -inf
assert _normalize(mpf, 53) != (0, 0L, 0, 0)
- from sympy.mpmath.libmp.libmpf import fnan
+ from mpmath.libmp.libmpf import fnan
assert mlib.mpf_eq(fnan, fnan)
def test_Catalan_EulerGamma_prec():
--- ./sympy/core/tests/test_sets.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/core/tests/test_sets.py 2013-06-18 09:08:54.094202492 -0600
@@ -3,7 +3,7 @@ from sympy import (
GreaterThan, LessThan, Max, Min, And, Or, Eq, Ge, Le, Gt, Lt, Float,
FiniteSet, Intersection
)
-from sympy.mpmath import mpi
+from mpmath import mpi
from sympy.utilities.pytest import raises
from sympy.utilities.pytest import raises, XFAIL
--- ./sympy/core/function.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/core/function.py 2013-06-18 09:08:54.093202494 -0600
@@ -49,8 +49,8 @@ from sympy.core.logic import fuzzy_and
from sympy.utilities import default_sort_key
from sympy.utilities.iterables import uniq
-from sympy import mpmath
-import sympy.mpmath.libmp as mlib
+import mpmath
+import mpmath.libmp as mlib
def _coeff_isneg(a):
"""Return True if the leading Number is negative.
@@ -1051,7 +1051,7 @@ class Derivative(Expr):
When we can represent derivatives at a point, this should be folded
into the normal evalf. For now, we need a special method.
"""
- from sympy import mpmath
+ import mpmath
from sympy.core.expr import Expr
if len(self.free_symbols) != 1 or len(self.variables) != 1:
raise NotImplementedError('partials and higher order derivatives')
--- ./sympy/core/sets.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/core/sets.py 2013-06-18 09:08:54.095202490 -0600
@@ -6,7 +6,7 @@ from sympy.core.numbers import Float
from sympy.core.compatibility import iterable
from sympy.core.decorators import deprecated
-from sympy.mpmath import mpi, mpf
+from mpmath import mpi, mpf
from sympy.assumptions import ask
from sympy.logic.boolalg import And, Or
--- ./sympy/core/power.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/core/power.py 2013-06-18 09:08:54.097202486 -0600
@@ -8,7 +8,7 @@ from sympy.core.function import (_coeff_
from singleton import S
from expr import Expr
-from sympy import mpmath
+import mpmath
from sympy.utilities.iterables import sift
def integer_nthroot(y, n):
--- ./sympy/core/expr.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/core/expr.py 2013-06-18 09:08:54.096202488 -0600
@@ -6,7 +6,7 @@ from evalf import EvalfMixin, pure_compl
from decorators import _sympifyit, call_highest_priority
from cache import cacheit
from compatibility import reduce, as_int
-from sympy.mpmath.libmp import mpf_log, prec_to_dps
+from mpmath.libmp import mpf_log, prec_to_dps
from sympy.utilities.misc import default_sort_key
from collections import defaultdict
--- ./sympy/core/evalf.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/core/evalf.py 2013-06-18 09:08:54.098202485 -0600
@@ -2,19 +2,19 @@
Adaptive numerical evaluation of SymPy expressions, using mpmath
for mathematical functions.
"""
-import sympy.mpmath.libmp as libmp
-from sympy.mpmath import make_mpc, make_mpf, mp, mpc, mpf, nsum, quadts, quadosc
-from sympy.mpmath import inf as mpmath_inf
-from sympy.mpmath.libmp import (bitcount, from_int, from_man_exp,
+import mpmath.libmp as libmp
+from mpmath import make_mpc, make_mpf, mp, mpc, mpf, nsum, quadts, quadosc
+from mpmath import inf as mpmath_inf
+from mpmath.libmp import (bitcount, from_int, from_man_exp,
from_rational, fhalf, fnone, fone, fzero, mpf_abs, mpf_add, mpf_atan,
mpf_atan2, mpf_cmp, mpf_cos, mpf_e, mpf_exp, mpf_log, mpf_lt, mpf_mul,
mpf_neg, mpf_pi, mpf_pow, mpf_pow_int, mpf_shift, mpf_sin, mpf_sqrt,
normalize, round_nearest, to_int, to_str)
-from sympy.mpmath.libmp.backend import MPZ
-from sympy.mpmath.libmp.libmpc import _infs_nan
-from sympy.mpmath.libmp.libmpf import dps_to_prec
+from mpmath.libmp.backend import MPZ
+from mpmath.libmp.libmpc import _infs_nan
+from mpmath.libmp.libmpf import dps_to_prec
-from sympy.mpmath.libmp.gammazeta import mpf_bernoulli
+from mpmath.libmp.gammazeta import mpf_bernoulli
import math
--- ./sympy/core/numbers.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/core/numbers.py 2013-06-18 09:08:54.099202483 -0600
@@ -6,11 +6,11 @@ from expr import Expr, AtomicExpr
from decorators import _sympifyit, deprecated
from cache import cacheit, clear_cache
from sympy.core.compatibility import as_int
-import sympy.mpmath as mpmath
-import sympy.mpmath.libmp as mlib
-from sympy.mpmath.libmp import mpf_pow, mpf_pi, mpf_e, phi_fixed
-from sympy.mpmath.ctx_mp import mpnumeric
-from sympy.mpmath.libmp.libmpf import fnan, _normalize as mpf_normalize
+import mpmath as mpmath
+import mpmath.libmp as mlib
+from mpmath.libmp import mpf_pow, mpf_pi, mpf_e, phi_fixed
+from mpmath.ctx_mp import mpnumeric
+from mpmath.libmp.libmpf import fnan, _normalize as mpf_normalize
import decimal
import math
--- ./sympy/external/tests/test_numpy.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/external/tests/test_numpy.py 2013-06-18 09:08:54.099202483 -0600
@@ -26,7 +26,7 @@ from sympy import (Rational, Symbol, lis
symarray, symbols, Integer)
import sympy
-from sympy import mpmath
+import mpmath
from sympy.utilities.decorator import conserve_mpmath_dps
# first, systematically check, that all operations are implemented and don't
--- ./sympy/polys/domains/groundtypes.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/polys/domains/groundtypes.py 2013-06-18 09:08:54.099202483 -0600
@@ -66,13 +66,13 @@ else:
gmpy_lcm = None
gmpy_sqrt = None
-from sympy.mpmath import (
+from mpmath import (
mpf as MPmathRealType,
mpc as MPmathComplexType,
mpi as MPmathIntervalType,
)
-from sympy.mpmath.libmp.libmpf import isqrt
+from mpmath.libmp.libmpf import isqrt
def python_sqrt(a):
return int(isqrt(a))
--- ./sympy/polys/rootoftools.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/polys/rootoftools.py 2013-06-18 09:08:54.100202481 -0600
@@ -22,8 +22,8 @@ from sympy.polys.polyerrors import (
from sympy.polys.domains import QQ
-from sympy.mpmath import mp, mpf, mpc, findroot
-from sympy.mpmath.libmp.libmpf import prec_to_dps
+from mpmath import mp, mpf, mpc, findroot
+from mpmath.libmp.libmpf import prec_to_dps
from sympy.utilities import lambdify
--- ./sympy/polys/numberfields.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/polys/numberfields.py 2013-06-18 09:08:54.100202481 -0600
@@ -26,7 +26,7 @@ from sympy.utilities import (
)
from sympy.ntheory import sieve
-from sympy.mpmath import pslq, mp
+from mpmath import pslq, mp
def minimal_polynomial(ex, x=None, **args):
"""
--- ./sympy/polys/polytools.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/polys/polytools.py 2013-06-18 09:08:54.102202477 -0600
@@ -59,7 +59,7 @@ from sympy.polys.polyerrors import (
from sympy.utilities import group
import sympy.polys
-import sympy.mpmath
+import mpmath
from sympy.polys.domains import FF, QQ
from sympy.polys.constructor import construct_domain
@@ -3065,16 +3065,16 @@ class Poly(Expr):
coeffs = [ coeff.evalf(n=n).as_real_imag() for coeff in f.all_coeffs() ]
- dps = sympy.mpmath.mp.dps
- sympy.mpmath.mp.dps = n
+ dps = mpmath.mp.dps
+ mpmath.mp.dps = n
try:
try:
- coeffs = [ sympy.mpmath.mpc(*coeff) for coeff in coeffs ]
+ coeffs = [ mpmath.mpc(*coeff) for coeff in coeffs ]
except TypeError:
raise DomainError("numerical domain expected, got %s" % f.rep.dom)
- result = sympy.mpmath.polyroots(coeffs, maxsteps=maxsteps, cleanup=cleanup, error=error)
+ result = mpmath.polyroots(coeffs, maxsteps=maxsteps, cleanup=cleanup, error=error)
if error:
roots, error = result
@@ -3083,7 +3083,7 @@ class Poly(Expr):
roots = map(sympify, sorted(roots, key=lambda r: (r.real, r.imag)))
finally:
- sympy.mpmath.mp.dps = dps
+ mpmath.mp.dps = dps
if error is not None:
return roots, sympify(error)
--- ./sympy/functions/combinatorial/numbers.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/functions/combinatorial/numbers.py 2013-06-18 09:08:54.102202477 -0600
@@ -9,8 +9,8 @@ the separate 'factorials' module.
from sympy import Function, S, Symbol, Rational, oo, Integer, C, Add, expand_mul
-from sympy.mpmath import bernfrac
-from sympy.mpmath.libmp import ifib as _ifib
+from mpmath import bernfrac
+from mpmath.libmp import ifib as _ifib
def _product(a, b):
p = 1
@@ -526,7 +526,7 @@ class euler(Function):
if m.is_odd:
return S.Zero
if m.is_Integer and m.is_nonnegative:
- from sympy.mpmath import mp
+ from mpmath import mp
m = m._to_mpmath(mp.prec)
res = mp.eulernum(m, exact=True)
return Integer(res)
@@ -547,7 +547,7 @@ class euler(Function):
m = self.args[0]
if m.is_Integer and m.is_nonnegative:
- from sympy.mpmath import mp
+ from mpmath import mp
from sympy import Expr
m = m._to_mpmath(prec)
oprec = mp.prec
--- ./sympy/functions/special/bessel.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/functions/special/bessel.py 2013-06-18 09:08:54.102202477 -0600
@@ -536,8 +536,8 @@ def jn_zeros(n, k, method="sympy", dps=1
from math import pi
if method == "sympy":
- from sympy.mpmath import besseljzero
- from sympy.mpmath.libmp.libmpf import dps_to_prec
+ from mpmath import besseljzero
+ from mpmath.libmp.libmpf import dps_to_prec
from sympy import Expr
prec = dps_to_prec(dps)
return [Expr._from_mpmath(besseljzero(S(n + 0.5)._to_mpmath(prec),
--- ./sympy/functions/special/hyper.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/functions/special/hyper.py 2013-06-18 09:46:19.184655634 -0600
@@ -572,7 +572,8 @@ class meijerg(TupleParametersBase):
# (carefully so as not to loose the branch information), and evaluate
# G(z'**(1/r)) = G(z'**n) = G(z).
from sympy.functions import exp_polar, ceiling
- from sympy import mpmath, Expr
+ from sympy import Expr
+ import mpmath
z = self.argument
znum = self.argument._eval_evalf(prec)
if znum.has(exp_polar):
--- ./sympy/functions/special/gamma_functions.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/functions/special/gamma_functions.py 2013-06-18 09:08:54.103202476 -0600
@@ -208,7 +208,7 @@ class lowergamma(Function):
return (cls(a + 1, x) + x**a * C.exp(-x))/a
def _eval_evalf(self, prec):
- from sympy.mpmath import mp
+ from mpmath import mp
from sympy import Expr
a = self.args[0]._to_mpmath(prec)
z = self.args[1]._to_mpmath(prec)
@@ -292,7 +292,7 @@ class uppergamma(Function):
raise ArgumentIndexError(self, argindex)
def _eval_evalf(self, prec):
- from sympy.mpmath import mp
+ from mpmath import mp
from sympy import Expr
a = self.args[0]._to_mpmath(prec)
z = self.args[1]._to_mpmath(prec)
--- ./sympy/mpmath/tests/test_functions.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_functions.py 2013-06-18 09:08:54.110202463 -0600
@@ -1,5 +1,5 @@
-from sympy.mpmath.libmp import *
-from sympy.mpmath import *
+from mpmath.libmp import *
+from mpmath import *
import random
import time
import math
--- ./sympy/mpmath/tests/test_interval.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_interval.py 2013-06-18 09:08:54.107202468 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def test_interval_identity():
iv.dps = 15
--- ./sympy/mpmath/tests/test_gammazeta.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_gammazeta.py 2013-06-18 09:08:54.104202474 -0600
@@ -1,5 +1,5 @@
-from sympy.mpmath import *
-from sympy.mpmath.libmp import round_up, from_float, mpf_zeta_int
+from mpmath import *
+from mpmath.libmp import round_up, from_float, mpf_zeta_int
from sympy.utilities.pytest import XFAIL
--- ./sympy/mpmath/tests/test_compatibility.py.orig 2012-01-30 13:18:38.000000000 -0700
+++ ./sympy/mpmath/tests/test_compatibility.py 2013-06-18 09:08:54.107202468 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
from random import seed, randint, random
import math
--- ./sympy/mpmath/tests/test_mpmath.py.orig 2012-08-30 11:54:11.000000000 -0600
+++ ./sympy/mpmath/tests/test_mpmath.py 2013-06-18 09:08:54.109202465 -0600
@@ -1,3 +1,3 @@
-from sympy.mpmath.libmp import *
-from sympy.mpmath import *
+from mpmath.libmp import *
+from mpmath import *
import random
--- ./sympy/mpmath/tests/test_ode.py.orig 2012-07-31 03:37:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_ode.py 2013-06-18 09:08:54.106202470 -0600
@@ -1,5 +1,5 @@
-#from sympy.mpmath.calculus import ODE_step_euler, ODE_step_rk4, odeint, arange
-from sympy.mpmath import odefun, cos, sin, mpf, sinc, mp
+#from mpmath.calculus import ODE_step_euler, ODE_step_rk4, odeint, arange
+from mpmath import odefun, cos, sin, mpf, sinc, mp
'''
solvers = [ODE_step_euler, ODE_step_rk4]
--- ./sympy/mpmath/tests/test_bitwise.py.orig 2012-09-13 17:10:35.000000000 -0600
+++ ./sympy/mpmath/tests/test_bitwise.py 2013-06-18 09:08:54.103202476 -0600
@@ -2,8 +2,8 @@
Test bit-level integer and mpf operations
"""
-from sympy.mpmath import *
-from sympy.mpmath.libmp import *
+from mpmath import *
+from mpmath.libmp import *
def test_bitcount():
assert bitcount(0) == 0
--- ./sympy/mpmath/tests/test_summation.py.orig 2012-08-30 11:54:11.000000000 -0600
+++ ./sympy/mpmath/tests/test_summation.py 2013-06-18 09:08:54.104202474 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def test_sumem():
mp.dps = 15
--- ./sympy/mpmath/tests/test_linalg.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_linalg.py 2013-06-18 09:08:54.106202470 -0600
@@ -2,7 +2,7 @@
from __future__ import division
-from sympy.mpmath import *
+from mpmath import *
# XXX: these shouldn't be visible(?)
LU_decomp = mp.LU_decomp
--- ./sympy/mpmath/tests/test_identify.py.orig 2011-10-24 00:15:57.000000000 -0600
+++ ./sympy/mpmath/tests/test_identify.py 2013-06-18 09:08:54.108202467 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def test_pslq():
mp.dps = 15
--- ./sympy/mpmath/tests/test_convert.py.orig 2012-09-13 17:10:35.000000000 -0600
+++ ./sympy/mpmath/tests/test_convert.py 2013-06-18 09:08:54.108202467 -0600
@@ -1,6 +1,6 @@
import random
-from sympy.mpmath import *
-from sympy.mpmath.libmp import *
+from mpmath import *
+from mpmath.libmp import *
def test_basic_string():
--- ./sympy/mpmath/tests/test_power.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_power.py 2013-06-18 09:08:54.108202467 -0600
@@ -1,5 +1,5 @@
-from sympy.mpmath import *
-from sympy.mpmath.libmp import *
+from mpmath import *
+from mpmath.libmp import *
import random
--- ./sympy/mpmath/tests/test_division.py.orig 2012-07-31 03:37:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_division.py 2013-06-18 09:08:54.106202470 -0600
@@ -1,5 +1,5 @@
-from sympy.mpmath.libmp import *
-from sympy.mpmath import mpf, mp
+from mpmath.libmp import *
+from mpmath import mpf, mp
from random import randint, choice, seed
--- ./sympy/mpmath/tests/test_elliptic.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_elliptic.py 2013-06-18 09:08:54.104202474 -0600
@@ -13,10 +13,10 @@ References:
"""
-import sympy.mpmath
+import mpmath
import random
-from sympy.mpmath import *
+from mpmath import *
def mpc_ae(a, b, eps=eps):
res = True
--- ./sympy/mpmath/tests/test_matrices.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_matrices.py 2013-06-18 09:08:54.105202472 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def test_matrix_basic():
A1 = matrix(3)
--- ./sympy/mpmath/tests/test_special.py.orig 2012-08-30 11:54:11.000000000 -0600
+++ ./sympy/mpmath/tests/test_special.py 2013-06-18 09:08:54.109202465 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def test_special():
assert inf == inf
--- ./sympy/mpmath/tests/test_basic_ops.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_basic_ops.py 2013-06-18 09:08:54.107202468 -0600
@@ -1,6 +1,6 @@
-import sympy.mpmath
-from sympy.mpmath import *
-from sympy.mpmath.libmp import *
+import mpmath
+from mpmath import *
+from mpmath.libmp import *
import random
import sys
@@ -140,7 +140,7 @@ def test_hash():
# Check that overflow doesn't assign equal hashes to large numbers
assert hash(mpf('1e1000')) != hash('1e10000')
assert hash(mpc(100,'1e1000')) != hash(mpc(200,'1e1000'))
- from sympy.mpmath.rational import mpq
+ from mpmath.rational import mpq
assert hash(mp.mpq(1,3))
assert hash(mp.mpq(0,1)) == 0
assert hash(mp.mpq(-1,1)) == hash(-1)
@@ -341,7 +341,7 @@ def test_floor_ceil_nint_frac():
assert frac(3.25+4.75j) == 0.25+0.75j
def test_isnan_etc():
- from sympy.mpmath.rational import mpq
+ from mpmath.rational import mpq
assert isnan(nan) == True
assert isnan(3) == False
assert isnan(mpf(3)) == False
--- ./sympy/mpmath/tests/test_hp.py.orig 2012-07-31 03:37:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_hp.py 2013-06-18 09:08:54.105202472 -0600
@@ -5,7 +5,7 @@ verified with Mathematica.
"""
import time
-from sympy.mpmath import *
+from mpmath import *
precs = [5, 15, 28, 35, 57, 80, 100, 150, 200]
--- ./sympy/mpmath/tests/test_calculus.py.orig 2012-01-30 13:18:38.000000000 -0700
+++ ./sympy/mpmath/tests/test_calculus.py 2013-06-18 09:08:54.105202472 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def test_approximation():
mp.dps = 15
--- ./sympy/mpmath/tests/test_functions2.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_functions2.py 2013-06-18 09:08:54.105202472 -0600
@@ -1,5 +1,5 @@
import math
-from sympy.mpmath import *
+from mpmath import *
from sympy.utilities.pytest import XFAIL
--- ./sympy/mpmath/tests/test_quad.py.orig 2012-08-30 11:54:11.000000000 -0600
+++ ./sympy/mpmath/tests/test_quad.py 2013-06-18 09:08:54.109202465 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def ae(a, b):
return abs(a-b) < 10**(-mp.dps+5)
--- ./sympy/mpmath/tests/test_diff.py.orig 2012-08-30 11:54:11.000000000 -0600
+++ ./sympy/mpmath/tests/test_diff.py 2013-06-18 09:08:54.108202467 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import *
+from mpmath import *
def test_diff():
mp.dps = 15
--- ./sympy/mpmath/tests/test_trig.py.orig 2012-09-13 17:10:35.000000000 -0600
+++ ./sympy/mpmath/tests/test_trig.py 2013-06-18 09:08:54.104202474 -0600
@@ -1,5 +1,5 @@
-from sympy.mpmath import *
-from sympy.mpmath.libmp import *
+from mpmath import *
+from mpmath.libmp import *
def test_trig_misc_hard():
mp.prec = 53
--- ./sympy/mpmath/tests/test_str.py.orig 2012-07-31 03:37:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_str.py 2013-06-18 09:08:54.109202465 -0600
@@ -1,4 +1,4 @@
-from sympy.mpmath import nstr, matrix, inf
+from mpmath import nstr, matrix, inf
def test_nstr():
m = matrix([[0.75, 0.190940654, -0.0299195971],
--- ./sympy/mpmath/tests/test_pickle.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_pickle.py 2013-06-18 09:08:54.110202463 -0600
@@ -4,7 +4,7 @@ import os
import tempfile
import pickle
-from sympy.mpmath import *
+from mpmath import *
def pickler(obj):
fn = tempfile.mktemp()
--- ./sympy/mpmath/tests/test_fp.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_fp.py 2013-06-18 09:08:54.107202468 -0600
@@ -6,7 +6,7 @@ exp 2.25
log 2.25
'''
-from sympy.mpmath import *
+from mpmath import *
mp.dps = 20
for test in cases.splitlines():
if not test:
@@ -21,7 +21,7 @@ for test in cases.splitlines():
"""
-from sympy.mpmath import fp
+from mpmath import fp
def ae(x, y, tol=1e-12):
if x == y:
--- ./sympy/mpmath/tests/test_visualization.py.orig 2012-09-13 17:10:35.000000000 -0600
+++ ./sympy/mpmath/tests/test_visualization.py 2013-06-18 09:08:54.103202476 -0600
@@ -9,7 +9,7 @@ sure that passing custom Axes works.
# for a test, so let's just skip this entirely.
disabled = True
-from sympy.mpmath import mp, fp
+from mpmath import mp, fp
def test_axes():
try:
--- ./sympy/mpmath/tests/test_rootfinding.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/mpmath/tests/test_rootfinding.py 2013-06-18 09:08:54.108202467 -0600
@@ -1,5 +1,5 @@
-from sympy.mpmath import *
-from sympy.mpmath.calculus.optimization import Secant, Muller, Bisection, Illinois, \
+from mpmath import *
+from mpmath.calculus.optimization import Secant, Muller, Bisection, Illinois, \
Pegasus, Anderson, Ridder, ANewton, Newton, MNewton, MDNewton
from sympy.utilities.pytest import XFAIL
--- ./sympy/physics/quantum/qubit.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/physics/quantum/qubit.py 2013-06-18 09:08:54.110202463 -0600
@@ -22,7 +22,7 @@ from sympy.physics.quantum.represent imp
from sympy.physics.quantum.matrixutils import (
numpy_ndarray, scipy_sparse_matrix
)
-from sympy.mpmath.libmp.libintmath import bitcount
+from mpmath.libmp.libintmath import bitcount
__all__ = [
'Qubit',
--- ./sympy/physics/quantum/constants.py.orig 2012-10-16 19:53:14.000000000 -0600
+++ ./sympy/physics/quantum/constants.py 2013-06-18 09:08:54.110202463 -0600
@@ -2,7 +2,7 @@
from sympy.core.numbers import NumberSymbol
from sympy.printing.pretty.stringpict import prettyForm
-import sympy.mpmath.libmp as mlib
+import mpmath.libmp as mlib
#-----------------------------------------------------------------------------
# Constants
--- ./sympy/simplify/simplify.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/simplify/simplify.py 2013-06-18 09:08:54.111202461 -0600
@@ -26,7 +26,7 @@ from sympy.polys import (Poly, together,
ComputationFailed, terms_gcd, lcm, gcd)
from sympy.polys.polytools import _keep_coeff
-import sympy.mpmath as mpmath
+import mpmath as mpmath
def _mexpand(expr):
return expand_mul(expand_multinomial(expr))
--- ./sympy/matrices/matrices.py.orig 2012-10-16 20:30:33.000000000 -0600
+++ ./sympy/matrices/matrices.py 2013-06-18 09:08:54.112202459 -0600
@@ -1233,7 +1233,7 @@ class MatrixBase(object):
self is the coefficient matrix A and rhs is the right side b.
This is for symbolic matrices, for real or complex ones use
- sympy.mpmath.lu_solve or sympy.mpmath.qr_solve.
+ mpmath.lu_solve or mpmath.qr_solve.
See Also
========
@@ -1599,7 +1599,7 @@ class MatrixBase(object):
to use QRsolve.
This is mainly for educational purposes and symbolic matrices, for real
- (or complex) matrices use sympy.mpmath.qr_solve.
+ (or complex) matrices use mpmath.qr_solve.
See Also
========