Update to 1.1.1 (bz 1468405).
This commit is contained in:
parent
1724a745c7
commit
c6c6e1b41c
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/sympy-0.7.6.1.tar.gz
|
/sympy-0.7.6.1.tar.gz
|
||||||
/sympy-1.0.tar.gz
|
/sympy-1.0.tar.gz
|
||||||
/sympy-1.1.tar.gz
|
/sympy-1.1.tar.gz
|
||||||
|
/sympy-1.1.1.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (sympy-1.1.tar.gz) = 1b44d1709eaacc3744f84ca60862e9db9470ff657aa65df3c7e498acb3fc4d10fe92f3dbea665662647174052fb0ae7c05e2bc7d8273f3a74d8fbfb938eadc08
|
SHA512 (sympy-1.1.1.tar.gz) = c571a5c6fd0abb59e60baec0f9c7b909ec2d133db52353c58288f7477ac2bc905219b308122761e41509d4bbdfc145375bdc6f76f608eb557e44163bb37b111a
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
--- sympy-sympy-1.1/sympy/core/tests/test_sympify.py.orig 2017-07-05 17:13:24.000000000 -0600
|
|
||||||
+++ sympy-sympy-1.1/sympy/core/tests/test_sympify.py 2017-07-08 19:32:15.297900401 -0600
|
|
||||||
@@ -560,11 +560,7 @@ def test_numpy():
|
|
||||||
skip('numpy not installed.Abort numpy tests.')
|
|
||||||
|
|
||||||
assert sympify(np.bool_(1)) is S(True)
|
|
||||||
- assert equal(
|
|
||||||
- sympify(np.int_(1234567891234567891)), S(1234567891234567891))
|
|
||||||
assert equal(sympify(np.intc(1234567891)), S(1234567891))
|
|
||||||
- assert equal(
|
|
||||||
- sympify(np.intp(1234567891234567891)), S(1234567891234567891))
|
|
||||||
assert equal(sympify(np.int8(-123)), S(-123))
|
|
||||||
assert equal(sympify(np.int16(-12345)), S(-12345))
|
|
||||||
assert equal(sympify(np.int32(-1234567891)), S(-1234567891))
|
|
||||||
@@ -587,12 +583,6 @@ def test_numpy():
|
|
||||||
except AttributeError: #float96 does not exist on all platforms
|
|
||||||
pass
|
|
||||||
|
|
||||||
- try:
|
|
||||||
- assert equal(sympify(np.float128(1.123456789123)),
|
|
||||||
- Float(1.123456789123, precision=80))
|
|
||||||
- except AttributeError: #float128 does not exist on all platforms
|
|
||||||
- pass
|
|
||||||
-
|
|
||||||
|
|
||||||
@XFAIL
|
|
||||||
def test_sympify_rational_numbers_set():
|
|
||||||
--- sympy-sympy-1.1/sympy/solvers/tests/test_solveset.py.orig 2017-07-05 17:13:24.000000000 -0600
|
|
||||||
+++ sympy-sympy-1.1/sympy/solvers/tests/test_solveset.py 2017-07-08 21:19:24.576055995 -0600
|
|
||||||
@@ -1465,7 +1465,6 @@ def test_issue_9557():
|
|
||||||
|
|
||||||
|
|
||||||
def test_issue_9778():
|
|
||||||
- assert solveset(x**3 + 1, x, S.Reals) == FiniteSet(-1)
|
|
||||||
assert solveset(x**(S(3)/5) + 1, x, S.Reals) == S.EmptySet
|
|
||||||
assert solveset(x**3 + y, x, S.Reals) == Intersection(Interval(-oo, oo), \
|
|
||||||
FiniteSet((-y)**(S(1)/3)*Piecewise((1, Ne(-im(y), 0)), ((-1)**(S(2)/3), -y < 0), (1, True))))
|
|
10
sympy.spec
10
sympy.spec
@ -1,12 +1,10 @@
|
|||||||
Name: sympy
|
Name: sympy
|
||||||
Version: 1.1
|
Version: 1.1.1
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A Python library for symbolic mathematics
|
Summary: A Python library for symbolic mathematics
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://sympy.org/
|
URL: http://sympy.org/
|
||||||
Source0: https://github.com/%{name}/%{name}/archive/%{name}-%{version}.tar.gz
|
Source0: https://github.com/%{name}/%{name}/archive/%{name}-%{version}.tar.gz
|
||||||
# Disable tests that fail due to overflow on some 32-bit architectures
|
|
||||||
Patch0: %{name}-test.patch
|
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -94,7 +92,6 @@ HTML documentation for sympy.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -c
|
%setup -q -c
|
||||||
%patch0
|
|
||||||
|
|
||||||
# If running on a 32-bit system, disable a test that requires 64-bit integers.
|
# If running on a 32-bit system, disable a test that requires 64-bit integers.
|
||||||
%global maxpyint %(python3 -c 'import sys;print("%x" % sys.maxsize)')
|
%global maxpyint %(python3 -c 'import sys;print("%x" % sys.maxsize)')
|
||||||
@ -241,6 +238,9 @@ popd
|
|||||||
%{_docdir}/%{name}-doc/html
|
%{_docdir}/%{name}-doc/html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 27 2017 Jerry James <loganjerry@gmail.com> - 1.1.1-1
|
||||||
|
- Update to 1.1.1 (bz 1468405)
|
||||||
|
|
||||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-4
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user