Import.
This commit is contained in:
parent
ed68a4a19b
commit
a55edf4f53
@ -0,0 +1 @@
|
|||||||
|
sympy-0.6.2.tar.gz
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
|||||||
|
sympy-0_6_2-2_fc9:HEAD:sympy-0.6.2-2.fc9.src.rpm:1224101147
|
34
sympy-0.6.2-remove-extraneous-shebangs.diff
Normal file
34
sympy-0.6.2-remove-extraneous-shebangs.diff
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
diff -r -U 3 sympy-0.6.2.orig/sympy/mpmath/elliptic.py sympy-0.6.2/sympy/mpmath/elliptic.py
|
||||||
|
--- sympy-0.6.2.orig/sympy/mpmath/elliptic.py 2008-08-17 08:00:28.000000000 -0700
|
||||||
|
+++ sympy-0.6.2/sympy/mpmath/elliptic.py 2008-10-13 13:03:31.000000000 -0700
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
"""
|
||||||
|
elliptic.py
|
||||||
|
|
||||||
|
diff -r -U 3 sympy-0.6.2.orig/sympy/mpmath/tests/test_elliptic.py sympy-0.6.2/sympy/mpmath/tests/test_elliptic.py
|
||||||
|
--- sympy-0.6.2.orig/sympy/mpmath/tests/test_elliptic.py 2008-08-17 08:00:28.000000000 -0700
|
||||||
|
+++ sympy-0.6.2/sympy/mpmath/tests/test_elliptic.py 2008-10-13 13:03:52.000000000 -0700
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
"""
|
||||||
|
Limited tests of the elliptic functions module. A full suite of
|
||||||
|
extensive testing can be found in elliptic_torture_tests.py
|
||||||
|
diff -r -U 3 sympy-0.6.2.orig/sympy/solvers/numeric.py sympy-0.6.2/sympy/solvers/numeric.py
|
||||||
|
--- sympy-0.6.2.orig/sympy/solvers/numeric.py 2008-08-17 08:00:30.000000000 -0700
|
||||||
|
+++ sympy-0.6.2/sympy/solvers/numeric.py 2008-10-13 13:03:23.000000000 -0700
|
||||||
|
@@ -1,5 +1,3 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
-
|
||||||
|
# TODO: * calculate J numerically
|
||||||
|
# * better exceptions for bad input
|
||||||
|
# * solving overdetermined systems with Gauss-Newton algorithm
|
||||||
|
diff -r -U 3 sympy-0.6.2.orig/sympy/utilities/compilef.py sympy-0.6.2/sympy/utilities/compilef.py
|
||||||
|
--- sympy-0.6.2.orig/sympy/utilities/compilef.py 2008-08-17 08:00:31.000000000 -0700
|
||||||
|
+++ sympy-0.6.2/sympy/utilities/compilef.py 2008-10-13 13:03:10.000000000 -0700
|
||||||
|
@@ -1,5 +1,3 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
-
|
||||||
|
# needs access to libtcc and math.h
|
||||||
|
# TODO: *get tcc errors (currently something like 'Unknown error 3217941984',
|
||||||
|
# this makes debugging painful)
|
58
sympy.spec
Normal file
58
sympy.spec
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
|
||||||
|
Name: sympy
|
||||||
|
Version: 0.6.2
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: A Python library for symbolic mathematics
|
||||||
|
Group: Development/Languages
|
||||||
|
License: BSD
|
||||||
|
URL: http://code.google.com/p/sympy/
|
||||||
|
Source0: http://sympy.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||||
|
# Patch0 submitted upstream:
|
||||||
|
# http://code.google.com/p/sympy/issues/detail?id=1156
|
||||||
|
Patch0: sympy-0.6.2-remove-extraneous-shebangs.diff
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: python-devel
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
SymPy aims to become a full-featured computer algebra system (CAS)
|
||||||
|
while keeping the code as simple as possible in order to be
|
||||||
|
comprehensible and easily extensible. SymPy is written entirely in
|
||||||
|
Python and does not require any external libraries.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%{__python} setup.py build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc README LICENSE
|
||||||
|
%{python_sitelib}/*
|
||||||
|
%{_bindir}/isympy
|
||||||
|
%{_mandir}/man1/isympy.1*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Oct 13 2008 Conrad Meyer <konrad@tylerc.org> - 0.6.2-2
|
||||||
|
- Patch to remove extraneous shebangs.
|
||||||
|
|
||||||
|
* Sun Oct 12 2008 Conrad Meyer <konrad@tylerc.org> - 0.6.2-1
|
||||||
|
- Initial package.
|
Loading…
Reference in New Issue
Block a user