fix a python 2.7 incompatibility

This commit is contained in:
David Malcolm 2010-07-31 07:19:42 -04:00
parent 1e6092ca9d
commit 65c1ebf20b
2 changed files with 23 additions and 1 deletions

13
sympy-python27.patch Normal file
View File

@ -0,0 +1,13 @@
diff --git a/sympy/utilities/runtests.py b/sympy/utilities/runtests.py
index 65f870a..6aaf935 100644
--- a/sympy/utilities/runtests.py
+++ b/sympy/utilities/runtests.py
@@ -779,7 +779,7 @@ class PyTestReporter(Reporter):
self.write_center("test process starts")
executable = sys.executable
v = sys.version_info
- python_version = "%s.%s.%s-%s-%s" % v
+ python_version = "%s.%s.%s-%s-%s" % tuple(v)
self.write("executable: %s (%s)\n\n" % (executable, python_version))
self._t_start = clock()

View File

@ -2,7 +2,7 @@
Name: sympy
Version: 0.6.7
Release: 3%{?dist}
Release: 4%{?dist}
Summary: A Python library for symbolic mathematics
Group: Development/Languages
License: BSD
@ -11,6 +11,11 @@ Source0: http://sympy.googlecode.com/files/%{name}-%{version}.tar.gz
# Upstream tried to graft in another project as a private copy; we rip
# it out (rhbz# 551576):
Patch0: sympy-0.6.7-strip-internal-mpmath.diff
# Fix a python 2.7 incompatibility
# Not yet sent upstream:
Patch1: sympy-python27.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@ -28,6 +33,7 @@ Python and does not require any external libraries.
%setup -q
%patch0 -p1 -b .mpmath
rm -rf sympy/mpmath doc/src/modules/mpmath
%patch1 -p1
%build
python setup.py build
@ -53,6 +59,9 @@ rm -rf %{buildroot}
%{_mandir}/man1/isympy.1*
%changelog
* Sat Jul 31 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.7-4
- fix a python 2.7 incompatibility
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.7-3
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild