Version 1.6. Drop upstreamed -doc and -sample-set patches.
This commit is contained in:
parent
e3f48f62c3
commit
53a6ccd846
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sympy-1.5.1.tar.gz) = 3c4220243d2cbcff9eedb2a7986431b5b4d7d0007c78208a60b21830c9a3528d2171086874c42205c1227f779e44c19b9562943e2935d329bc352e7ea85396c7
|
||||
SHA512 (sympy-1.6.tar.gz) = d3fa69deb27d70be476c2be45f8cd58f2951bfa8adba5f62810ccce36a26d0380b1b8f4eac3d1f28056f415b2b66ef2bcbe752a29e7cd8913feff19443ceddba
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- sympy-sympy-1.4/README.rst.orig 2019-04-09 18:29:25.000000000 -0600
|
||||
+++ sympy-sympy-1.4/README.rst 2019-04-17 14:31:01.408877172 -0600
|
||||
@@ -240,7 +240,7 @@ To cite SymPy in publications use
|
||||
|
||||
A BibTeX entry for LaTeX users is
|
||||
|
||||
-.. code-block:: none
|
||||
+.. code-block:: BibTeX
|
||||
|
||||
@article{10.7717/peerj-cs.103,
|
||||
title = {SymPy: symbolic computing in Python},
|
@ -1,20 +0,0 @@
|
||||
--- sympy-sympy-1.5.1/sympy/polys/modulargcd.py.orig 2019-12-20 15:59:54.000000000 -0700
|
||||
+++ sympy-sympy-1.5.1/sympy/polys/modulargcd.py 2020-05-10 14:56:32.546383740 -0600
|
||||
@@ -1010,7 +1010,7 @@ def _modgcd_multivariate_p(f, g, p, degb
|
||||
d = 0
|
||||
evalpoints = []
|
||||
heval = []
|
||||
- points = set(range(p))
|
||||
+ points = list(range(p))
|
||||
|
||||
while points:
|
||||
a = random.sample(points, 1)[0]
|
||||
@@ -1606,7 +1606,7 @@ def _func_field_modgcd_p(f, g, minpoly,
|
||||
evalpoints = []
|
||||
heval = []
|
||||
LMlist = []
|
||||
- points = set(range(p))
|
||||
+ points = list(range(p))
|
||||
|
||||
while points:
|
||||
a = random.sample(points, 1)[0]
|
26
sympy.spec
26
sympy.spec
@ -1,19 +1,14 @@
|
||||
Name: sympy
|
||||
Version: 1.5.1
|
||||
Release: 4%{?dist}
|
||||
Version: 1.6
|
||||
Release: 1%{?dist}
|
||||
Summary: A Python library for symbolic mathematics
|
||||
License: BSD
|
||||
URL: http://sympy.org/
|
||||
Source0: https://github.com/%{name}/%{name}/archive/%{name}-%{version}.tar.gz
|
||||
# Remove tests that fail on non-x86 architectures
|
||||
Patch0: %{name}-float.patch
|
||||
# Fix a documentation typo
|
||||
Patch1: %{name}-doc.patch
|
||||
# Default to python3 in the Cython backend
|
||||
Patch2: %{name}-python3.patch
|
||||
# Do not use deprecated sample from a set functionality
|
||||
# https://github.com/sympy/sympy/pull/19291
|
||||
Patch3: %{name}-sample-set.patch
|
||||
Patch1: %{name}-python3.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -136,9 +131,6 @@ chmod a-x %{buildroot}%{_datadir}/TeXmacs/plugins/sympy/progs/*.scm
|
||||
# Don't let an executable script go into the documentation
|
||||
chmod -R a-x+X examples
|
||||
|
||||
# Convert the README to HTML
|
||||
rst2html --no-datestamp README.rst README.html
|
||||
|
||||
# Install the HTML documentation
|
||||
mkdir -p %{buildroot}%{_docdir}/%{name}-doc
|
||||
cp -a doc/_build/html %{buildroot}%{_docdir}/%{name}-doc
|
||||
@ -148,12 +140,6 @@ rm -fr %{buildroot}%{_docdir}/%{name}-doc/i18n
|
||||
# Try to get rid of pyc files, which aren't useful for documentation
|
||||
find examples/ -name '*.py[co]' -print -delete
|
||||
|
||||
# Fix some executable bits
|
||||
chmod a+x \
|
||||
%{buildroot}%{python3_sitelib}/sympy/benchmarks/bench_symbench.py \
|
||||
%{buildroot}%{python3_sitelib}/sympy/physics/mechanics/models.py \
|
||||
%{buildroot}%{python3_sitelib}/sympy/utilities/tests/diagnose_imports.py
|
||||
|
||||
%check
|
||||
let "dnum = $RANDOM % 90 + 10"
|
||||
# Split into many small chunks to reduce waiting in the end-game
|
||||
@ -165,7 +151,7 @@ xvfb-run -a -n $dnum \
|
||||
::: $(bash -c "echo {1..$jobs}")
|
||||
|
||||
%files -n python3-%{name}
|
||||
%doc AUTHORS CODE_OF_CONDUCT.md README.html
|
||||
%doc AUTHORS README.md
|
||||
%doc doc/_build/cheatsheet/combinatoric_cheatsheet.pdf
|
||||
%license LICENSE
|
||||
%{python3_sitelib}/isympy.*
|
||||
@ -188,6 +174,10 @@ xvfb-run -a -n $dnum \
|
||||
%{_docdir}/%{name}-doc/html
|
||||
|
||||
%changelog
|
||||
* Fri May 29 2020 Jerry James <loganjerry@gmail.com> - 1.6-1
|
||||
- Version 1.6
|
||||
- Drop upstreamed -doc and -sample-set patches
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 1.5.1-4
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user