Update to 0.7.1.
This commit is contained in:
parent
abaf5465df
commit
10e2b06eed
2
sources
2
sources
@ -1 +1 @@
|
||||
7407285e8a68d1a6d2e35a0608e51104 sympy-0.6.3.tar.gz
|
||||
3847b5ed5c1531bf3c1b849dc2337253 sympy-0.7.1.tar.gz
|
||||
|
529
sympy-0.7.1-strip-internal-mpmath.patch
Normal file
529
sympy-0.7.1-strip-internal-mpmath.patch
Normal file
@ -0,0 +1,529 @@
|
||||
diff -up sympy-0.7.1/examples/advanced/autowrap_ufuncify.py.mpmath sympy-0.7.1/examples/advanced/autowrap_ufuncify.py
|
||||
--- sympy-0.7.1/examples/advanced/autowrap_ufuncify.py.mpmath 2011-07-26 02:59:41.000000000 +0300
|
||||
+++ sympy-0.7.1/examples/advanced/autowrap_ufuncify.py 2011-10-12 01:53:48.550102357 +0300
|
||||
@@ -22,7 +22,7 @@ np = import_module('numpy')
|
||||
if not np:
|
||||
sys.exit("Cannot import numpy. Exiting.")
|
||||
|
||||
-import sympy.mpmath as mpmath
|
||||
+import mpmath as mpmath
|
||||
from sympy.utilities.autowrap import ufuncify
|
||||
from sympy.utilities.lambdify import implemented_function
|
||||
from sympy import symbols, legendre, Plot, pprint
|
||||
diff -up sympy-0.7.1/examples/advanced/pidigits.py.mpmath sympy-0.7.1/examples/advanced/pidigits.py
|
||||
--- sympy-0.7.1/examples/advanced/pidigits.py.mpmath 2011-07-26 02:59:41.000000000 +0300
|
||||
+++ sympy-0.7.1/examples/advanced/pidigits.py 2011-10-12 01:53:48.551102384 +0300
|
||||
@@ -6,8 +6,8 @@ Example shows arbitrary precision using
|
||||
computation of the digits of pi.
|
||||
"""
|
||||
|
||||
-from sympy.mpmath import libmp, pi
|
||||
-from sympy.mpmath import functions as mpf_funs
|
||||
+from mpmath import libmp, pi
|
||||
+from mpmath import functions as mpf_funs
|
||||
|
||||
import math
|
||||
from time import clock
|
||||
diff -up sympy-0.7.1/setup.py.mpmath sympy-0.7.1/setup.py
|
||||
--- sympy-0.7.1/setup.py.mpmath 2011-07-30 03:04:23.000000000 +0300
|
||||
+++ sympy-0.7.1/setup.py 2011-10-12 01:54:20.703994407 +0300
|
||||
@@ -59,12 +59,6 @@ modules = [
|
||||
'sympy.logic.algorithms',
|
||||
'sympy.logic.utilities',
|
||||
'sympy.matrices',
|
||||
- 'sympy.mpmath',
|
||||
- 'sympy.mpmath.calculus',
|
||||
- 'sympy.mpmath.functions',
|
||||
- 'sympy.mpmath.libmp',
|
||||
- 'sympy.mpmath.matrices',
|
||||
- 'sympy.mpmath.tests',
|
||||
'sympy.ntheory',
|
||||
'sympy.parsing',
|
||||
'sympy.physics',
|
||||
@@ -208,7 +202,6 @@ tests = [
|
||||
'sympy.integrals.tests',
|
||||
'sympy.logic.tests',
|
||||
'sympy.matrices.tests',
|
||||
- 'sympy.mpmath.tests',
|
||||
'sympy.ntheory.tests',
|
||||
'sympy.parsing.tests',
|
||||
'sympy.physics.quantum.tests',
|
||||
diff -up sympy-0.7.1/sympy/core/evalf.py.mpmath sympy-0.7.1/sympy/core/evalf.py
|
||||
--- sympy-0.7.1/sympy/core/evalf.py.mpmath 2011-07-30 03:04:23.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/evalf.py 2011-10-12 01:53:48.552102412 +0300
|
||||
@@ -3,18 +3,18 @@ Adaptive numerical evaluation of SymPy e
|
||||
for mathematical functions.
|
||||
"""
|
||||
|
||||
-import sympy.mpmath.libmp as libmp
|
||||
-from sympy.mpmath import make_mpc, make_mpf, mp, mpc, mpf, nsum, quadts, quadosc
|
||||
-from sympy.mpmath import inf as mpmath_inf
|
||||
-from sympy.mpmath.libmp import (bitcount, from_int, from_man_exp, \
|
||||
+import mpmath.libmp as libmp
|
||||
+from mpmath import make_mpc, make_mpf, mp, mpc, mpf, nsum, quadts, quadosc
|
||||
+from mpmath import inf as mpmath_inf
|
||||
+from mpmath.libmp import (bitcount, from_int, from_man_exp, \
|
||||
from_rational, fhalf, fnone, fone, fzero, mpf_abs, mpf_add, mpf_atan, \
|
||||
mpf_atan2, mpf_cmp, mpf_cos, mpf_e, mpf_exp, mpf_log, mpf_lt, mpf_mul, \
|
||||
mpf_neg, mpf_pi, mpf_pow, mpf_pow_int, mpf_shift, mpf_sin, mpf_sqrt, \
|
||||
normalize, round_nearest, to_int, to_str)
|
||||
-from sympy.mpmath.libmp.backend import MPZ
|
||||
-from sympy.mpmath.libmp.libmpf import dps_to_prec
|
||||
+from mpmath.libmp.backend import MPZ
|
||||
+from mpmath.libmp.libmpf import dps_to_prec
|
||||
|
||||
-from sympy.mpmath.libmp.gammazeta import mpf_bernoulli
|
||||
+from mpmath.libmp.gammazeta import mpf_bernoulli
|
||||
|
||||
import math
|
||||
|
||||
diff -up sympy-0.7.1/sympy/core/function.py.mpmath sympy-0.7.1/sympy/core/function.py
|
||||
--- sympy-0.7.1/sympy/core/function.py.mpmath 2011-07-30 03:04:24.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/function.py 2011-10-12 01:53:48.553102440 +0300
|
||||
@@ -43,8 +43,8 @@ from sympy.core.decorators import deprec
|
||||
from sympy.utilities import default_sort_key
|
||||
from sympy.utilities.iterables import uniq
|
||||
|
||||
-from sympy import mpmath
|
||||
-import sympy.mpmath.libmp as mlib
|
||||
+import mpmath
|
||||
+import mpmath.libmp as mlib
|
||||
|
||||
class PoleError(Exception):
|
||||
pass
|
||||
@@ -737,7 +737,7 @@ class Derivative(Expr):
|
||||
When we can represent derivatives at a point, this should be folded
|
||||
into the normal evalf. For now, we need a special method.
|
||||
"""
|
||||
- from sympy import mpmath
|
||||
+ import mpmath
|
||||
from sympy.core.expr import Expr
|
||||
if len(self.free_symbols) != 1 or len(self.variables) != 1:
|
||||
raise NotImplementedError('partials and higher order derivatives')
|
||||
diff -up sympy-0.7.1/sympy/core/numbers.py.mpmath sympy-0.7.1/sympy/core/numbers.py
|
||||
--- sympy-0.7.1/sympy/core/numbers.py.mpmath 2011-07-30 03:04:24.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/numbers.py 2011-10-12 01:53:48.553102440 +0300
|
||||
@@ -5,10 +5,10 @@ from singleton import S, Singleton
|
||||
from expr import Expr, AtomicExpr
|
||||
from decorators import _sympifyit, deprecated
|
||||
from cache import cacheit, clear_cache
|
||||
-import sympy.mpmath as mpmath
|
||||
-import sympy.mpmath.libmp as mlib
|
||||
-from sympy.mpmath.libmp import mpf_pow, mpf_pi, mpf_e, phi_fixed
|
||||
-from sympy.mpmath.ctx_mp import mpnumeric
|
||||
+import mpmath as mpmath
|
||||
+import mpmath.libmp as mlib
|
||||
+from mpmath.libmp import mpf_pow, mpf_pi, mpf_e, phi_fixed
|
||||
+from mpmath.ctx_mp import mpnumeric
|
||||
|
||||
import decimal
|
||||
|
||||
diff -up sympy-0.7.1/sympy/core/power.py.mpmath sympy-0.7.1/sympy/core/power.py
|
||||
--- sympy-0.7.1/sympy/core/power.py.mpmath 2011-07-28 00:06:51.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/power.py 2011-10-12 01:53:48.554102468 +0300
|
||||
@@ -6,7 +6,7 @@ from core import C
|
||||
from singleton import S
|
||||
from expr import Expr
|
||||
|
||||
-from sympy import mpmath
|
||||
+import mpmath
|
||||
from sympy.utilities.iterables import sift
|
||||
|
||||
def integer_nthroot(y, n):
|
||||
diff -up sympy-0.7.1/sympy/core/sets.py.mpmath sympy-0.7.1/sympy/core/sets.py
|
||||
--- sympy-0.7.1/sympy/core/sets.py.mpmath 2011-07-28 00:06:51.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/sets.py 2011-10-12 01:53:48.555102496 +0300
|
||||
@@ -3,7 +3,7 @@ from singleton import Singleton, S
|
||||
from evalf import EvalfMixin
|
||||
from numbers import Float, Integer
|
||||
from sympify import _sympify, sympify, SympifyError
|
||||
-from sympy.mpmath import mpi, mpf
|
||||
+from mpmath import mpi, mpf
|
||||
from containers import Tuple
|
||||
|
||||
|
||||
diff -up sympy-0.7.1/sympy/core/tests/test_evalf.py.mpmath sympy-0.7.1/sympy/core/tests/test_evalf.py
|
||||
--- sympy-0.7.1/sympy/core/tests/test_evalf.py.mpmath 2011-07-28 00:06:51.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/tests/test_evalf.py 2011-10-12 01:53:48.555102496 +0300
|
||||
@@ -5,7 +5,7 @@ from sympy import pi, I, Symbol, Add, Ra
|
||||
factorial, binomial, Sum, zeta, Catalan, Pow, GoldenRatio, sympify, \
|
||||
sstr, Function, Eq, Mul, Pow, Derivative
|
||||
|
||||
-from sympy.mpmath.libmp.libmpf import from_float
|
||||
+from mpmath.libmp.libmpf import from_float
|
||||
|
||||
from sympy.utilities.pytest import raises
|
||||
|
||||
diff -up sympy-0.7.1/sympy/core/tests/test_numbers.py.mpmath sympy-0.7.1/sympy/core/tests/test_numbers.py
|
||||
--- sympy-0.7.1/sympy/core/tests/test_numbers.py.mpmath 2011-07-30 02:00:19.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/tests/test_numbers.py 2011-10-12 01:53:48.556102524 +0300
|
||||
@@ -5,7 +5,7 @@ from sympy.core.power import integer_nth
|
||||
|
||||
from sympy.core.numbers import igcd, ilcm, igcdex, seterr, _intcache
|
||||
from sympy.utilities.pytest import raises
|
||||
-from sympy import mpmath
|
||||
+import mpmath
|
||||
|
||||
def test_integers_cache():
|
||||
python_int = 2**65 + 3175259
|
||||
diff -up sympy-0.7.1/sympy/core/tests/test_sets.py.mpmath sympy-0.7.1/sympy/core/tests/test_sets.py
|
||||
--- sympy-0.7.1/sympy/core/tests/test_sets.py.mpmath 2011-07-28 00:06:51.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/tests/test_sets.py 2011-10-12 01:53:48.556102524 +0300
|
||||
@@ -2,7 +2,7 @@ from sympy import (
|
||||
Symbol, Set, Union, Interval, oo, S, sympify, nan,
|
||||
Inequality, Max, Min, And, Or, Eq, Ge, Le, Gt, Lt, Float, FiniteSet
|
||||
)
|
||||
-from sympy.mpmath import mpi
|
||||
+from mpmath import mpi
|
||||
|
||||
from sympy.utilities.pytest import raises
|
||||
|
||||
diff -up sympy-0.7.1/sympy/core/tests/test_sympify.py.mpmath sympy-0.7.1/sympy/core/tests/test_sympify.py
|
||||
--- sympy-0.7.1/sympy/core/tests/test_sympify.py.mpmath 2011-07-28 00:06:51.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/core/tests/test_sympify.py 2011-10-12 01:53:48.557102552 +0300
|
||||
@@ -6,7 +6,7 @@ from sympy.core.decorators import _sympi
|
||||
from sympy.utilities.pytest import XFAIL, raises
|
||||
from sympy.geometry import Point, Line
|
||||
|
||||
-from sympy import mpmath
|
||||
+import mpmath
|
||||
|
||||
def test_439():
|
||||
v = sympify("exp(x)")
|
||||
diff -up sympy-0.7.1/sympy/external/tests/test_numpy.py.mpmath sympy-0.7.1/sympy/external/tests/test_numpy.py
|
||||
--- sympy-0.7.1/sympy/external/tests/test_numpy.py.mpmath 2011-07-28 00:06:51.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/external/tests/test_numpy.py 2011-10-12 01:53:48.558102579 +0300
|
||||
@@ -21,7 +21,7 @@ from sympy import (Rational, Symbol, lis
|
||||
symarray, symbols, Integer)
|
||||
import sympy
|
||||
|
||||
-from sympy import mpmath
|
||||
+import mpmath
|
||||
|
||||
# first, systematically check, that all operations are implemented and don't
|
||||
# raise and exception
|
||||
diff -up sympy-0.7.1/sympy/functions/combinatorial/numbers.py.mpmath sympy-0.7.1/sympy/functions/combinatorial/numbers.py
|
||||
--- sympy-0.7.1/sympy/functions/combinatorial/numbers.py.mpmath 2011-06-29 11:58:10.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/functions/combinatorial/numbers.py 2011-10-12 01:53:48.558102579 +0300
|
||||
@@ -9,7 +9,7 @@ the separate 'factorials' module.
|
||||
|
||||
from sympy import Function, S, Symbol, Rational, oo, Integer, C, Add
|
||||
|
||||
-from sympy.mpmath import bernfrac
|
||||
+from mpmath import bernfrac
|
||||
|
||||
def _product(a, b):
|
||||
p = 1
|
||||
diff -up sympy-0.7.1/sympy/functions/special/bessel.py.mpmath sympy-0.7.1/sympy/functions/special/bessel.py
|
||||
--- sympy-0.7.1/sympy/functions/special/bessel.py.mpmath 2011-07-30 03:04:25.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/functions/special/bessel.py 2011-10-12 01:53:48.558102579 +0300
|
||||
@@ -400,7 +400,7 @@ def jn_zeros(n, k, method="sympy"):
|
||||
|
||||
**Examples**
|
||||
|
||||
- >>> from sympy.mpmath import nprint
|
||||
+ >>> from mpmath import nprint
|
||||
>>> from sympy import jn_zeros
|
||||
>>> nprint(jn_zeros(2, 4))
|
||||
[5.76345919689, 9.09501133048, 12.3229409706, 15.5146030109]
|
||||
@@ -409,7 +409,7 @@ def jn_zeros(n, k, method="sympy"):
|
||||
from math import pi
|
||||
|
||||
if method == "sympy":
|
||||
- from sympy.mpmath import findroot
|
||||
+ from mpmath import findroot
|
||||
f = lambda x: jn(n, x).n()
|
||||
elif method == "scipy":
|
||||
from scipy.special import sph_jn
|
||||
diff -up sympy-0.7.1/sympy/functions/special/gamma_functions.py.mpmath sympy-0.7.1/sympy/functions/special/gamma_functions.py
|
||||
--- sympy-0.7.1/sympy/functions/special/gamma_functions.py.mpmath 2011-07-28 00:06:51.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/functions/special/gamma_functions.py 2011-10-12 01:53:48.559102606 +0300
|
||||
@@ -167,7 +167,7 @@ class lowergamma(Function):
|
||||
return (cls(a + 1, x) + x**a * C.exp(-x))/a
|
||||
|
||||
def _eval_evalf(self, prec):
|
||||
- from sympy.mpmath import mp
|
||||
+ from mpmath import mp
|
||||
from sympy import Expr
|
||||
a = self.args[0]._to_mpmath(prec)
|
||||
z = self.args[1]._to_mpmath(prec)
|
||||
@@ -230,7 +230,7 @@ class uppergamma(Function):
|
||||
raise ArgumentIndexError(self, argindex)
|
||||
|
||||
def _eval_evalf(self, prec):
|
||||
- from sympy.mpmath import mp
|
||||
+ from mpmath import mp
|
||||
from sympy import Expr
|
||||
a = self.args[0]._to_mpmath(prec)
|
||||
z = self.args[1]._to_mpmath(prec)
|
||||
diff -up sympy-0.7.1/sympy/matrices/matrices.py.mpmath sympy-0.7.1/sympy/matrices/matrices.py
|
||||
--- sympy-0.7.1/sympy/matrices/matrices.py.mpmath 2011-07-30 03:04:26.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/matrices/matrices.py 2011-10-12 01:53:48.560102634 +0300
|
||||
@@ -1093,7 +1093,7 @@ class Matrix(object):
|
||||
self is the coefficient matrix A and rhs is the right side b.
|
||||
|
||||
This is for symbolic matrices, for real or complex ones use
|
||||
- sympy.mpmath.lu_solve or sympy.mpmath.qr_solve.
|
||||
+ mpmath.lu_solve or mpmath.qr_solve.
|
||||
|
||||
"""
|
||||
if rhs.rows != self.rows:
|
||||
@@ -1367,7 +1367,7 @@ class Matrix(object):
|
||||
to use QRsolve.
|
||||
|
||||
This is mainly for educational purposes and symbolic matrices, for real
|
||||
- (or complex) matrices use sympy.mpmath.qr_solve.
|
||||
+ (or complex) matrices use mpmath.qr_solve.
|
||||
"""
|
||||
|
||||
Q, R = self.QRdecomposition()
|
||||
diff -up sympy-0.7.1/sympy/ntheory/partitions_.py.mpmath sympy-0.7.1/sympy/ntheory/partitions_.py
|
||||
--- sympy-0.7.1/sympy/ntheory/partitions_.py.mpmath 2011-06-28 09:41:12.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/ntheory/partitions_.py 2011-10-12 01:53:48.569102884 +0300
|
||||
@@ -1,4 +1,4 @@
|
||||
-from sympy.mpmath.libmp import (fzero,
|
||||
+from mpmath.libmp import (fzero,
|
||||
from_man_exp, from_int, from_rational,
|
||||
fone, fhalf, bitcount, to_int, to_str, mpf_mul, mpf_div, mpf_sub,
|
||||
mpf_add, mpf_sqrt, mpf_pi, mpf_cosh_sinh, pi_fixed, mpf_cos)
|
||||
diff -up sympy-0.7.1/sympy/physics/quantum/constants.py.mpmath sympy-0.7.1/sympy/physics/quantum/constants.py
|
||||
--- sympy-0.7.1/sympy/physics/quantum/constants.py.mpmath 2011-06-29 11:58:11.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/physics/quantum/constants.py 2011-10-12 01:53:48.569102884 +0300
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
from sympy.core.numbers import NumberSymbol
|
||||
from sympy.printing.pretty.stringpict import prettyForm
|
||||
-import sympy.mpmath.libmp as mlib
|
||||
+import mpmath.libmp as mlib
|
||||
|
||||
#-----------------------------------------------------------------------------
|
||||
# Constants
|
||||
diff -up sympy-0.7.1/sympy/polys/domains/groundtypes.py.mpmath sympy-0.7.1/sympy/polys/domains/groundtypes.py
|
||||
--- sympy-0.7.1/sympy/polys/domains/groundtypes.py.mpmath 2011-07-26 02:59:44.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/polys/domains/groundtypes.py 2011-10-12 01:53:48.569102884 +0300
|
||||
@@ -66,13 +66,13 @@ else:
|
||||
gmpy_lcm = None
|
||||
gmpy_sqrt = None
|
||||
|
||||
-from sympy.mpmath import (
|
||||
+from mpmath import (
|
||||
mpf as MPmathRealType,
|
||||
mpc as MPmathComplexType,
|
||||
mpi as MPmathIntervalType,
|
||||
)
|
||||
|
||||
-from sympy.mpmath.libmp.libmpf import isqrt
|
||||
+from mpmath.libmp.libmpf import isqrt
|
||||
|
||||
def python_sqrt(a):
|
||||
return int(isqrt(a))
|
||||
diff -up sympy-0.7.1/sympy/polys/numberfields.py.mpmath sympy-0.7.1/sympy/polys/numberfields.py
|
||||
--- sympy-0.7.1/sympy/polys/numberfields.py.mpmath 2011-07-28 00:06:54.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/polys/numberfields.py 2011-10-12 01:53:48.569102884 +0300
|
||||
@@ -28,7 +28,7 @@ from sympy.utilities import (
|
||||
)
|
||||
|
||||
from sympy.ntheory import sieve
|
||||
-from sympy.mpmath import pslq, mp
|
||||
+from mpmath import pslq, mp
|
||||
|
||||
def minimal_polynomial(ex, x=None, **args):
|
||||
"""
|
||||
diff -up sympy-0.7.1/sympy/polys/polytools.py.mpmath sympy-0.7.1/sympy/polys/polytools.py
|
||||
--- sympy-0.7.1/sympy/polys/polytools.py.mpmath 2011-07-30 03:04:27.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/polys/polytools.py 2011-10-12 01:53:48.570102912 +0300
|
||||
@@ -63,7 +63,7 @@ from sympy.utilities import (
|
||||
from sympy.ntheory import isprime
|
||||
|
||||
import sympy.polys
|
||||
-import sympy.mpmath
|
||||
+import mpmath
|
||||
|
||||
from sympy.polys.domains import FF, QQ
|
||||
from sympy.polys.constructor import construct_domain
|
||||
@@ -2912,16 +2912,16 @@ class Poly(Expr):
|
||||
|
||||
coeffs = [ coeff.evalf(n=n).as_real_imag() for coeff in f.all_coeffs() ]
|
||||
|
||||
- dps = sympy.mpmath.mp.dps
|
||||
- sympy.mpmath.mp.dps = n
|
||||
+ dps = mpmath.mp.dps
|
||||
+ mpmath.mp.dps = n
|
||||
|
||||
try:
|
||||
try:
|
||||
- coeffs = [ sympy.mpmath.mpc(*coeff) for coeff in coeffs ]
|
||||
+ coeffs = [ mpmath.mpc(*coeff) for coeff in coeffs ]
|
||||
except TypeError:
|
||||
raise DomainError("numerical domain expected, got %s" % f.rep.dom)
|
||||
|
||||
- result = sympy.mpmath.polyroots(coeffs, maxsteps=maxsteps, cleanup=cleanup, error=error)
|
||||
+ result = mpmath.polyroots(coeffs, maxsteps=maxsteps, cleanup=cleanup, error=error)
|
||||
|
||||
if error:
|
||||
roots, error = result
|
||||
@@ -2930,7 +2930,7 @@ class Poly(Expr):
|
||||
|
||||
roots = map(sympify, sorted(roots, key=lambda r: (r.real, r.imag)))
|
||||
finally:
|
||||
- sympy.mpmath.mp.dps = dps
|
||||
+ mpmath.mp.dps = dps
|
||||
|
||||
if error is not None:
|
||||
return roots, sympify(error)
|
||||
diff -up sympy-0.7.1/sympy/polys/rootoftools.py.mpmath sympy-0.7.1/sympy/polys/rootoftools.py
|
||||
--- sympy-0.7.1/sympy/polys/rootoftools.py.mpmath 2011-07-07 06:08:19.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/polys/rootoftools.py 2011-10-12 01:53:48.571102940 +0300
|
||||
@@ -21,7 +21,7 @@ from sympy.polys.polyerrors import (
|
||||
|
||||
from sympy.polys.domains import QQ
|
||||
|
||||
-from sympy.mpmath import (
|
||||
+from mpmath import (
|
||||
mp, mpf, mpc, findroot)
|
||||
|
||||
from sympy.utilities import lambdify
|
||||
diff -up sympy-0.7.1/sympy/printing/latex.py.mpmath sympy-0.7.1/sympy/printing/latex.py
|
||||
--- sympy-0.7.1/sympy/printing/latex.py.mpmath 2011-07-30 03:04:28.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/printing/latex.py 2011-10-12 01:53:48.571102940 +0300
|
||||
@@ -8,8 +8,8 @@ from conventions import split_super_sub
|
||||
from sympy.simplify import fraction
|
||||
from sympy import Interval
|
||||
|
||||
-import sympy.mpmath.libmp as mlib
|
||||
-from sympy.mpmath.libmp import prec_to_dps
|
||||
+import mpmath.libmp as mlib
|
||||
+from mpmath.libmp import prec_to_dps
|
||||
|
||||
from sympy.core.compatibility import cmp_to_key
|
||||
|
||||
diff -up sympy-0.7.1/sympy/printing/repr.py.mpmath sympy-0.7.1/sympy/printing/repr.py
|
||||
--- sympy-0.7.1/sympy/printing/repr.py.mpmath 2011-07-24 06:17:32.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/printing/repr.py 2011-10-12 01:53:48.571102940 +0300
|
||||
@@ -7,8 +7,8 @@ relation eval(srepr(expr))=expr holds in
|
||||
|
||||
from printer import Printer
|
||||
from sympy.core import Basic
|
||||
-import sympy.mpmath.libmp as mlib
|
||||
-from sympy.mpmath.libmp import prec_to_dps, repr_dps
|
||||
+import mpmath.libmp as mlib
|
||||
+from mpmath.libmp import prec_to_dps, repr_dps
|
||||
|
||||
class ReprPrinter(Printer):
|
||||
printmethod = "_sympyrepr"
|
||||
diff -up sympy-0.7.1/sympy/printing/str.py.mpmath sympy-0.7.1/sympy/printing/str.py
|
||||
--- sympy-0.7.1/sympy/printing/str.py.mpmath 2011-07-28 00:06:54.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/printing/str.py 2011-10-12 01:53:48.572102968 +0300
|
||||
@@ -6,8 +6,8 @@ from sympy.core import S, Rational, Pow,
|
||||
from printer import Printer
|
||||
from sympy.printing.precedence import precedence, PRECEDENCE
|
||||
|
||||
-import sympy.mpmath.libmp as mlib
|
||||
-from sympy.mpmath.libmp import prec_to_dps
|
||||
+import mpmath.libmp as mlib
|
||||
+from mpmath.libmp import prec_to_dps
|
||||
|
||||
from sympy.polys.polyerrors import PolynomialError
|
||||
|
||||
diff -up sympy-0.7.1/sympy/simplify/simplify.py.mpmath sympy-0.7.1/sympy/simplify/simplify.py
|
||||
--- sympy-0.7.1/sympy/simplify/simplify.py.mpmath 2011-07-30 03:04:29.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/simplify/simplify.py 2011-10-12 01:53:48.572102968 +0300
|
||||
@@ -18,7 +18,7 @@ from sympy.polys import (Poly, together,
|
||||
|
||||
from sympy.core.compatibility import reduce
|
||||
|
||||
-import sympy.mpmath as mpmath
|
||||
+import mpmath as mpmath
|
||||
|
||||
def fraction(expr, exact=False):
|
||||
"""Returns a pair with expression's numerator and denominator.
|
||||
diff -up sympy-0.7.1/sympy/solvers/solvers.py.mpmath sympy-0.7.1/sympy/solvers/solvers.py
|
||||
--- sympy-0.7.1/sympy/solvers/solvers.py.mpmath 2011-07-30 03:04:29.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/solvers/solvers.py 2011-10-12 01:53:48.572102968 +0300
|
||||
@@ -25,7 +25,7 @@ from sympy.polys import roots, cancel, P
|
||||
from sympy.functions.elementary.piecewise import piecewise_fold
|
||||
|
||||
from sympy.utilities.lambdify import lambdify
|
||||
-from sympy.mpmath import findroot
|
||||
+from mpmath import findroot
|
||||
|
||||
from sympy.solvers.polysys import solve_poly_system
|
||||
from sympy.solvers.inequalities import reduce_inequalities
|
||||
@@ -1182,7 +1182,7 @@ def nsolve(*args, **kwargs):
|
||||
|
||||
>>> from sympy import Symbol, nsolve
|
||||
>>> import sympy
|
||||
- >>> sympy.mpmath.mp.dps = 15
|
||||
+ >>> mpmath.mp.dps = 15
|
||||
>>> x1 = Symbol('x1')
|
||||
>>> x2 = Symbol('x2')
|
||||
>>> f1 = 3 * x1**2 - 2 * x2**2 - 1
|
||||
diff -up sympy-0.7.1/sympy/solvers/tests/test_numeric.py.mpmath sympy-0.7.1/sympy/solvers/tests/test_numeric.py
|
||||
--- sympy-0.7.1/sympy/solvers/tests/test_numeric.py.mpmath 2011-06-29 11:58:12.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/solvers/tests/test_numeric.py 2011-10-12 01:53:48.573102996 +0300
|
||||
@@ -1,4 +1,4 @@
|
||||
-from sympy.mpmath import mnorm, mpf
|
||||
+from mpmath import mnorm, mpf
|
||||
from sympy.solvers import nsolve
|
||||
from sympy.utilities.lambdify import lambdify
|
||||
from sympy import Symbol, Matrix, sqrt, Eq
|
||||
diff -up sympy-0.7.1/sympy/statistics/distributions.py.mpmath sympy-0.7.1/sympy/statistics/distributions.py
|
||||
--- sympy-0.7.1/sympy/statistics/distributions.py.mpmath 2011-06-29 11:58:12.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/statistics/distributions.py 2011-10-12 01:53:48.573102996 +0300
|
||||
@@ -135,7 +135,7 @@ class Normal(ContinuousProbability):
|
||||
# error function is not yet implemented in SymPy but can easily be
|
||||
# computed numerically
|
||||
|
||||
- from sympy.mpmath import mpf, erfinv
|
||||
+ from mpmath import mpf, erfinv
|
||||
|
||||
# calculate y = ierf(p) by solving erf(y) - p = 0
|
||||
y = erfinv(mpf(p))
|
||||
diff -up sympy-0.7.1/sympy/statistics/tests/test_statistics.py.mpmath sympy-0.7.1/sympy/statistics/tests/test_statistics.py
|
||||
--- sympy-0.7.1/sympy/statistics/tests/test_statistics.py.mpmath 2011-06-29 11:58:12.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/statistics/tests/test_statistics.py 2011-10-12 01:53:48.573102996 +0300
|
||||
@@ -4,7 +4,7 @@ from sympy.statistics import Normal, Uni
|
||||
from sympy.statistics.distributions import PDF
|
||||
from operator import abs
|
||||
|
||||
-from sympy.mpmath import mp
|
||||
+from mpmath import mp
|
||||
|
||||
def test_normal():
|
||||
dps, mp.dps = mp.dps, 20
|
||||
diff -up sympy-0.7.1/sympy/utilities/lambdify.py.mpmath sympy-0.7.1/sympy/utilities/lambdify.py
|
||||
--- sympy-0.7.1/sympy/utilities/lambdify.py.mpmath 2011-07-28 00:06:55.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/utilities/lambdify.py 2011-10-12 01:53:48.573102996 +0300
|
||||
@@ -70,7 +70,7 @@ NUMPY_TRANSLATIONS = {
|
||||
# Available modules:
|
||||
MODULES = {
|
||||
"math":(MATH, MATH_DEFAULT, MATH_TRANSLATIONS, ("from math import *",)),
|
||||
- "mpmath":(MPMATH, MPMATH_DEFAULT, MPMATH_TRANSLATIONS, ("from sympy.mpmath import *",)),
|
||||
+ "mpmath":(MPMATH, MPMATH_DEFAULT, MPMATH_TRANSLATIONS, ("from mpmath import *",)),
|
||||
"numpy":(NUMPY, NUMPY_DEFAULT, NUMPY_TRANSLATIONS, ("from numpy import *",)),
|
||||
"sympy":(SYMPY, SYMPY_DEFAULT, {}, ("from sympy.functions import *",
|
||||
"from sympy.matrices import Matrix",
|
||||
diff -up sympy-0.7.1/sympy/utilities/runtests.py.mpmath sympy-0.7.1/sympy/utilities/runtests.py
|
||||
--- sympy-0.7.1/sympy/utilities/runtests.py.mpmath 2011-07-30 03:04:30.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/utilities/runtests.py 2011-10-12 01:53:48.573102996 +0300
|
||||
@@ -220,7 +220,7 @@ def doctest(*paths, **kwargs):
|
||||
blacklist = kwargs.get("blacklist", [])
|
||||
blacklist.extend([
|
||||
"doc/src/modules/mpmath", # needs to be fixed upstream
|
||||
- "sympy/mpmath", # needs to be fixed upstream
|
||||
+ "mpmath", # needs to be fixed upstream
|
||||
"doc/src/modules/plotting.txt", # generates live plots
|
||||
"sympy/plotting", # generates live plots
|
||||
"sympy/utilities/compilef.py", # needs tcc
|
||||
diff -up sympy-0.7.1/sympy/utilities/tests/test_lambdify.py.mpmath sympy-0.7.1/sympy/utilities/tests/test_lambdify.py
|
||||
--- sympy-0.7.1/sympy/utilities/tests/test_lambdify.py.mpmath 2011-07-28 00:06:55.000000000 +0300
|
||||
+++ sympy-0.7.1/sympy/utilities/tests/test_lambdify.py 2011-10-12 01:53:48.574103024 +0300
|
||||
@@ -2,7 +2,7 @@ from sympy.utilities.pytest import XFAIL
|
||||
from sympy import (symbols, lambdify, sqrt, sin, cos, pi, atan, Rational, Float,
|
||||
Matrix, Lambda, exp, Integral, oo, I)
|
||||
from sympy.printing.lambdarepr import LambdaPrinter
|
||||
-from sympy import mpmath
|
||||
+import mpmath
|
||||
from sympy.utilities.lambdify import implemented_function
|
||||
import math, sympy
|
||||
|
70
sympy.spec
70
sympy.spec
@ -1,18 +1,23 @@
|
||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
|
||||
Name: sympy
|
||||
Version: 0.6.3
|
||||
Release: 3%{?dist}
|
||||
Version: 0.7.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A Python library for symbolic mathematics
|
||||
Group: Development/Languages
|
||||
License: BSD
|
||||
URL: http://code.google.com/p/sympy/
|
||||
Source0: http://sympy.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||
# Upstream tried to graft in another project as a private copy; we rip
|
||||
# it out (rhbz# 551576):
|
||||
Patch0: sympy-0.7.1-strip-internal-mpmath.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: python-devel
|
||||
|
||||
BuildRequires: python-mpmath
|
||||
Requires: python-mpmath
|
||||
|
||||
%description
|
||||
SymPy aims to become a full-featured computer algebra system (CAS)
|
||||
@ -20,33 +25,72 @@ while keeping the code as simple as possible in order to be
|
||||
comprehensible and easily extensible. SymPy is written entirely in
|
||||
Python and does not require any external libraries.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .mpmath
|
||||
rm -rf sympy/mpmath doc/src/modules/mpmath
|
||||
|
||||
#patch1 -p1
|
||||
#patch2 -p1
|
||||
|
||||
%build
|
||||
%{__python} setup.py build
|
||||
|
||||
python setup.py build
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
|
||||
rm -rf %{buildroot}
|
||||
python setup.py install -O1 --skip-build --root %{buildroot}
|
||||
# Remove extra files
|
||||
rm -f %{buildroot}%{_bindir}/{,doc}test
|
||||
|
||||
%check
|
||||
python setup.py test
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc README LICENSE
|
||||
%{python_sitelib}/*
|
||||
%{python_sitelib}/sympy/
|
||||
%{python_sitelib}/sympy-%{version}-*.egg-info
|
||||
%{_bindir}/isympy
|
||||
%{_mandir}/man1/isympy.1*
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 11 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 0.7.1-1
|
||||
- Update to 0.7.1.
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.7-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Aug 30 2010 Jussi Lehtola <jussilehtola@fedoraproject.org> - 0.6.7-5
|
||||
- Patch around BZ #564504.
|
||||
|
||||
* Sat Jul 31 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.7-4
|
||||
- fix a python 2.7 incompatibility
|
||||
|
||||
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||
|
||||
* Tue Apr 27 2010 Jussi Lehtola <jussilehtola@fedoraproject.org> - 0.6.7-2
|
||||
- Added %%check phase.
|
||||
|
||||
* Tue Apr 27 2010 Jussi Lehtola <jussilehtola@fedoraproject.org> - 0.6.7-1
|
||||
- Update to 0.6.7.
|
||||
|
||||
* Mon Feb 15 2010 Conrad Meyer <konrad@tylerc.org> - 0.6.6-3
|
||||
- Patch around private copy nicely; avoid breakage from trying to replace
|
||||
a directory with a symlink.
|
||||
|
||||
* Mon Feb 15 2010 Conrad Meyer <konrad@tylerc.org> - 0.6.6-2
|
||||
- Remove private copy of system lib 'mpmath' (rhbz #551576).
|
||||
|
||||
* Sun Dec 27 2009 Jussi Lehtola <jussilehtola@fedoraproject.org> - 0.6.6-1
|
||||
- Update to 0.6.6.
|
||||
|
||||
* Sat Nov 07 2009 Jussi Lehtola <jussilehtola@fedoraproject.org> - 0.6.5-1
|
||||
- Update to 0.6.5.
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user