Update to v0.5.0 release

This commit is contained in:
Stefan Berger 2020-10-07 17:06:35 -04:00
parent 912e02bc81
commit 5b31389eed
4 changed files with 25 additions and 41 deletions

1
.gitignore vendored
View File

@ -15,3 +15,4 @@
/swtpm-74ae43b.tar.gz
/swtpm-80f0418.tar.gz
/swtpm-0c238a2.tar.gz
/swtpm-b931e10.tar.gz

View File

@ -1,32 +0,0 @@
From ba424f8dc89ac89430c4f7513a9c82e8a4542e52 Mon Sep 17 00:00:00 2001
From: Stefan Berger <stefanb@linux.ibm.com>
Date: Thu, 27 Aug 2020 08:28:57 -0400
Subject: [PATCH] Temporarily disable a pkcs11 test case due to bug in gnutls
GnuTLS on current F33 and rawhide has a locking bug reported here:
https://gitlab.com/gnutls/gnutls/-/issues/1060#note_392260362
Disable the test case that runs into this bug to be able to build
the package.
Signed-off-by: Stefan Berger <stefanb@linux.ibm.com>
---
tests/Makefile.am | 1 -
1 file changed, 1 deletion(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8a4a9c2..c88acb4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -79,7 +79,6 @@ TESTS += \
test_swtpm_setup_create_cert \
test_tpm2_parameters \
test_tpm2_samples_swtpm_localca \
- test_tpm2_samples_swtpm_localca_pkcs11 \
test_tpm2_swtpm_cert \
test_tpm2_swtpm_cert_ecc \
test_tpm2_swtpm_setup_create_cert
--
2.28.0

View File

@ -1 +1 @@
SHA512 (swtpm-0c238a2.tar.gz) = 584573b2cfcb295babf4f288f9dc26f0c86c15023c8e6e9f352689d49bb16dd415e37dc8dcd205ed525fe505b58d9d7d2a7a0da3a0b3cfa4b454fadeb0b2779a
SHA512 (swtpm-b931e10.tar.gz) = 33ff6edb06aa73f5f55dcabb753503877db4e656c91e5b22b4352b50ad386dff6f8c9a5e66e0f7f371f931379760bb108ccf2e704b7d1067e3b56ba472308f48

View File

@ -1,7 +1,7 @@
%bcond_without gnutls
%global gitdate 20200828
%global gitcommit 0c238a2c93cdeea4283c6e9a7b8430a9b2df2b3e
%global gitdate 20201007
%global gitcommit b931e1098533319f67e789f03c13a767a1772f7b
%global gitshortcommit %(c=%{gitcommit}; echo ${c:0:7})
# Macros needed by SELinux
@ -11,14 +11,12 @@
Summary: TPM Emulator
Name: swtpm
Version: 0.4.0
Version: 0.5.0
Release: 1.%{gitdate}git%{gitshortcommit}%{?dist}
License: BSD
Url: http://github.com/stefanberger/swtpm
Source0: %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
Patch0001: 0001-Temporarily-disable-a-pkcs11-test-case-due-to-bug-in.patch
BuildRequires: git-core
BuildRequires: automake
BuildRequires: autoconf
@ -46,6 +44,7 @@ BuildRequires: libtasn1
BuildRequires: selinux-policy-devel
BuildRequires: gcc
BuildRequires: libseccomp-devel
BuildRequires: tpm2-pkcs11 tpm2-pkcs11-tools tpm2-tools tpm2-abrmd
Requires: %{name}-libs = %{version}-%{release}
Requires: libtpms >= 0.6.0
@ -79,6 +78,16 @@ Requires: trousers >= 0.3.9 bash gnutls-utils python3 python3-cryptography
%description tools
Tools for the TPM emulator from the swtpm package
%package tools-pkcs11
Summary: Tools for creating a local CA based on a TPM pkcs11 device
License: BSD
Requires: swtpm-tools = %{version}-%{release}
Requires: tpm2-pkcs11 tpm2-pkcs11-tools tpm2-tools tpm2-abrmd
Requires: expect gnutls-utils trousers >= 0.3.9
%description tools-pkcs11
Tools for creating a local CA based on a pkcs11 device
%prep
%autosetup -S git -n %{name}-%{gitcommit}
@ -100,8 +109,6 @@ make %{?_smp_mflags} check VERBOSE=1
%make_install
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la,so}
rm -f $RPM_BUILD_ROOT%{_mandir}/man8/swtpm-create-tpmca.8*
rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/swtpm-create-tpmca
%post
for pp in /usr/share/selinux/packages/swtpm.pp \
@ -151,7 +158,6 @@ fi
%{_bindir}/swtpm_cert
%endif
%{_bindir}/swtpm_setup
%{_bindir}/swtpm_setup.sh
%{_bindir}/swtpm_ioctl
%{_mandir}/man8/swtpm_bios.8*
%{_mandir}/man8/swtpm_cert.8*
@ -170,9 +176,18 @@ fi
%{_datadir}/swtpm/swtpm-create-user-config-files
%{python3_sitelib}/py_swtpm_setup/*
%{python3_sitelib}/swtpm_setup-*/*
%{python3_sitelib}/py_swtpm_localca/*
%{python3_sitelib}/swtpm_localca-*/*
%attr( 750, tss, root) %{_localstatedir}/lib/swtpm-localca
%files tools-pkcs11
%{_mandir}/man8/swtpm-create-tpmca.8*
%{_datadir}/swtpm/swtpm-create-tpmca
%changelog
* Wed Oct 7 2020 Stefan Berger <stefanb@linux.ibm.com> - 0.4.0-1.20201007gitb931e109
- Update to v0.5.0 release
* Fri Aug 28 2020 Stefan Berger <stefanb@linux.ibm.com> - 0.4.0-1.20200828git0c238a2
- Update to v0.4.0 release