Build upcoming v0.6.1 that has patch to build with OpenSSL 3.0.0

This commit is contained in:
Stefan Berger 2021-09-16 13:50:16 -04:00
parent a3c0d75489
commit 33364fefe1
4 changed files with 9 additions and 37 deletions

1
.gitignore vendored
View File

@ -20,3 +20,4 @@
/swtpm-96f5a04.tar.gz
/swtpm-e59c0c1.tar.gz
/swtpm-ea627b3.tar.gz
/swtpm-a0ca7c3.tar.gz

View File

@ -1,29 +0,0 @@
From a0ca7c328f1c3c6a417973d194b41d06ab7b0802 Mon Sep 17 00:00:00 2001
From: Stefan Berger <stefanb@linux.ibm.com>
Date: Wed, 15 Sep 2021 11:34:02 -0400
Subject: [PATCH] build-sys: Add -Wno-deprecated-declarations to default CFLAGS
(OSSL 3)
To be able to build with OpenSSL 3.0 we need to added
-Wno-deprecated-declarations to the default CFLAGS.
Signed-off-by: Stefan Berger <stefanb@linux.ibm.com>
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index 1e0710c..7da1b47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -461,6 +461,7 @@ AC_SUBST([TSS_GROUP])
CFLAGS="$CFLAGS -Wreturn-type -Wsign-compare -Wswitch-enum"
CFLAGS="$CFLAGS -Wmissing-prototypes -Wall -Werror"
CFLAGS="$CFLAGS -Wformat -Wformat-security"
+CFLAGS="$CFLAGS -Wno-deprecated-declarations"
CFLAGS="$CFLAGS $GNUTLS_CFLAGS $COVERAGE_CFLAGS"
LDFLAGS="$LDFLAGS $COVERAGE_LDFLAGS"
--
2.31.1

View File

@ -1 +1 @@
SHA512 (swtpm-ea627b3.tar.gz) = 7396eaa295c59cb05e8c0525b34ae2c39dfa49b9f1c1a8086c9d71a907892d9cc083dd5061635e33a56e9c6e3aa93a9c6378f91c788aec56d46e586ef67aaa4a
SHA512 (swtpm-a0ca7c3.tar.gz) = 0510ae230665514a366653d877a06f1f929229b0488c6492092cdf9b966db97e6a35b906fef506d0daddc0362d76ddd91e65a0a5d185e23553afea1e91d1a4fd

View File

@ -1,7 +1,7 @@
%bcond_without gnutls
%global gitdate 20210607
%global gitcommit ea627b3b5e847f9141fcf25de0c03004d35fb375
%global gitdate 20210916
%global gitcommit a0ca7c328f1c3c6a417973d194b41d06ab7b0802
%global gitshortcommit %(c=%{gitcommit}; echo ${c:0:7})
# Macros needed by SELinux
@ -11,14 +11,12 @@
Summary: TPM Emulator
Name: swtpm
Version: 0.6.0
Release: 5.%{gitdate}git%{gitshortcommit}%{?dist}
Version: 0.6.1
Release: 0.%{gitdate}git%{gitshortcommit}%{?dist}
License: BSD
Url: http://github.com/stefanberger/swtpm
Source0: %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
Patch0001: 0001-build-sys-Add-Wno-deprecated-declarations-to-default.patch
BuildRequires: make
BuildRequires: git-core
BuildRequires: automake
@ -89,7 +87,6 @@ Tools for creating a local CA based on a pkcs11 device
%prep
%autosetup -S git -n %{name}-%{gitcommit} -p1
%patch0001 -p1
%build
@ -181,6 +178,9 @@ fi
%{_datadir}/swtpm/swtpm-create-tpmca
%changelog
* Thu Sep 16 2021 Stefan Berger <stefanb@linux.ibm.com> - 0.6.1-0.20210916gita0ca7c3
- Build upcoming v0.6.1 that has patch to build with OpenSSL 3.0.0
* Thu Sep 16 2021 Stefan Berger <stefanb@linux.ibm.com.> - 0.6.0-5.20210607gitea627b3
- Applied patch with -Wno-deprecated-declarations for build with OpenSSL 3.0.0