Merge branch 'f27'
This commit is contained in:
commit
f09a4f3f00
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,6 +1,10 @@
|
||||
*.swp
|
||||
*.rpm
|
||||
results_sword
|
||||
sword-1.6.1.tar.gz
|
||||
/sword-1.6.2.tar.gz
|
||||
/sword-1.7.2.tar.gz
|
||||
/sword-1.7.3.tar.gz
|
||||
/sword-1.7.3.900.tar.gz
|
||||
/sword-1.7.4.tar.gz
|
||||
/sword-1.8.1.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
1677f02a86cbf07713d4e1d4c39791e6 sword-1.7.4.tar.gz
|
||||
SHA512 (sword-1.8.1.tar.gz) = 5c08c070ea0c86b7d929bbf94c89730eb5a487986deb9edf01c08d1710356aecd1ab3bde4437a778e5fc1ceb05b63287612ec6161381c0986a36344c27d2ab36
|
||||
|
13
sword-1.8.1-cmake.diff
Normal file
13
sword-1.8.1-cmake.diff
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/cmake/options.cmake b/cmake/options.cmake
|
||||
index 81981c8..19b7004 100644
|
||||
--- a/cmake/options.cmake
|
||||
+++ b/cmake/options.cmake
|
||||
@@ -44,7 +44,7 @@ _SET_FANCY(SYSCONF_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/etc" "Directory to insta
|
||||
|
||||
_SET_FANCY(SHARE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/share" "Directory to install global data files. Defaults to ${SWORD_INSTALL_DIR}/share.")
|
||||
|
||||
-_SET_FANCY(SWORD_PYTHON_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}" CACHE STRING "Directory where the Python bindings will be installed. Defaults to default Python path.")
|
||||
+_SET_FANCY(SWORD_PYTHON_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}" STRING "Directory where the Python bindings will be installed. Defaults to default Python path.")
|
||||
|
||||
# Post-processing of variables
|
||||
MACRO(PROCESS_VERSION LEVEL VALUE)
|
31
sword.spec
31
sword.spec
@ -1,12 +1,13 @@
|
||||
%define soversion 1.7
|
||||
%define soversion 1.8
|
||||
|
||||
Name: sword
|
||||
Version: 1.7.4
|
||||
Release: 15%{?dist}
|
||||
Name: sword
|
||||
Version: 1.8.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Free Bible Software Project
|
||||
License: GPLv2
|
||||
URL: http://www.crosswire.org/sword/
|
||||
Source0: http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/sword-%{version}.tar.gz
|
||||
Source0: http://www.crosswire.org/ftpmirror/pub/sword/source/v1.8/sword-%{version}.tar.gz
|
||||
Patch0: sword-1.8.1-cmake.diff
|
||||
BuildRequires: cmake
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: curl-devel
|
||||
@ -67,15 +68,18 @@ Python bindings for The SWORD Library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
mkdir build
|
||||
pushd build
|
||||
%cmake -DLIBSWORD_LIBRARY_TYPE=Shared \
|
||||
-DSWORD_BINDINGS="Python" \
|
||||
-DBUILD_UTILITIES="Yes" \
|
||||
-DSWORD_BUILD_UTILITIES="Yes" \
|
||||
-DLIBSWORD_SOVERSION=%{soversion} \
|
||||
-DLIBDIR=%{_libdir} \
|
||||
-DSWORD_BUILD_TESTS=Yes \
|
||||
-DSWORD_PYTHON_INSTALL_DIR="%{buildroot}%{_prefix}" \
|
||||
..
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -91,6 +95,9 @@ find %{buildroot} -type f -name "*.la" -delete -print
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%check
|
||||
make tests
|
||||
|
||||
%files
|
||||
%doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README
|
||||
%doc samples doc
|
||||
@ -130,9 +137,19 @@ find %{buildroot} -type f -name "*.la" -delete -print
|
||||
%{python2_sitearch}/Sword.pyc
|
||||
%{python2_sitearch}/Sword.pyo
|
||||
%{python2_sitearch}/_Sword.so
|
||||
%{python2_sitearch}/sword-%{version}-py2.7.egg-info
|
||||
%{python2_sitearch}/sword-%{version}-py%{python2_version}.egg-info
|
||||
|
||||
%changelog
|
||||
* Mon Jan 08 2018 Greg Hellings <greg.hellings@gmail.com> - 1.8.1-1
|
||||
- Upstream release 1.8.1
|
||||
- Add check section
|
||||
|
||||
* Sat Dec 23 2017 Greg Hellings <greg.hellings@gmail.com> - 1.8.0-1
|
||||
- Upstream release 1.8.0
|
||||
|
||||
* Tue Dec 5 2017 Greg Hellings <greg.hellings@gmail.com> - 1.7.906-1
|
||||
- Testing 1.8.0RC6
|
||||
|
||||
* Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 1.7.4-15
|
||||
- Rebuild for ICU 60.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user