New upstream release, removing patches
This commit is contained in:
parent
8184b4fae4
commit
c55414e086
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ sword-1.6.1.tar.gz
|
||||
/sword-1.7.2.tar.gz
|
||||
/sword-1.7.3.tar.gz
|
||||
/sword-1.7.3.900.tar.gz
|
||||
/sword-1.7.4.tar.gz
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff --git a/bindings/swig/python/CMakeLists.txt b/bindings/swig/python/CMakeLists.txt
|
||||
index b661654..f608d50 100644
|
||||
--- a/bindings/swig/python/CMakeLists.txt
|
||||
+++ b/bindings/swig/python/CMakeLists.txt
|
||||
@@ -45,9 +45,9 @@ ADD_CUSTOM_TARGET(swordswig ALL
|
||||
|
||||
# Allow user installation to custom directory
|
||||
IF(SWORD_PYTHON_INSTALL_DIR)
|
||||
- SET(SETUP_ARGS "--home=${SWORD_PYTHON_INSTALL_DIR}")
|
||||
+ SET(SETUP_ARGS "--home=${SWORD_PYTHON_INSTALL_DIR} --root \$ENV{DESTDIR}")
|
||||
ELSE(SWORD_PYTHON_INSTALL_DIR)
|
||||
- SET(SETUP_ARGS "--home=${CMAKE_INSTALL_PREFIX}")
|
||||
+ SET(SETUP_ARGS "--root \$ENV{DESTDIR}")
|
||||
ENDIF(SWORD_PYTHON_INSTALL_DIR)
|
||||
CONFIGURE_FILE("${CMAKE_CURRENT_SOURCE_DIR}/install.cmake.in"
|
||||
"${CMAKE_CURRENT_BINARY_DIR}/install.cmake")
|
2
sources
2
sources
@ -1 +1 @@
|
||||
21c961c26778473ca432e4b905906804 sword-1.7.3.900.tar.gz
|
||||
1677f02a86cbf07713d4e1d4c39791e6 sword-1.7.4.tar.gz
|
||||
|
@ -1,167 +0,0 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 785e14b..d945a2a 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -119,10 +119,10 @@ ENDIF(LIBSWORD_LIBRARY_TYPE MATCHES ".*Static.*" OR NOT LIBSWORD_LIBRARY_TYPE)
|
||||
################################################################################################
|
||||
# Some random user settings
|
||||
#
|
||||
-
|
||||
-IF(NOT SWORD_GLOBAL_CONF_DIR STREQUAL "")
|
||||
- ADD_DEFINITIONS(-DGLOBCONFPATH="${SWORD_GLOBAL_CONF_DIR}/sword.conf")
|
||||
-ENDIF(NOT SWORD_GLOBAL_CONF_DIR STREQUAL "")
|
||||
+ADD_DEFINITIONS(-DGLOBCONFPATH="${SYSCONF_INSTALL_DIR}/sword.conf")
|
||||
+SET(CONFFILE "[Install]
|
||||
+DataPath=${SHARE_INSTALL_PREFIX}/sword")
|
||||
+FILE(WRITE "${CMAKE_CURRENT_BINARY_DIR}/sword.conf" "${CONFFILE}")
|
||||
|
||||
|
||||
###############################################################################################
|
||||
diff --git a/cmake/install.cmake b/cmake/install.cmake
|
||||
index fd79545..6c0b2c1 100644
|
||||
--- a/cmake/install.cmake
|
||||
+++ b/cmake/install.cmake
|
||||
@@ -3,34 +3,39 @@
|
||||
#
|
||||
MESSAGE(STATUS "\n-- CONFIGURING INSTALLATION DESTINATIONS")
|
||||
# Configuration files, of course
|
||||
-SET(prefix "${PREFIX}")
|
||||
-SET(exec_prefix "${PREFIX}")
|
||||
-SET(libdir "${LIBDIR}")
|
||||
-SET(includedir "${INCLUDEDIR}")
|
||||
|
||||
# Install the library
|
||||
IF(BUILDING_SHARED)
|
||||
INSTALL(TARGETS sword
|
||||
- DESTINATION "${LIBDIR}")
|
||||
+ RUNTIME DESTINATION "${BINDIR}"
|
||||
+ LIBRARY DESTINATION "${LIB_INSTALL_DIR}"
|
||||
+ ARCHIVE DESTINATION "${LIB_INSTALL_DIR}")
|
||||
ENDIF(BUILDING_SHARED)
|
||||
IF(BUILDING_STATIC)
|
||||
INSTALL(TARGETS sword_static
|
||||
- DESTINATION "${LIBDIR}")
|
||||
+ RUNTIME DESTINATION "${BINDIR}"
|
||||
+ LIBRARY DESTINATION "${LIB_INSTALL_DIR}"
|
||||
+ ARCHIVE DESTINATION "${LIB_INSTALL_DIR}")
|
||||
ENDIF(BUILDING_STATIC)
|
||||
# Install the locales
|
||||
INSTALL(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/locales.d
|
||||
- DESTINATION "${PREFIX}/share/sword")
|
||||
+ DESTINATION "${SHARE_INSTALL_PREFIX}/sword")
|
||||
|
||||
# Install the headers
|
||||
INSTALL(FILES ${SWORD_INSTALL_HEADERS}
|
||||
- DESTINATION "${INCLUDEDIR}/sword")
|
||||
+ DESTINATION "${INCLUDE_INSTALL_DIR}/sword")
|
||||
+# Install sysconf file
|
||||
+INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/sword.conf"
|
||||
+ DESTINATION "${SYSCONF_INSTALL_DIR}")
|
||||
+# Create the mods.d
|
||||
+INSTALL(DIRECTORY DESTINATION "${SHARE_INSTALL_PREFIX}/sword/mods.d")
|
||||
|
||||
IF(SWORD_INTERNAL_REGEX)
|
||||
INSTALL(FILES ${INTERNAL_REGEX_HEADER}
|
||||
- DESTINATION "${INCLUDEDIR}/sword")
|
||||
+ DESTINATION "${INCLUDE_INSTALL_DIR}/sword")
|
||||
ENDIF(SWORD_INTERNAL_REGEX)
|
||||
|
||||
-MESSAGE(STATUS "Destination: ${PREFIX}")
|
||||
+MESSAGE(STATUS "Destination: ${CMAKE_INSTALL_PREFIX}")
|
||||
|
||||
SET(VERSION ${SWORD_VERSION})
|
||||
IF(WITH_CURL)
|
||||
@@ -49,8 +54,12 @@ ELSE(LIBSWORD_LIBRARY_TYPE STREQUAL "Static")
|
||||
SET(SHAREDLIB_FALSE "#")
|
||||
ENDIF(LIBSWORD_LIBRARY_TYPE STREQUAL "Static")
|
||||
# The @ONLY restricts it because our ${variable} which are left there as part of pkg-config
|
||||
+SET(prefix ${CMAKE_INSTALL_PREFIX})
|
||||
+SET(libdir ${LIB_INSTALL_DIR})
|
||||
+SET(exec_prefix ${BINDIR})
|
||||
+SET(includedir ${INCLUDE_INSTALL_DIR})
|
||||
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/sword.pc.in ${CMAKE_CURRENT_BINARY_DIR}/sword.pc @ONLY)
|
||||
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/include/swversion.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/swversion.h @ONLY)
|
||||
|
||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/sword.pc
|
||||
- DESTINATION "${LIBDIR}/pkgconfig")
|
||||
+ DESTINATION "${LIB_INSTALL_DIR}/pkgconfig")
|
||||
diff --git a/cmake/options.cmake b/cmake/options.cmake
|
||||
index 3e07128..4ca7b19 100644
|
||||
--- a/cmake/options.cmake
|
||||
+++ b/cmake/options.cmake
|
||||
@@ -1,3 +1,27 @@
|
||||
+# Borrowed
|
||||
+#
|
||||
+# This macro implements some very special logic how to deal with the cache.
|
||||
+# By default the various install locations inherit their value from their "parent" variable
|
||||
+# so if you set CMAKE_INSTALL_PREFIX, then EXEC_INSTALL_PREFIX, PLUGIN_INSTALL_DIR will
|
||||
+# calculate their value by appending subdirs to CMAKE_INSTALL_PREFIX .
|
||||
+# This would work completely without using the cache.
|
||||
+# But if somebody wants e.g. a different EXEC_INSTALL_PREFIX this value has to go into
|
||||
+# the cache, otherwise it will be forgotten on the next cmake run.
|
||||
+# Once a variable is in the cache, it doesn't depend on its "parent" variables
|
||||
+# anymore and you can only change it by editing it directly.
|
||||
+# this macro helps in this regard, because as long as you don't set one of the
|
||||
+# variables explicitely to some location, it will always calculate its value from its
|
||||
+# parents. So modifying CMAKE_INSTALL_PREFIX later on will have the desired effect.
|
||||
+# But once you decide to set e.g. EXEC_INSTALL_PREFIX to some special location
|
||||
+# this will go into the cache and it will no longer depend on CMAKE_INSTALL_PREFIX.
|
||||
+macro(_SET_FANCY _var _value _comment)
|
||||
+ if (NOT DEFINED ${_var})
|
||||
+ set(${_var} ${_value})
|
||||
+ else()
|
||||
+ set(${_var} "${${_var}}" CACHE STRING "${_comment}")
|
||||
+ endif()
|
||||
+endmacro(_SET_FANCY)
|
||||
+
|
||||
# A list of the options that the library supports
|
||||
SET(SWORD_PYTHON_INSTALL_DIR "" CACHE STRING "Directory where the Python bindings will be installed. Defaults to default Python path.")
|
||||
|
||||
@@ -10,17 +34,17 @@ ELSE(APPLE)
|
||||
SET(SWORD_INSTALL_DIR "/usr/local")
|
||||
ENDIF(APPLE)
|
||||
|
||||
-IF(CMAKE_INSTALL_PREFIX)
|
||||
- SET(PREFIX "${CMAKE_INSTALL_PREFIX}" CACHE STRING "Directory into which to install architecture-dependent files. Defaults to ${SWORD_INSTALL_DIR}.")
|
||||
-ELSE(CMAKE_INSTALL_PREFIX)
|
||||
- SET(PREFIX "${SWORD_INSTALL_DIR}" CACHE STRING "Directory into which to install architecture-dependent files. Defaults to ${SWORD_INSTALL_DIR}")
|
||||
-ENDIF(CMAKE_INSTALL_PREFIX)
|
||||
+_SET_FANCY(CMAKE_INSTALL_PREFIX "${SWORD_INSTALL_DIR}" "Directory into which to install architecture-dependent files. Defaults to ${SWORD_INSTALL_DIR}.")
|
||||
+
|
||||
+_SET_FANCY(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib" "Object code library install directory. Defaults to ${SWORD_INSTALL_DIR}/lib")
|
||||
+
|
||||
+_SET_FANCY(INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include" "C Header files install directory. Defaults to ${SWORD_INSTALL_DIR}/include.")
|
||||
|
||||
-SET(LIBDIR "${PREFIX}/lib" CACHE STRING "Object code library install directory. Defaults to ${SWORD_INSTALL_DIR}/lib")
|
||||
+SET(BINDIR "${CMAKE_INSTALL_PREFIX}/bin" CACHE STRING "Directory to install binary executable files. Defaults to ${SWORD_INSTALL_DIR}/bin.")
|
||||
|
||||
-SET(INCLUDEDIR "${PREFIX}/include" CACHE STRING "C Header files install directory. Defaults to ${SWORD_INSTALL_DIR}/include.")
|
||||
+_SET_FANCY(SYSCONF_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/etc" "Directory to install global config files. Defaults to ${SWORD_INSTALL_DIR}/etc.")
|
||||
|
||||
-SET(BINDIR "${PREFIX}/bin" CACHE STRING "Directory to install binary executable files. Defaults to ${SWORD_INSTALL_DIR}/bin.")
|
||||
+_SET_FANCY(SHARE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/share" "Directory to install global data files. Defaults to ${SWORD_INSTALL_DIR}/share.")
|
||||
|
||||
# Post-processing of variables
|
||||
MACRO(PROCESS_VERSION LEVEL VALUE)
|
||||
diff --git a/utilities/CMakeLists.txt b/utilities/CMakeLists.txt
|
||||
index 169bda4..e7bd82d 100644
|
||||
--- a/utilities/CMakeLists.txt
|
||||
+++ b/utilities/CMakeLists.txt
|
||||
@@ -88,7 +88,7 @@ ENDIF(BUILDING_SHARED)
|
||||
#
|
||||
FOREACH(UTIL ${install_UTILITIES})
|
||||
INSTALL(TARGETS ${UTIL}
|
||||
- DESTINATION ${BINDIR}
|
||||
+ RUNTIME DESTINATION "${BINDIR}"
|
||||
COMPONENT utilities
|
||||
)
|
||||
ENDFOREACH(UTIL ${install_UTILITIES})
|
||||
@@ -113,7 +113,7 @@ ELSE(BUILDING_SHARED)
|
||||
TARGET_LINK_LIBRARIES(diatheke sword_static)
|
||||
ENDIF(BUILDING_SHARED)
|
||||
INSTALL(TARGETS diatheke
|
||||
- DESTINATION ${BINDIR}
|
||||
+ DESTINATION "${BINDIR}"
|
||||
COMPONENT utilities
|
||||
)
|
||||
|
13
sword.spec
13
sword.spec
@ -1,8 +1,8 @@
|
||||
%define soversion 1.7
|
||||
|
||||
Name: sword
|
||||
Version: 1.7.3.900
|
||||
Release: 3%{?dist}
|
||||
Version: 1.7.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Free Bible Software Project
|
||||
License: GPLv2
|
||||
URL: http://www.crosswire.org/sword/
|
||||
@ -17,8 +17,6 @@ BuildRequires: clucene-core-devel
|
||||
BuildRequires: cppunit-devel
|
||||
BuildRequires: swig
|
||||
BuildRequires: python-devel
|
||||
Patch0: install_swig_destdir.diff
|
||||
Patch1: standard_cmake_args.diff
|
||||
|
||||
%description
|
||||
The SWORD Project is the CrossWire Bible Society's free Bible software
|
||||
@ -65,9 +63,6 @@ Python bindings for The SWORD Library.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .swigdest
|
||||
%patch1 -p1 -b .cmakeargs
|
||||
|
||||
%build
|
||||
mkdir build
|
||||
pushd build
|
||||
@ -133,6 +128,10 @@ find %{buildroot} -type f -name "*.la" -delete -print
|
||||
%{python2_sitearch}/sword-%{version}-py2.7.egg-info
|
||||
|
||||
%changelog
|
||||
* Wed Dec 24 2014 Greg Hellings <greg.hellings@gmail.com> - 1.7.4-1
|
||||
- New upstream release
|
||||
- Removed upstreamed patches
|
||||
|
||||
* Tue Dec 09 2014 Greg Hellings <greg.hellings@gmail.com> - 1.7.3.900-3
|
||||
- Fixed invalid pkg-config
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user