Add Perl bindings

This commit is contained in:
Dominique Corbex 2019-08-05 14:41:05 +02:00
parent 7ab2dc8c5e
commit 8b9dd20df6
2 changed files with 37 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff --git a/bindings/swig/perl/CMakeLists.txt b/bindings/swig/perl/CMakeLists.txt
index 3e2e2e9..46f4c8f 100644
--- a/bindings/swig/perl/CMakeLists.txt
+++ b/bindings/swig/perl/CMakeLists.txt
@@ -23,6 +23,7 @@ WriteMakefile(
'NAME' => 'Sword',
'VERSION' => '${SWORD_VERSION}',
'INC' => '-I${CMAKE_SOURCE_DIR}/include -I${CMAKE_CURRENT_SOURCE_DIR}/..',
+ 'INSTALLDIRS' => 'vendor',
'DEFINE' => '-DSWIG',
'LIBS' => '-L${CMAKE_BINARY_DIR} -lsword -lz',
'FIRST_MAKEFILE' => 'Makefile.perlswig',

View File

@ -2,7 +2,7 @@
Name: sword
Version: 1.8.1
Release: 12%{?dist}
Release: 13%{?dist}
Summary: Free Bible Software Project
License: GPLv2
URL: http://www.crosswire.org/sword/
@ -10,6 +10,7 @@ Source0: http://www.crosswire.org/ftpmirror/pub/sword/source/v1.8/sword-%
Patch0: sword-1.8.1-cmake.diff
Patch1: sword-1.8.1-icu61.diff
Patch2: sword-1.8.1-swig.diff
Patch3: sword-1.8.1-swig-perl.diff
BuildRequires: cmake
BuildRequires: cmake-data
BuildRequires: openssl-devel
@ -21,6 +22,7 @@ BuildRequires: clucene-core-devel
BuildRequires: cppunit-devel
BuildRequires: swig
BuildRequires: python3-devel
BuildRequires: perl-devel
BuildRequires: gcc
BuildRequires: gcc-c++
@ -65,17 +67,30 @@ Requires: python3
%description -n python3-sword
Python bindings for The SWORD Library.
%package -n perl-sword
%{?perl_provide:%perl_provide perl-sword}
Summary: Perl bindings for Sword
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: perl
Requires: perl-XML-LibXML
Requires: perl-HTML-Strip
%description -n perl-sword
Perl bindings for The SWORD Library.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%build
mkdir build
pushd build
%cmake -DLIBSWORD_LIBRARY_TYPE=Shared \
-DSWORD_PYTHON_3:BOOL=TRUE \
-DSWORD_PERL:BOOL=TRUE \
-DSWORD_BUILD_UTILITIES="Yes" \
-DLIBSWORD_SOVERSION=%{soversion} \
-DLIBDIR=%{_libdir} \
@ -135,7 +150,16 @@ make tests
%{python3_sitearch}/__pycache__/*
%{python3_sitearch}/sword-%{version}-py%{python3_version}.egg-info
%files -n perl-sword
%{perl_vendorarch}/*
%exclude %dir %{perl_vendorarch}/auto/
%exclude %{_libdir}/perl5/perllocal.pod
%changelog
* Sun Aug 04 2019 Dominique Corbex <dominique@corbex.org> - 1.8.1-13
- Added Perl bindings
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild