Merge branch 'master' into epel7
This commit is contained in:
commit
63e674a967
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,6 +1,10 @@
|
|||||||
|
*.swp
|
||||||
|
*.rpm
|
||||||
|
results_sword
|
||||||
sword-1.6.1.tar.gz
|
sword-1.6.1.tar.gz
|
||||||
/sword-1.6.2.tar.gz
|
/sword-1.6.2.tar.gz
|
||||||
/sword-1.7.2.tar.gz
|
/sword-1.7.2.tar.gz
|
||||||
/sword-1.7.3.tar.gz
|
/sword-1.7.3.tar.gz
|
||||||
/sword-1.7.3.900.tar.gz
|
/sword-1.7.3.900.tar.gz
|
||||||
/sword-1.7.4.tar.gz
|
/sword-1.7.4.tar.gz
|
||||||
|
/sword-1.8.1.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
1677f02a86cbf07713d4e1d4c39791e6 sword-1.7.4.tar.gz
|
SHA512 (sword-1.8.1.tar.gz) = 5c08c070ea0c86b7d929bbf94c89730eb5a487986deb9edf01c08d1710356aecd1ab3bde4437a778e5fc1ceb05b63287612ec6161381c0986a36344c27d2ab36
|
||||||
|
13
sword-1.8.1-cmake.diff
Normal file
13
sword-1.8.1-cmake.diff
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/cmake/options.cmake b/cmake/options.cmake
|
||||||
|
index 81981c8..19b7004 100644
|
||||||
|
--- a/cmake/options.cmake
|
||||||
|
+++ b/cmake/options.cmake
|
||||||
|
@@ -44,7 +44,7 @@ _SET_FANCY(SYSCONF_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/etc" "Directory to insta
|
||||||
|
|
||||||
|
_SET_FANCY(SHARE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/share" "Directory to install global data files. Defaults to ${SWORD_INSTALL_DIR}/share.")
|
||||||
|
|
||||||
|
-_SET_FANCY(SWORD_PYTHON_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}" CACHE STRING "Directory where the Python bindings will be installed. Defaults to default Python path.")
|
||||||
|
+_SET_FANCY(SWORD_PYTHON_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}" STRING "Directory where the Python bindings will be installed. Defaults to default Python path.")
|
||||||
|
|
||||||
|
# Post-processing of variables
|
||||||
|
MACRO(PROCESS_VERSION LEVEL VALUE)
|
84
sword.spec
84
sword.spec
@ -1,12 +1,13 @@
|
|||||||
%define soversion 1.7
|
%define soversion 1.8
|
||||||
|
|
||||||
Name: sword
|
Name: sword
|
||||||
Version: 1.7.4
|
Version: 1.8.1
|
||||||
Release: 6%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Free Bible Software Project
|
Summary: Free Bible Software Project
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://www.crosswire.org/sword/
|
URL: http://www.crosswire.org/sword/
|
||||||
Source0: http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/sword-%{version}.tar.gz
|
Source0: http://www.crosswire.org/ftpmirror/pub/sword/source/v1.8/sword-%{version}.tar.gz
|
||||||
|
Patch0: sword-1.8.1-cmake.diff
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: curl-devel
|
BuildRequires: curl-devel
|
||||||
@ -17,6 +18,8 @@ BuildRequires: clucene-core-devel
|
|||||||
BuildRequires: cppunit-devel
|
BuildRequires: cppunit-devel
|
||||||
BuildRequires: swig
|
BuildRequires: swig
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The SWORD Project is the CrossWire Bible Society's free Bible software
|
The SWORD Project is the CrossWire Bible Society's free Bible software
|
||||||
@ -52,25 +55,35 @@ a packaged release as updates to the utilities do not affect the
|
|||||||
release schedule of the library. However, these utilities were the
|
release schedule of the library. However, these utilities were the
|
||||||
latest at the time of the current library release.
|
latest at the time of the current library release.
|
||||||
|
|
||||||
%package python
|
%package -n python2-sword
|
||||||
|
%{?python_provide:%python_provide python2-sword}
|
||||||
|
# Remove before F30
|
||||||
|
Provides: %{name}-python = %{version}-%{release}
|
||||||
|
Provides: %{name}-python%{?_isa} = %{version}-%{release}
|
||||||
|
Provides: python-%{name}
|
||||||
|
Obsoletes: %{name}-python < %{version}-%{release}
|
||||||
|
Obsoletes: python-%{name} < %{version}-%{release}
|
||||||
Summary: Python bindings for Sword
|
Summary: Python bindings for Sword
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
Requires: python
|
Requires: python2
|
||||||
|
|
||||||
%description python
|
%description -n python2-sword
|
||||||
Python bindings for The SWORD Library.
|
Python bindings for The SWORD Library.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
mkdir build
|
mkdir build
|
||||||
pushd build
|
pushd build
|
||||||
%cmake -DLIBSWORD_LIBRARY_TYPE=Shared \
|
%cmake -DLIBSWORD_LIBRARY_TYPE=Shared \
|
||||||
-DSWORD_BINDINGS="Python" \
|
-DSWORD_BINDINGS="Python" \
|
||||||
-DBUILD_UTILITIES="Yes" \
|
-DSWORD_BUILD_UTILITIES="Yes" \
|
||||||
-DLIBSWORD_SOVERSION=%{soversion} \
|
-DLIBSWORD_SOVERSION=%{soversion} \
|
||||||
-DLIBDIR=%{_libdir} \
|
-DLIBDIR=%{_libdir} \
|
||||||
|
-DSWORD_BUILD_TESTS=Yes \
|
||||||
|
-DSWORD_PYTHON_INSTALL_DIR="%{buildroot}%{_prefix}" \
|
||||||
..
|
..
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -82,9 +95,8 @@ mkdir -p %{buildroot}%{_datadir}/sword/modules
|
|||||||
|
|
||||||
find %{buildroot} -type f -name "*.la" -delete -print
|
find %{buildroot} -type f -name "*.la" -delete -print
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%check
|
||||||
|
make tests
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README
|
%doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README
|
||||||
@ -120,14 +132,60 @@ find %{buildroot} -type f -name "*.la" -delete -print
|
|||||||
%{_bindir}/mod2osis
|
%{_bindir}/mod2osis
|
||||||
%{_bindir}/emptyvss
|
%{_bindir}/emptyvss
|
||||||
|
|
||||||
%files python
|
%files -n python2-sword
|
||||||
%{python2_sitearch}/Sword.py
|
%{python2_sitearch}/Sword.py
|
||||||
%{python2_sitearch}/Sword.pyc
|
%{python2_sitearch}/Sword.pyc
|
||||||
%{python2_sitearch}/Sword.pyo
|
%{python2_sitearch}/Sword.pyo
|
||||||
%{python2_sitearch}/_Sword.so
|
%{python2_sitearch}/_Sword.so
|
||||||
%{python2_sitearch}/sword-%{version}-py2.7.egg-info
|
%{python2_sitearch}/sword-%{version}-py%{python2_version}.egg-info
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 18 2018 Gregory Hellings <greg.hellings@gmail.com> - 1.8.1-3
|
||||||
|
- Remove post/postun for F28+
|
||||||
|
- Rename python-sword to python2-sword
|
||||||
|
- Add BR for gcc/g++ per F28+ changes
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org>
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 08 2018 Greg Hellings <greg.hellings@gmail.com> - 1.8.1-1
|
||||||
|
- Upstream release 1.8.1
|
||||||
|
- Add check section
|
||||||
|
|
||||||
|
* Sat Dec 23 2017 Greg Hellings <greg.hellings@gmail.com> - 1.8.0-1
|
||||||
|
- Upstream release 1.8.0
|
||||||
|
|
||||||
|
* Tue Dec 5 2017 Greg Hellings <greg.hellings@gmail.com> - 1.7.906-1
|
||||||
|
- Testing 1.8.0RC6
|
||||||
|
|
||||||
|
* Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 1.7.4-15
|
||||||
|
- Rebuild for ICU 60.1
|
||||||
|
|
||||||
|
* Sun Aug 20 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.7.4-14
|
||||||
|
- Add Provides for the old name without %%_isa
|
||||||
|
|
||||||
|
* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.7.4-13
|
||||||
|
- Python 2 binary package renamed to python2-sword
|
||||||
|
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.4-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.4-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.4-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.4-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.4-8
|
||||||
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||||
|
|
||||||
|
* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 1.7.4-7
|
||||||
|
- rebuild for ICU 57.1
|
||||||
|
|
||||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.4-6
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.4-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user