swig/swig-3.0.12-Fix-testsuite-t...

62 lines
2.2 KiB
Diff

From 8855ef2b482c09da9255079b0fac92d08c8308fb Mon Sep 17 00:00:00 2001
From: Olly Betts <olly@survex.com>
Date: Tue, 13 Jun 2017 17:32:37 +1200
Subject: [PATCH] [Perl] Fix testsuite to work without . in @INC
"." was removed from @INC in Perl 5.26 for security reasons, and has
also been removed from older versions in some distros.
Fixes https://github.com/swig/swig/issues/997 reported by lfam.
---
CHANGES.current | 6 ++++++
Examples/Makefile.in | 2 +-
Examples/test-suite/perl5/run-perl-test.pl | 2 +-
3 files changed, 8 insertions(+), 2 deletions(-)
#diff --git a/CHANGES.current b/CHANGES.current
#index ac620c9..6b379a9 100644
#--- a/CHANGES.current
#+++ b/CHANGES.current
#@@ -7,6 +7,12 @@ the issue number to the end of the URL: https://github.com/swig/swig/issues/
# Version 4.0.0 (in progress)
# ===========================
#
#+2017-06-13: olly
#+ [Perl] Fix testsuite to work without . in @INC - it was removed in
#+ Perl 5.26 for security reasons, and has also been removed from
#+ older versions in some distros. Fixes
#+ https://github.com/swig/swig/issues/997 reported by lfam.
#+
# 2017-06-03: wsfulton
# Fix %import on a file containing a file scope %fragment forced inclusion to not
# generate the fragment contents as %import should not result in code being generated.
diff --git a/Examples/Makefile.in b/Examples/Makefile.in
index 7682b56..8a88fb5 100644
--- a/Examples/Makefile.in
+++ b/Examples/Makefile.in
@@ -282,7 +282,7 @@ perl5_static_cpp: $(SRCDIR_SRCS)
# -----------------------------------------------------------------
perl5_run:
- $(RUNTOOL) $(PERL) $(PERL5_SCRIPT) $(RUNPIPE)
+ $(RUNTOOL) $(PERL) -I. $(PERL5_SCRIPT) $(RUNPIPE)
# -----------------------------------------------------------------
# Version display
diff --git a/Examples/test-suite/perl5/run-perl-test.pl b/Examples/test-suite/perl5/run-perl-test.pl
index 106bf00..5ea4e511 100644
--- a/Examples/test-suite/perl5/run-perl-test.pl
+++ b/Examples/test-suite/perl5/run-perl-test.pl
@@ -7,7 +7,7 @@ use strict;
my $command = shift @ARGV;
-my $output = `$^X $command 2>&1`;
+my $output = `$^X -I. $command 2>&1`;
die "SWIG Perl test failed: \n\n$output\n"
if $?;
--
2.9.4