Fixed tests to building on Perl 5.26 without dot in INC

This commit is contained in:
Jitka Plesnikova 2017-06-14 16:31:06 +02:00
parent de4494ca6c
commit c8c0cd2376
2 changed files with 67 additions and 1 deletions

View File

@ -0,0 +1,61 @@
From 8855ef2b482c09da9255079b0fac92d08c8308fb Mon Sep 17 00:00:00 2001
From: Olly Betts <olly@survex.com>
Date: Tue, 13 Jun 2017 17:32:37 +1200
Subject: [PATCH] [Perl] Fix testsuite to work without . in @INC
"." was removed from @INC in Perl 5.26 for security reasons, and has
also been removed from older versions in some distros.
Fixes https://github.com/swig/swig/issues/997 reported by lfam.
---
CHANGES.current | 6 ++++++
Examples/Makefile.in | 2 +-
Examples/test-suite/perl5/run-perl-test.pl | 2 +-
3 files changed, 8 insertions(+), 2 deletions(-)
#diff --git a/CHANGES.current b/CHANGES.current
#index ac620c9..6b379a9 100644
#--- a/CHANGES.current
#+++ b/CHANGES.current
#@@ -7,6 +7,12 @@ the issue number to the end of the URL: https://github.com/swig/swig/issues/
# Version 4.0.0 (in progress)
# ===========================
#
#+2017-06-13: olly
#+ [Perl] Fix testsuite to work without . in @INC - it was removed in
#+ Perl 5.26 for security reasons, and has also been removed from
#+ older versions in some distros. Fixes
#+ https://github.com/swig/swig/issues/997 reported by lfam.
#+
# 2017-06-03: wsfulton
# Fix %import on a file containing a file scope %fragment forced inclusion to not
# generate the fragment contents as %import should not result in code being generated.
diff --git a/Examples/Makefile.in b/Examples/Makefile.in
index 7682b56..8a88fb5 100644
--- a/Examples/Makefile.in
+++ b/Examples/Makefile.in
@@ -282,7 +282,7 @@ perl5_static_cpp: $(SRCDIR_SRCS)
# -----------------------------------------------------------------
perl5_run:
- $(RUNTOOL) $(PERL) $(PERL5_SCRIPT) $(RUNPIPE)
+ $(RUNTOOL) $(PERL) -I. $(PERL5_SCRIPT) $(RUNPIPE)
# -----------------------------------------------------------------
# Version display
diff --git a/Examples/test-suite/perl5/run-perl-test.pl b/Examples/test-suite/perl5/run-perl-test.pl
index 106bf00..5ea4e511 100644
--- a/Examples/test-suite/perl5/run-perl-test.pl
+++ b/Examples/test-suite/perl5/run-perl-test.pl
@@ -7,7 +7,7 @@ use strict;
my $command = shift @ARGV;
-my $output = `$^X $command 2>&1`;
+my $output = `$^X -I. $command 2>&1`;
die "SWIG Perl test failed: \n\n$output\n"
if $?;
--
2.9.4

View File

@ -31,7 +31,7 @@
Summary: Connects C/C++/Objective C to some high-level programming languages
Name: swig
Version: 3.0.12
Release: 7%{?dist}
Release: 8%{?dist}
License: GPLv3+ and BSD
URL: http://swig.sourceforge.net/
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
@ -42,6 +42,7 @@ Source3: ccache-swig.sh
Source4: ccache-swig.csh
Patch0: swig308-Do-not-use-isystem.patch
Patch1: swig-3.0.12-Fix-testsuite-to-work-without-.-in-INC.patch
BuildRequires: perl, pcre-devel
BuildRequires: python2-devel, python3-devel
@ -133,6 +134,7 @@ in gdb.
%setup -q
%patch0 -p1 -b .isystem
%patch1 -p1
for all in CHANGES README; do
iconv -f ISO88591 -t UTF8 < $all > $all.new
@ -279,6 +281,9 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
%{_datadir}/%{name}/gdb
%changelog
* Wed Jun 14 2017 Jitka Plesnikova <jplesnik@redhat.com> - 3.0.12-8
- Fixed tests to building on Perl 5.26 without dot in INC
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.12-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild