- update
- new pylib patch - remove destdir patch, swig.m4 is no longer included - remove ldconfig patch, swig now uses *-config to find out linker options
This commit is contained in:
parent
09816206b7
commit
c7bfc58882
@ -1 +1 @@
|
||||
swig-1.3.21.tar.gz
|
||||
swig-1.3.23.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
88ff5b99be3eafebb8a6e20f4f986c04 swig-1.3.21.tar.gz
|
||||
3f12460b7d0cbb96ea7bf66f86fcea5b swig-1.3.23.tar.gz
|
||||
|
29
swig-1.3.23-pylib.patch
Normal file
29
swig-1.3.23-pylib.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- SWIG-1.3.23/configure.in.pylib 2004-11-02 00:45:57.000000000 +0100
|
||||
+++ SWIG-1.3.23/configure.in 2004-11-23 12:20:12.552926982 +0100
|
||||
@@ -574,9 +574,11 @@
|
||||
|
||||
# Set the include directory
|
||||
|
||||
+ PYLIB=`$PYTHON -c "import sys; print sys.path[[1]]"`
|
||||
+
|
||||
AC_MSG_CHECKING(for Python header files)
|
||||
if test -r $PYPREFIX/include/$PYVERSION/Python.h; then
|
||||
- PYINCLUDE="-I$PYPREFIX/include/$PYVERSION -I$PYEPREFIX/$PYLIBDIR/$PYVERSION/config"
|
||||
+ PYINCLUDE="-I$PYPREFIX/include/$PYVERSION -I$PYLIB/config"
|
||||
fi
|
||||
if test -z "$PYINCLUDE"; then
|
||||
if test -r $PYPREFIX/include/Py/Python.h; then
|
||||
@@ -587,13 +589,6 @@
|
||||
|
||||
# Set the library directory blindly. This probably won't work with older versions
|
||||
AC_MSG_CHECKING(for Python library)
|
||||
- dirs="$PYVERSION/config $PYVERSION/$PYLIBDIR python/$PYLIBDIR"
|
||||
- for i in $dirs; do
|
||||
- if test -d $PYEPREFIX/$PYLIBDIR/$i; then
|
||||
- PYLIB="$PYEPREFIX/$PYLIBDIR/$i"
|
||||
- break
|
||||
- fi
|
||||
- done
|
||||
if test -z "$PYLIB"; then
|
||||
AC_MSG_RESULT(Not found)
|
||||
else
|
19
swig.spec
19
swig.spec
@ -3,15 +3,13 @@
|
||||
|
||||
Summary: Connects C/C++/Objective C to some high-level programming languages.
|
||||
Name: swig
|
||||
Version: 1.3.21
|
||||
Release: 7
|
||||
Version: 1.3.23
|
||||
Release: 1
|
||||
License: BSD
|
||||
Group: Development/Tools
|
||||
URL: http://swig.sourceforge.net/
|
||||
Source: http://download.sourceforge.net/swig/swig-%{version}.tar.gz
|
||||
Patch1: swig-1.3.19-pylib.patch
|
||||
Patch2: swig-1.3.21-destdir.patch
|
||||
Patch3: swig-1.3.21-ldflags.patch
|
||||
Patch1: swig-1.3.23-pylib.patch
|
||||
BuildRoot: %{_tmppath}/swig-root
|
||||
BuildPrereq: perl, python-devel
|
||||
%if %{tcl}
|
||||
@ -33,14 +31,12 @@ tool for building user interfaces.
|
||||
%prep
|
||||
%setup -q -n SWIG-%{version}
|
||||
%patch1 -p1 -b .pylib
|
||||
%patch2 -p1 -b .destdir
|
||||
%patch3 -p1 -b .ldflags
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure
|
||||
make
|
||||
make runtime
|
||||
#make check
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -60,9 +56,14 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_bindir}/*
|
||||
%{_libdir}/lib*.*
|
||||
%{_libdir}/swig1.3
|
||||
%{_datadir}/aclocal/swig.m4
|
||||
|
||||
%changelog
|
||||
* Tue Nov 23 2004 Karsten Hopp <karsten@redhat.de> 1.3.23-1
|
||||
- update
|
||||
- new pylib patch
|
||||
- remove destdir patch, swig.m4 is no longer included
|
||||
- remove ldconfig patch, swig now uses *-config to find out linker options
|
||||
|
||||
* Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 1.3.21-7
|
||||
- rebuild against python 2.4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user