Backport upstream fix for Go tests (BZ#1736731)
This commit is contained in:
parent
9f07bb8030
commit
84ea8a4c67
20
swig.spec
20
swig.spec
@ -2,6 +2,7 @@
|
||||
%bcond_without testsuite
|
||||
|
||||
%if %{without testsuite}
|
||||
%global tcl 0
|
||||
%global lualang 0
|
||||
%global phplang 0
|
||||
%global rubylang 0
|
||||
@ -49,14 +50,10 @@
|
||||
%{!?golang:%global golang 0}
|
||||
%endif
|
||||
|
||||
# Tests fail with GO 1.13-beta1
|
||||
# https://github.com/swig/swig/issues/1607
|
||||
%global golang 0
|
||||
|
||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||
Name: swig
|
||||
Version: 4.0.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: GPLv3+ and BSD
|
||||
URL: http://swig.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||
@ -71,6 +68,10 @@ Source4: ccache-swig.csh
|
||||
Patch0: swig308-Do-not-use-isystem.patch
|
||||
# https://github.com/swig/swig/pull/1522
|
||||
Patch1: swig-octave-ldflags.patch
|
||||
# Fix Go tests for Go 1.13-beta1 (BZ#1736731)
|
||||
Patch2: swig400-Fix-all-Go-tests-to-build-with-go-build.patch
|
||||
Patch3: swig400-Restore-setting-of-GOVERSIONOPTION.patch
|
||||
Patch4: swig400-Fix-Go-version-check-and-Go-in-tree-example-tests.patch
|
||||
|
||||
BuildRequires: perl-interpreter, pcre-devel
|
||||
%if %{python2lang}
|
||||
@ -173,6 +174,9 @@ in gdb.
|
||||
|
||||
%patch0 -p1 -b .isystem
|
||||
%patch1 -p1 -b .octave-ldflags
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
for all in CHANGES README; do
|
||||
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
||||
@ -203,6 +207,9 @@ done
|
||||
%else
|
||||
--without-php \
|
||||
%endif
|
||||
%if ! %{tcl}
|
||||
--without-tcl \
|
||||
%endif
|
||||
%if ! %{javalang}
|
||||
--without-java \
|
||||
%endif
|
||||
@ -342,6 +349,9 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
||||
%{_datadir}/%{name}/gdb
|
||||
|
||||
%changelog
|
||||
* Mon Aug 12 2019 Jitka Plesnikova <jplesnik@redhat.com> - 4.0.0-5
|
||||
- Backport upstream fix for Go tests (BZ#1736731)
|
||||
|
||||
* Tue Aug 06 2019 Jitka Plesnikova <jplesnik@redhat.com> - 4.0.0-4
|
||||
- Disable Go tests, they fail with Go 1.13-beta
|
||||
|
||||
|
@ -0,0 +1,54 @@
|
||||
From 62136ff782e9bf6641970f716d7d40afcf6c49ea Mon Sep 17 00:00:00 2001
|
||||
From: Ian Lance Taylor <iant@golang.org>
|
||||
Date: Fri, 9 Aug 2019 14:06:45 -0700
|
||||
Subject: [PATCH] Fix Go version check and Go in-tree example tests
|
||||
|
||||
Fixes #1607
|
||||
---
|
||||
Examples/Makefile.in | 4 ++--
|
||||
configure.ac | 5 +++--
|
||||
2 files changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Examples/Makefile.in b/Examples/Makefile.in
|
||||
index 9e05d2763..6fbca29db 100644
|
||||
--- a/Examples/Makefile.in
|
||||
+++ b/Examples/Makefile.in
|
||||
@@ -1484,7 +1484,7 @@ go: $(SRCDIR_SRCS) $(GOPATHPARENTDIR)/go.mod
|
||||
rm -f gopath/$(GOMOD)/src/runme/*; \
|
||||
fi
|
||||
if test -f $(SRCDIR)$(RUNME).go; then \
|
||||
- cp $(SRCDIR)/$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
||||
+ cp $(SRCDIR)$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
||||
fi
|
||||
GOPATH=`pwd`/gopath/$(GOMOD); \
|
||||
export GOPATH; \
|
||||
@@ -1533,7 +1533,7 @@ go_cpp: $(SRCDIR_SRCS) $(GOPATHPARENTDIR)/go.mod
|
||||
rm -f gopath/$(GOMOD)/src/runme/*; \
|
||||
fi
|
||||
if test -f $(SRCDIR)$(RUNME).go; then \
|
||||
- cp $(SRCDIR)/$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
||||
+ cp $(SRCDIR)$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
||||
fi
|
||||
GOPATH=`pwd`/gopath/$(GOMOD); \
|
||||
export GOPATH; \
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 73c38a72c..63509cd66 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2391,10 +2391,11 @@ else
|
||||
|
||||
if test -n "$GO" ; then
|
||||
GOVERSIONOPTION=version
|
||||
+ go_version=$($GO $GOVERSIONOPTION | sed -e 's/go version //')
|
||||
AC_MSG_CHECKING([whether go version is too old])
|
||||
case $go_version in
|
||||
- go1.[012345]*)
|
||||
- AC_MSG_RESULT([yes - minimum version is 1.6])
|
||||
+ go1.[012]*)
|
||||
+ AC_MSG_RESULT([yes - minimum version is 1.3])
|
||||
GO=
|
||||
GOOPT="-intgosize 32"
|
||||
;;
|
||||
--
|
||||
2.20.1
|
||||
|
2648
swig400-Fix-all-Go-tests-to-build-with-go-build.patch
Normal file
2648
swig400-Fix-all-Go-tests-to-build-with-go-build.patch
Normal file
File diff suppressed because it is too large
Load Diff
25
swig400-Restore-setting-of-GOVERSIONOPTION.patch
Normal file
25
swig400-Restore-setting-of-GOVERSIONOPTION.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 6b108c19e1504c937e1a7d50147575dd8e624b73 Mon Sep 17 00:00:00 2001
|
||||
From: Ian Lance Taylor <iant@golang.org>
|
||||
Date: Thu, 8 Aug 2019 22:59:57 -0700
|
||||
Subject: [PATCH 2/2] Restore setting of GOVERSIONOPTION
|
||||
|
||||
Accidentally removed in last commit.
|
||||
---
|
||||
configure.ac | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a38e97d2a..73c38a72c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2390,6 +2390,7 @@ else
|
||||
GOVERSIONOPTION=
|
||||
|
||||
if test -n "$GO" ; then
|
||||
+ GOVERSIONOPTION=version
|
||||
AC_MSG_CHECKING([whether go version is too old])
|
||||
case $go_version in
|
||||
go1.[012345]*)
|
||||
--
|
||||
2.20.1
|
||||
|
Loading…
Reference in New Issue
Block a user