- update to 1.3.39
- swig-1.3.38-rh485540.patch was merged - add Example/ to -doc again (#489077), filter provides correctly
This commit is contained in:
parent
210e5b5627
commit
6d0f03689d
@ -1 +1 @@
|
|||||||
swig-1.3.38.tar.gz
|
swig-1.3.39.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
650c774917be49c526a4f8a3e733c898 swig-1.3.38.tar.gz
|
ac201d1b87f8659584534f9540d7ad24 swig-1.3.39.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up swig-1.3.38/Source/Modules/main.cxx.rh485540 swig-1.3.38/Source/Modules/main.cxx
|
|
||||||
--- swig-1.3.38/Source/Modules/main.cxx.rh485540 2009-02-16 16:27:07.000000000 +0100
|
|
||||||
+++ swig-1.3.38/Source/Modules/main.cxx 2009-02-16 16:29:05.000000000 +0100
|
|
||||||
@@ -954,7 +954,7 @@ int SWIG_main(int argc, char *argv[], La
|
|
||||||
if (!s) {
|
|
||||||
Printf(stderr, "Unable to locate '%s' in the SWIG library.\n", input_file);
|
|
||||||
} else {
|
|
||||||
- FILE *f = Swig_include_open(outfile);
|
|
||||||
+ FILE *f = Swig_open(outfile);
|
|
||||||
if (f) {
|
|
||||||
fclose(f);
|
|
||||||
Printf(stderr, "File '%s' already exists. Checkout aborted.\n", outfile);
|
|
33
swig.spec
33
swig.spec
@ -3,14 +3,13 @@
|
|||||||
|
|
||||||
Summary: Connects C/C++/Objective C to some high-level programming languages.
|
Summary: Connects C/C++/Objective C to some high-level programming languages.
|
||||||
Name: swig
|
Name: swig
|
||||||
Version: 1.3.38
|
Version: 1.3.39
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://swig.sourceforge.net/
|
URL: http://swig.sourceforge.net/
|
||||||
Source: http://download.sourceforge.net/swig/swig-%{version}.tar.gz
|
Source: http://download.sourceforge.net/swig/swig-%{version}.tar.gz
|
||||||
Patch1: swig-1.3.23-pylib.patch
|
Patch1: swig-1.3.23-pylib.patch
|
||||||
Patch2: swig-1.3.38-rh485540.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: perl, python-devel
|
BuildRequires: perl, python-devel
|
||||||
@ -43,7 +42,26 @@ This package contains documentation for SWIG and useful examples.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n swig-%{version}
|
%setup -q -n swig-%{version}
|
||||||
%patch1 -p1 -b .pylib
|
%patch1 -p1 -b .pylib
|
||||||
%patch2 -p1 -b .rh485540
|
|
||||||
|
|
||||||
|
# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
|
||||||
|
# (specific req/prov filtering). Before you remove this hack make sure you don't
|
||||||
|
# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
|
||||||
|
cat << \EOF > %{name}-prov
|
||||||
|
#!/bin/sh
|
||||||
|
%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
|
||||||
|
EOF
|
||||||
|
|
||||||
|
%define __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
|
||||||
|
chmod +x %{__perl_provides}
|
||||||
|
|
||||||
|
cat << \EOF > %{name}-req
|
||||||
|
#!/bin/sh
|
||||||
|
%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
|
||||||
|
EOF
|
||||||
|
|
||||||
|
%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
|
||||||
|
chmod +x %{__perl_requires}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -78,9 +96,14 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files doc
|
%files doc
|
||||||
%doc ANNOUNCE CHANGES FUTURE INSTALL LICENSE NEW README TODO
|
%doc ANNOUNCE CHANGES FUTURE INSTALL LICENSE NEW README TODO
|
||||||
%doc Doc
|
%doc Doc Examples
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 30 2009 Adam Tkac <atkac redhat com> 1.3.39-1
|
||||||
|
- update to 1.3.39
|
||||||
|
- swig-1.3.38-rh485540.patch was merged
|
||||||
|
- add Example/ to -doc again (#489077), filter provides correctly
|
||||||
|
|
||||||
* Tue Mar 10 2009 Adam Tkac <atkac redhat com> 1.3.38-5
|
* Tue Mar 10 2009 Adam Tkac <atkac redhat com> 1.3.38-5
|
||||||
- revert #489077 enhancement due #489421
|
- revert #489077 enhancement due #489421
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user