Remove the old setools patch; Resolves: bz#1180257
This commit is contained in:
parent
a5592fa14a
commit
24d4028e6f
20
swig.spec
20
swig.spec
@ -33,18 +33,17 @@
|
||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||
Name: swig
|
||||
Version: 3.0.7
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: GPLv3+ and BSD
|
||||
URL: http://swig.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||
# Define the part of man page sections
|
||||
Source1: description.h2m
|
||||
Patch1: swig207-setools.patch
|
||||
|
||||
# Ruby patches will be part of SWIG 3.0.8
|
||||
Patch2: swig307-Fix-Ruby-trackings-code-to-use-C-hash.patch
|
||||
Patch3: swig307-Ruby-trackings-patch-tidy-up.patch
|
||||
Patch4: swig307-Ruby-trackings-support-for-1.8.patch
|
||||
Patch1: swig307-Fix-Ruby-trackings-code-to-use-C-hash.patch
|
||||
Patch2: swig307-Ruby-trackings-patch-tidy-up.patch
|
||||
Patch3: swig307-Ruby-trackings-support-for-1.8.patch
|
||||
|
||||
BuildRequires: perl, python2-devel, pcre-devel
|
||||
BuildRequires: autoconf, automake, gawk, dos2unix
|
||||
@ -108,10 +107,9 @@ This package contains documentation for SWIG and useful examples
|
||||
%prep
|
||||
%setup -q -n swig-%{version}
|
||||
|
||||
%patch1 -p1 -b .setools
|
||||
%patch2 -p1 -b .rubyhash
|
||||
%patch3 -p1 -b .rubytidyup
|
||||
%patch4 -p1 -b .ruby18
|
||||
%patch1 -p1 -b .rubyhash
|
||||
%patch2 -p1 -b .rubytidyup
|
||||
%patch3 -p1 -b .ruby18
|
||||
|
||||
for all in CHANGES README; do
|
||||
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
||||
@ -211,6 +209,10 @@ ln -fs ../../bin/ccache-swig %{buildroot}%{_libdir}/ccache/swig
|
||||
%doc Doc Examples COPYRIGHT
|
||||
|
||||
%changelog
|
||||
* Wed Sep 16 2015 Jitka Plesnikova <jplesnik@redhat.com> - 3.0.7-6
|
||||
- Remove the old setools patch. The bug was already fixed by upstream
|
||||
- Resolves: bz#1180257
|
||||
|
||||
* Mon Sep 14 2015 Jitka Plesnikova <jplesnik@redhat.com> - 3.0.7-5
|
||||
- Fix Ruby tracking code (BZ#1225140)
|
||||
|
||||
|
@ -1,18 +0,0 @@
|
||||
diff -up swig-2.0.7/Source/Swig/naming.c.setools swig-2.0.7/Source/Swig/naming.c
|
||||
--- swig-2.0.7/Source/Swig/naming.c.setools 2011-12-11 17:29:51.000000000 +0100
|
||||
+++ swig-2.0.7/Source/Swig/naming.c 2012-06-27 16:21:21.248375130 +0200
|
||||
@@ -215,11 +215,11 @@ String *Swig_name_member(const_String_or
|
||||
Append(r, f);
|
||||
}
|
||||
cname = Char(rclassname);
|
||||
- if ((strncmp(cname, "struct ", 7) == 0) || ((strncmp(cname, "class ", 6) == 0)) || ((strncmp(cname, "union ", 6) == 0))) {
|
||||
- cname = strchr(cname, ' ') + 1;
|
||||
- }
|
||||
replace_nspace(r, nspace);
|
||||
Replace(r, "%c", cname, DOH_REPLACE_ANY);
|
||||
+ if ((strncmp(cname, "struct ", 7) == 0) || ((strncmp(cname, "class ", 6) == 0)) || ((strncmp(cname, "union ", 6) == 0))) {
|
||||
+ Replace(r, " ", "_", DOH_REPLACE_FIRST);
|
||||
+ }
|
||||
Replace(r, "%m", membername, DOH_REPLACE_ANY);
|
||||
/* name_mangle(r); */
|
||||
Delete(rclassname);
|
Loading…
Reference in New Issue
Block a user