Add cblas patch

This commit is contained in:
Dave Love 2017-06-08 20:58:00 +00:00
parent 5e5f978aa4
commit dcac6e6241
1 changed files with 30 additions and 0 deletions

30
superlu_dist-cblas.patch Normal file
View File

@ -0,0 +1,30 @@
--- SuperLU_DIST_5.1.3/CBLAS/Makefile~ 2017-02-14 04:51:02.000000000 +0000
+++ SuperLU_DIST_5.1.3/CBLAS/Makefile 2017-06-07 22:24:24.229000000 +0000
@@ -66,22 +66,22 @@
all: single double complex complex16
-single: $(SBLAS1) $(SBLAS2) $(SBLAS3)
+single: $(SBLAS1) $(SBLAS2) $(SBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(SBLAS1) $(ALLBLAS) \
$(SBLAS2) $(SBLAS3)
$(RANLIB) $(BLASLIB)
-double: $(DBLAS1) $(DBLAS2) $(DBLAS3)
+double: $(DBLAS1) $(DBLAS2) $(DBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(DBLAS1) $(ALLBLAS) \
$(DBLAS2) $(DBLAS3)
$(RANLIB) $(BLASLIB)
-complex: $(CBLAS1) $(CBLAS2) $(CBLAS3)
+complex: $(CBLAS1) $(CBLAS2) $(CBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(CBLAS1) $(ALLBLAS) \
$(CBLAS2) $(CBLAS3)
$(RANLIB) $(BLASLIB)
-complex16: $(ZBLAS1) $(ZBLAS2) $(ZBLAS3)
+complex16: $(ZBLAS1) $(ZBLAS2) $(ZBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(ZBLAS1) $(ALLBLAS) \
$(ZBLAS2) $(ZBLAS3)
$(RANLIB) $(BLASLIB)