New version

Drop output and cmake patches
Update soname minor version (added function)
This commit is contained in:
Dave Love 2017-10-31 11:52:10 +00:00
parent b20f7cdabf
commit 8c23a5a28c
5 changed files with 12 additions and 65 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/superlu_dist_5.1.3.tar.gz
/superlu_dist_5.2.2.tar.gz

View File

@ -1 +1 @@
SHA512 (superlu_dist_5.1.3.tar.gz) = 064942171543006047d5379bc47d27d14467a116e8d2fd8dac82283e237757e2afd31a4ad51c2925323c1b59e70e15da38c6b35db3c1d14b520fc02b906704b6
SHA512 (superlu_dist_5.2.2.tar.gz) = 8a384112cf94ad99b03d9907f146a4c1e24640f6b9fa1cf86bb6fd3955344c38c6ab32356831ebe6802476c05509d86a77019f380a80beb0773fc952d5fe73f9

View File

@ -1,30 +0,0 @@
--- SuperLU_DIST_5.1.3/CBLAS/Makefile~ 2017-02-14 04:51:02.000000000 +0000
+++ SuperLU_DIST_5.1.3/CBLAS/Makefile 2017-06-07 22:24:24.229000000 +0000
@@ -66,22 +66,22 @@
all: single double complex complex16
-single: $(SBLAS1) $(SBLAS2) $(SBLAS3)
+single: $(SBLAS1) $(SBLAS2) $(SBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(SBLAS1) $(ALLBLAS) \
$(SBLAS2) $(SBLAS3)
$(RANLIB) $(BLASLIB)
-double: $(DBLAS1) $(DBLAS2) $(DBLAS3)
+double: $(DBLAS1) $(DBLAS2) $(DBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(DBLAS1) $(ALLBLAS) \
$(DBLAS2) $(DBLAS3)
$(RANLIB) $(BLASLIB)
-complex: $(CBLAS1) $(CBLAS2) $(CBLAS3)
+complex: $(CBLAS1) $(CBLAS2) $(CBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(CBLAS1) $(ALLBLAS) \
$(CBLAS2) $(CBLAS3)
$(RANLIB) $(BLASLIB)
-complex16: $(ZBLAS1) $(ZBLAS2) $(ZBLAS3)
+complex16: $(ZBLAS1) $(ZBLAS2) $(ZBLAS3) $(ALLBLAS)
$(ARCH) $(ARCHFLAGS) $(BLASLIB) $(ZBLAS1) $(ALLBLAS) \
$(ZBLAS2) $(ZBLAS3)
$(RANLIB) $(BLASLIB)

View File

@ -1,22 +0,0 @@
--- SuperLU_DIST_5.1.2/SRC/dmemory_dist.c~ 2016-10-21 19:50:33.000000000 +0100
+++ SuperLU_DIST_5.1.2/SRC/dmemory_dist.c 2016-11-17 11:56:08.419300143 +0000
@@ -129,7 +129,7 @@
mem_usage->total += (float)(2 * k * iword);
#else
/*mem_usage->total += stat->current_buffer;*/
- printf(".. dQuery_Space: peak_buffer %.2f (MB)\n", stat->peak_buffer * 1.0e-6);
+ /* printf(".. dQuery_Space: peak_buffer %.2f (MB)\n", stat->peak_buffer * 1.0e-6); */
mem_usage->total += stat->peak_buffer;
#endif
--- SuperLU_DIST_5.1.2/SRC/zmemory_dist.c~ 2016-10-21 19:50:33.000000000 +0100
+++ SuperLU_DIST_5.1.2/SRC/zmemory_dist.c 2016-11-17 11:57:18.260046576 +0000
@@ -128,7 +128,7 @@
mem_usage->total += (float)(2 * k * iword);
#else
/*mem_usage->total += stat->current_buffer;*/
- printf(".. zQuery_Space: peak_buffer %.2f (MB)\n", stat->peak_buffer * 1.0e-6);
+ /* printf(".. zQuery_Space: peak_buffer %.2f (MB)\n", stat->peak_buffer * 1.0e-6); */
mem_usage->total += stat->peak_buffer;
#endif

View File

@ -10,8 +10,8 @@
%endif
Name: superlu_dist
Version: 5.1.3
Release: 8%{?dist}
Version: 5.2.2
Release: 1%{?dist}
Summary: Solution of large, sparse, nonsymmetric systems of linear equations
License: BSD
URL: http://crd-legacy.lbl.gov/~xiaoye/SuperLU/
@ -19,14 +19,10 @@ Source0: http://crd-legacy.lbl.gov/~xiaoye/SuperLU/superlu_dist_%version.t
Source1: superlu_dist-make.inc
# Make the parmetis support work with Scotch
Patch1: superlu_dist-parmetis.patch
# Zap diagnostics, recommended in
# <https://math.berkeley.edu/~linlin/pexsi/page_dependency.html>
Patch2: superlu_dist-output.patch
Patch3: superlu_dist-cblas.patch
BuildRequires: scotch-devel gcc-gfortran
%if %{with openblas}
BuildRequires: openblas-devel
# Probably not worth a bundled provides for the bundled partial cblas.
# [else] Probably not worth a bundled provides for the bundled partial cblas.
%endif
# The test program runs if we link with -lmetis but crashes if linked with
# -lscotchmetis.
@ -66,7 +62,7 @@ BuildRequires: metis-devel
# For library soname. Start at one in case we need the incompatible
# v4 packaged separately.
%global major 1
%global minor 0
%global minor 1
%global miner 0
%global sover %major.%minor.%miner
@ -149,8 +145,6 @@ Development files for %name-mpich
%prep
%setup -q -n SuperLU_DIST_%version
%patch1 -p1
%patch2 -p1
%patch3 -p1
cp %SOURCE1 make.inc
%build
@ -173,8 +167,7 @@ mkdir -p tmp $m
pushd tmp
ar x ../SRC/libsuperlu_dist.a
mpicc -shared -Wl,-soname=libsuperlu_dist.so.%major -Wl,--as-needed \
-o ../$m/libsuperlu_dist.so.%sover *.o -fopenmp -lptscotchparmetis \
-lptscotch -lptscotcherr -lscotch -lmetis \
-o ../$m/libsuperlu_dist.so.%sover *.o -fopenmp \
%if %{with openblas}
-lopenblas \
%endif
@ -253,6 +246,11 @@ make clean
%changelog
* Tue Oct 31 2017 Dave Love <loveshack@fedoraproject.org> - 5.2.2-1
- New version
- Drop output and cmake patches
- Update soname minor version (added function)
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.3-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild