Rebuild for PETSc; use devtoolset-8 on epel.

This commit is contained in:
sagitter 2019-06-29 15:21:47 +02:00
commit 0f73e57cc6
7 changed files with 718 additions and 586 deletions

7
.gitignore vendored
View File

@ -7,3 +7,10 @@ sundials-2.3.0.tar.gz
/sundials-2.7.0-pkgconfig_files.tar.gz
/sundials-2.7.0.tar.gz
/sundials-2.7.0_pkgconfig_files.tar.gz
/sundials-3.0.0.tar.gz
/sundials-3.1.0.tar.gz
/sundials-3.1.1.tar.gz
/sundials-3.1.2.tar.gz
/sundials-3.2.0.tar.gz
/sundials-3.2.1.tar.gz
/sundials-4.1.0.tar.gz

View File

@ -1 +1 @@
SHA512 (sundials-2.7.0.tar.gz) = c86c167538065a4109b36ae7c8f60f3d92184133cfa661b5acfccee052c38f40be865412a1746bb57907b61602c212c0f15e1e30ef29e8a49db6d46a75a28e69
SHA512 (sundials-4.1.0.tar.gz) = 1922dca3f0b8869098670aede802e48abec39607c96304e4efd9b03d195b16920175846fce10641aeebc48c216bda73c8691139dce57ffa7731a6bc8194b81b0

View File

@ -1,11 +0,0 @@
--- config/FindSUPERLUMT.orig.cmake 2016-09-27 00:16:47.000000000 +0200
+++ config/FindSUPERLUMT.cmake 2016-10-04 12:08:58.202988791 +0200
@@ -42,7 +42,7 @@
else()
# find library with user provided directory path
- set(SUPERLUMT_LIBRARY_NAME superlu_mt_${POST})
+ set(SUPERLUMT_LIBRARY_NAME superlumt_d)
find_library(SUPERLUMT_LIBRARY ${SUPERLUMT_LIBRARY_NAME} ${SUPERLUMT_LIBRARY_DIR} NO_DEFAULT_PATH)
endif()
mark_as_advanced(SUPERLUMT_LIBRARY)

View File

@ -0,0 +1,11 @@
--- config/FindSUPERLUMT.orig.cmake 2016-09-27 00:16:47.000000000 +0200
+++ config/FindSUPERLUMT.cmake 2016-10-04 12:08:58.202988791 +0200
@@ -44,7 +44,7 @@
set(SUPERLUMT_LIBRARY_DIR ${SUPERLUMT_LIBRARY_DIR} CACHE PATH "" FORCE)
else()
# find library with user provided directory path
- set(SUPERLUMT_LIBRARY_NAME superlu_mt_${POST})
+ set(SUPERLUMT_LIBRARY_NAME superlumt64_d)
find_library(SUPERLUMT_LIBRARY ${SUPERLUMT_LIBRARY_NAME} ${SUPERLUMT_LIBRARY_DIR} NO_DEFAULT_PATH)
endif()
mark_as_advanced(SUPERLUMT_LIBRARY)

View File

@ -0,0 +1,11 @@
--- config/FindSUPERLUMT.orig.cmake 2016-09-27 00:16:47.000000000 +0200
+++ config/FindSUPERLUMT.cmake 2016-10-04 12:08:58.202988791 +0200
@@ -44,7 +44,7 @@
set(SUPERLUMT_LIBRARY_DIR ${SUPERLUMT_LIBRARY_DIR} CACHE PATH "" FORCE)
else()
# find library with user provided directory path
- set(SUPERLUMT_LIBRARY_NAME superlu_mt_${POST})
+ set(SUPERLUMT_LIBRARY_NAME superlumt_d)
find_library(SUPERLUMT_LIBRARY ${SUPERLUMT_LIBRARY_NAME} ${SUPERLUMT_LIBRARY_DIR} NO_DEFAULT_PATH)
endif()
mark_as_advanced(SUPERLUMT_LIBRARY)

View File

@ -0,0 +1,75 @@
--- a/config/SundialsPETSc.cmake
+++ b/config/SundialsPETSc.cmake
@@ -25,49 +25,4 @@
# set PETSC_LIBRARIES
include(FindPETSc)
-# If we have the PETSC libraries, test them
-if(PETSC_LIBRARIES)
- message(STATUS "Looking for PETSc libraries...")
- # Create the PETSCTest directory
- set(PETSCTest_DIR ${PROJECT_BINARY_DIR}/PETSCTest)
- file(MAKE_DIRECTORY ${PETSCTest_DIR})
- # Create a CMakeLists.txt file
- file(WRITE ${PETSCTest_DIR}/CMakeLists.txt
- "CMAKE_MINIMUM_REQUIRED(VERSION 3.0.2)\n"
- "PROJECT(ltest C)\n"
- "SET(CMAKE_VERBOSE_MAKEFILE ON)\n"
- "SET(CMAKE_BUILD_TYPE \"${CMAKE_BUILD_TYPE}\")\n"
- "SET(CMAKE_C_COMPILER ${MPI_C_COMPILER})\n"
- "SET(CMAKE_C_FLAGS \"${CMAKE_C_FLAGS}\")\n"
- "SET(CMAKE_C_FLAGS_RELEASE \"${CMAKE_C_FLAGS_RELEASE}\")\n"
- "SET(CMAKE_C_FLAGS_DEBUG \"${CMAKE_C_FLAGS_DEBUG}\")\n"
- "SET(CMAKE_C_FLAGS_RELWITHDEBUGINFO \"${CMAKE_C_FLAGS_RELWITHDEBUGINFO}\")\n"
- "SET(CMAKE_C_FLAGS_MINSIZE \"${CMAKE_C_FLAGS_MINSIZE}\")\n"
- "INCLUDE_DIRECTORIES(${PETSC_INCLUDE_DIR})\n"
- "ADD_EXECUTABLE(ltest ltest.c)\n"
- "TARGET_LINK_LIBRARIES(ltest ${PETSC_LIBRARIES})\n")
- # Create a C source file which calls a PETSC function
- file(WRITE ${PETSCTest_DIR}/ltest.c
- "\#include \"petscvec.h\"\n"
- "int main(){\n"
- "Vec x;\n"
- "VecCreate(PETSC_COMM_WORLD, &x);\n"
- "return(0);\n"
- "}\n")
- # Attempt to link the "ltest" executable
- try_compile(LTEST_OK ${PETSCTest_DIR} ${PETSCTest_DIR} ltest OUTPUT_VARIABLE MY_OUTPUT)
-
- # To ensure we do not use stuff from the previous attempts,
- # we must remove the CMakeFiles directory.
- file(REMOVE_RECURSE ${PETSCTest_DIR}/CMakeFiles)
- # Process test result
- if(LTEST_OK)
- message(STATUS "Checking if PETSc works... OK")
- set(PETSC_FOUND TRUE)
- else(LTEST_OK)
- message(STATUS "Checking if PETSc works... FAILED")
- endif(LTEST_OK)
-else(PETSC_LIBRARIES)
- PRINT_WARNING("PETSC LIBRARIES NOT Found. Please check library path" "${PETSC_LIBRARY_DIR} ")
- message(STATUS "Looking for PETSc libraries... FAILED")
-endif(PETSC_LIBRARIES)
+set(PETSC_FOUND TRUE)
--- a/examples/ida/petsc/CMakeLists.txt
+++ b/examples/ida/petsc/CMakeLists.txt
@@ -19,8 +19,6 @@
# Examples using SUNDIALS linear solvers
SET(IDA_examples
- #"idaHeat2D_jac_petsc\;1\;4" # Not to be released in 2.7.0
- "idaHeat2D_kry_petsc\;1\;4\;develop"
)
IF(MPI_C_COMPILER)
--- a/examples/nvector/petsc/CMakeLists.txt
+++ b/examples/nvector/petsc/CMakeLists.txt
@@ -19,8 +19,6 @@
# Examples using SUNDIALS PETSc nvector
SET(nvector_petsc_examples
- "test_nvector_petsc\;1000 0\;\;\;" # run sequentially
- "test_nvector_petsc\;1000 0\;1\;4\;" # run 4 procs
)
# Dependencies for nvector examples

File diff suppressed because it is too large Load Diff