This commit is contained in:
Peter Vrabec 2008-07-04 14:13:33 +00:00
parent 05534ca1d2
commit f6d08872cc
3 changed files with 43 additions and 33 deletions

View File

@ -1,17 +1,19 @@
--- sudo-1.6.9p4/configure.in.getgrouplist 2007-08-20 11:41:32.000000000 +0200 diff -up sudo-1.6.9p17/configure.in.getgrouplist sudo-1.6.9p17/configure.in
+++ sudo-1.6.9p4/configure.in 2007-08-20 13:24:30.000000000 +0200 --- sudo-1.6.9p17/configure.in.getgrouplist 2008-07-04 16:07:42.000000000 +0200
@@ -1677,7 +1677,7 @@ +++ sudo-1.6.9p17/configure.in 2008-07-04 16:09:29.000000000 +0200
dnl @@ -1720,7 +1720,7 @@ dnl
AC_FUNC_GETGROUPS
AC_CHECK_FUNCS(strchr strrchr memchr memcpy memset sysconf tzset \ AC_CHECK_FUNCS(strchr strrchr memchr memcpy memset sysconf tzset \
strftime setrlimit initgroups getgroups fstat gettimeofday \ strftime setrlimit initgroups getgroups fstat gettimeofday \
- setlocale getaddrinfo) - setlocale getaddrinfo setsid)
+ setlocale getaddrinfo getgrouplist) + setlocale getaddrinfo setsid getgrouplist)
if test -z "$SKIP_SETRESUID"; then if test -z "$SKIP_SETRESUID"; then
AC_CHECK_FUNCS(setresuid, [SKIP_SETREUID=yes]) AC_CHECK_FUNCS(setresuid, [SKIP_SETREUID=yes])
fi fi
--- sudo-1.6.9p4/check.c.getgrouplist 2007-07-06 21:52:13.000000000 +0200 diff -up sudo-1.6.9p17/check.c.getgrouplist sudo-1.6.9p17/check.c
+++ sudo-1.6.9p4/check.c 2007-08-20 13:21:10.000000000 +0200 --- sudo-1.6.9p17/check.c.getgrouplist 2008-01-06 00:59:42.000000000 +0100
@@ -308,6 +308,24 @@ +++ sudo-1.6.9p17/check.c 2008-07-04 16:08:40.000000000 +0200
@@ -330,6 +330,24 @@ user_is_exempt()
return(TRUE); return(TRUE);
} }
@ -36,4 +38,3 @@
return(FALSE); return(FALSE);
} }

View File

@ -1,6 +1,7 @@
--- sudo-1.6.9p4/auth/pam.c.login 2007-07-22 14:14:53.000000000 +0200 diff -up sudo-1.6.9p17/auth/pam.c.login sudo-1.6.9p17/auth/pam.c
+++ sudo-1.6.9p4/auth/pam.c 2007-08-20 11:08:33.000000000 +0200 --- sudo-1.6.9p17/auth/pam.c.login 2008-02-22 21:19:45.000000000 +0100
@@ -89,7 +89,12 @@ +++ sudo-1.6.9p17/auth/pam.c 2008-07-04 15:34:17.000000000 +0200
@@ -98,7 +98,12 @@ pam_init(pw, promptp, auth)
if (auth != NULL) if (auth != NULL)
auth->data = (VOID *) &pam_status; auth->data = (VOID *) &pam_status;
pam_conv.conv = sudo_conv; pam_conv.conv = sudo_conv;
@ -14,9 +15,10 @@
if (pam_status != PAM_SUCCESS) { if (pam_status != PAM_SUCCESS) {
log_error(USE_ERRNO|NO_EXIT|NO_MAIL, "unable to initialize PAM"); log_error(USE_ERRNO|NO_EXIT|NO_MAIL, "unable to initialize PAM");
return(AUTH_FATAL); return(AUTH_FATAL);
--- sudo-1.6.9p4/env.c.login 2007-07-31 20:04:31.000000000 +0200 diff -up sudo-1.6.9p17/env.c.login sudo-1.6.9p17/env.c
+++ sudo-1.6.9p4/env.c 2007-08-20 11:24:48.000000000 +0200 --- sudo-1.6.9p17/env.c.login 2008-06-21 21:04:07.000000000 +0200
@@ -104,7 +104,7 @@ +++ sudo-1.6.9p17/env.c 2008-07-04 15:34:17.000000000 +0200
@@ -104,7 +104,7 @@ struct environment {
/* /*
* Prototypes * Prototypes
*/ */
@ -25,7 +27,7 @@
static void insert_env __P((char *, struct environment *, int)); static void insert_env __P((char *, struct environment *, int));
static char *format_env __P((char *, ...)); static char *format_env __P((char *, ...));
@@ -391,9 +391,8 @@ @@ -392,9 +392,8 @@ matches_env_keep(var)
* Also adds sudo-specific variables (SUDO_*). * Also adds sudo-specific variables (SUDO_*).
*/ */
char ** char **
@ -36,9 +38,10 @@
int noexec; int noexec;
{ {
char **ep, *cp, *ps1; char **ep, *cp, *ps1;
--- sudo-1.6.9p4/configure.in.login 2007-08-15 15:48:51.000000000 +0200 diff -up sudo-1.6.9p17/configure.in.login sudo-1.6.9p17/configure.in
+++ sudo-1.6.9p4/configure.in 2007-08-20 11:08:33.000000000 +0200 --- sudo-1.6.9p17/configure.in.login 2008-06-22 22:23:56.000000000 +0200
@@ -351,6 +351,17 @@ +++ sudo-1.6.9p17/configure.in 2008-07-04 15:34:17.000000000 +0200
@@ -366,6 +366,17 @@ AC_ARG_WITH(pam, [ --with-pam
;; ;;
esac]) esac])
@ -56,9 +59,10 @@
AC_ARG_WITH(AFS, [ --with-AFS enable AFS support], AC_ARG_WITH(AFS, [ --with-AFS enable AFS support],
[case $with_AFS in [case $with_AFS in
yes) AC_DEFINE(HAVE_AFS) yes) AC_DEFINE(HAVE_AFS)
--- sudo-1.6.9p4/sudo.h.login 2007-07-06 16:14:34.000000000 +0200 diff -up sudo-1.6.9p17/sudo.h.login sudo-1.6.9p17/sudo.h
+++ sudo-1.6.9p4/sudo.h 2007-08-20 11:33:45.000000000 +0200 --- sudo-1.6.9p17/sudo.h.login 2008-02-09 15:44:48.000000000 +0100
@@ -268,6 +268,7 @@ +++ sudo-1.6.9p17/sudo.h 2008-07-04 15:34:17.000000000 +0200
@@ -281,6 +281,7 @@ extern struct passwd *auth_pw;
extern FILE *sudoers_fp; extern FILE *sudoers_fp;
extern int tgetpass_flags; extern int tgetpass_flags;
extern uid_t timestamp_uid; extern uid_t timestamp_uid;
@ -66,9 +70,10 @@
#endif #endif
#ifndef errno #ifndef errno
extern int errno; extern int errno;
--- sudo-1.6.9p4/sudo.c.login 2007-08-15 15:48:56.000000000 +0200 diff -up sudo-1.6.9p17/sudo.c.login sudo-1.6.9p17/sudo.c
+++ sudo-1.6.9p4/sudo.c 2007-08-20 11:34:07.000000000 +0200 --- sudo-1.6.9p17/sudo.c.login 2008-06-21 21:04:07.000000000 +0200
@@ -122,7 +122,7 @@ +++ sudo-1.6.9p17/sudo.c 2008-07-04 16:01:43.000000000 +0200
@@ -125,7 +125,7 @@ static void usage_excl __P((int));
static struct passwd *get_authpw __P((void)); static struct passwd *get_authpw __P((void));
extern int sudo_edit __P((int, char **, char **)); extern int sudo_edit __P((int, char **, char **));
extern void list_matches __P((void)); extern void list_matches __P((void));
@ -77,15 +82,16 @@
extern void validate_env_vars __P((struct list_member *)); extern void validate_env_vars __P((struct list_member *));
extern char **insert_env_vars __P((char **, struct list_member *)); extern char **insert_env_vars __P((char **, struct list_member *));
extern struct passwd *sudo_getpwnam __P((const char *)); extern struct passwd *sudo_getpwnam __P((const char *));
@@ -153,6 +153,7 @@ @@ -156,7 +156,7 @@ login_cap_t *lc;
char *login_style; char *login_style;
#endif /* HAVE_BSD_AUTH_H */ #endif /* HAVE_BSD_AUTH_H */
sigaction_t saved_sa_int, saved_sa_quit, saved_sa_tstp, saved_sa_chld; sigaction_t saved_sa_int, saved_sa_quit, saved_sa_tstp;
-
+int sudo_mode; +int sudo_mode;
int int
@@ -164,7 +165,6 @@ main(argc, argv, envp)
@@ -167,7 +167,6 @@ main(argc, argv, envp)
int validated; int validated;
int fd; int fd;
int cmnd_status; int cmnd_status;
@ -93,7 +99,7 @@
int pwflag; int pwflag;
sigaction_t sa; sigaction_t sa;
extern int printmatches; extern int printmatches;
@@ -347,7 +347,7 @@ @@ -345,7 +344,7 @@ main(argc, argv, envp)
def_env_reset = FALSE; def_env_reset = FALSE;
/* Build a new environment that avoids any nasty bits. */ /* Build a new environment that avoids any nasty bits. */

View File

@ -1,7 +1,7 @@
Summary: Allows restricted root access for specified users Summary: Allows restricted root access for specified users
Name: sudo Name: sudo
Version: 1.6.9p13 Version: 1.6.9p17
Release: 7%{?dist} Release: 1%{?dist}
License: BSD License: BSD
Group: Applications/System Group: Applications/System
URL: http://www.courtesan.com/sudo/ URL: http://www.courtesan.com/sudo/
@ -133,6 +133,9 @@ rm -rf $RPM_BUILD_ROOT
/bin/chmod 0440 /etc/sudoers || : /bin/chmod 0440 /etc/sudoers || :
%changelog %changelog
* Fri Jul 04 2008 Peter Vrabec <pvrabec@redhat.com> 1.6.9p17-1
- upgrade
* Wed Jun 18 2008 Peter Vrabec <pvrabec@redhat.com> 1.6.9p13-7 * Wed Jun 18 2008 Peter Vrabec <pvrabec@redhat.com> 1.6.9p13-7
- build with newer autoconf-2.62 (#449614) - build with newer autoconf-2.62 (#449614)